Sintomi
Microsoft SoftGrid Client tenta di avviare un'applicazione. Tuttavia, il tentativo non è riuscito e viene visualizzato un messaggio di errore analogo al seguente:
Il SoftGrid Client Impossibile avviare < nome_applicazione >.
Il pacchetto richiesto non trovato nell'archivio dati di sistema o i file associati a questo pacchetto non trovati sul server. Segnalare il seguente codice di errore all'amministratore del sistema.
Codice di errore: xxxxxx-xxxxxx0A-20000194
Una voce simile al seguente può essere visualizzato nel file di registro SoftGrid Client (Sftlog.txt):
Una voce simile al seguente può essere visualizzato nel file di registro SoftGrid Virtual Application Server (Sft-server):
Causa
Questo comportamento può verificarsi se uno o più delle seguenti condizioni sono vere:
-
Si sta tentando di avviare un'applicazione abilitata SoftGrid che non è stato aggiunto alla Console di gestione di SoftGrid.
-
Il file. sft specificato nel file OSD non esiste all'interno della struttura di directory del contenuto.
-
Il percorso o il nome del file SFT specificato nella voce del Percorso relativo del File Softricity è valido.
-
Il criterio di Provider specificato nel file OSD non esiste.
Risoluzione
Le informazioni seguenti vengono fornite le soluzioni per ciascuna causa menzionato nella sezione "Cause".
-
Si sta tentando di avviare un'applicazione abilitata SoftGrid che non è stato aggiunto alla Console di gestione di SoftGrid
Esistono due condizioni in cui è possibile tentare di avviare un'applicazione abilitata SoftGrid che non è stato aggiunto alla Console di gestione di SoftGrid:-
Si fa doppio clic il file OSD di un'applicazione abilitata SoftGrid.
-
Facendo doppio clic sul collegamento di un'applicazione abilitata SoftGrid che è stata rimossa dalla gestione di SoftGrid Client.
Nota: Il collegamento non viene rimosso quando l'applicazione SoftGrid viene rimosso dalla gestione di SoftGrid Client. Il collegamento non viene rimosso se copiare manualmente il collegamento in una posizione alternativa quando l'applicazione viene aggiunta alla gestione di SoftGrid Client. Quando l'applicazione viene rimossa, SoftGrid Client Management non è a conoscenza della posizione alternativa e il collegamento non viene rimosso.
-
-
Il file. sft specificato nel file OSD non esiste all'interno della struttura di directory del contenuto
Il file. sft non esiste all'interno della struttura di directory del contenuto. Questo file. SFT viene specificato nell'attributo HREF dell'elemento CODEBASE del file OSD.
Si consideri il seguente scenario. Il file OSD è configurato come illustrato di seguito:HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft"La directory del contenuto è configurata come il percorso di esempio seguente:
C:\Program Files\Softricity\SoftGrid Server\contentIn questo scenario, Microsoft SoftGrid Impossibile avviare l'applicazione se non esiste il file sft_ea70.v1.sft nella sottodirectory Softricity nel percorso della directory del contenuto seguente:
C:\Program Files\Softricity\SoftGrid Server\content\Softricity.
-
Il percorso o il nome del file SFT specificato nel "Softricity relativo percorso" non è valido
Il Percorso relativo del File Softricity deve contenere solo la sottodirectory della directory del contenuto e il nome del file SFT. Ad esempio, il nome del file SFT è example.sft ed esiste all'interno di Applicazioni di esempio sottodirectory della directory del contenuto. Se la directory del contenuto è C:\Program Files\Softricity\SoftGrid \Programmi\Softricity\SoftGrid, il Percorso relativo del File Softricity è Applications\example.sft di esempio. Se la directory del contenuto è \\SERVERNAME\content, il Percorso relativo del File Softricity è ancora Applications\example.sft di esempio.
Per verificare che il percorso relativo contiene solo la sottodirectory della directory del contenuto e il nome del file SFT, attenersi alla seguente procedura: procedura:-
Da strumenti di amministrazione avviare Console di gestione di SoftGrid.
-
Espandere Sistemi SoftGrid< nome_server > pacchetti < versione del pacchetto dell'applicazione che non si avvia > .
-
Fare doppio clic sulla versione del pacchetto dell'applicazione che non si avvia.
-
Verificare che il Percorso relativo del File Softricity contenga solo la sottodirectory della directory del contenuto e il nome del file SFT.
-
-
Il criterio di Provider specificato nel file OSD non esiste
Il criterio di Provider che ?Customer = specifica non esiste. Questo criterio di Provider viene specificato nell'attributo HREF dell'elemento CODEBASE del file OSD
Si consideri il seguente scenario. L'ambiente di SoftGrid dispone di più Provider di criteri, ad esempio il Provider predefinito e un criterio di Provider personalizzato denominato anonimo. Inoltre, è necessario configurare un file OSD per utilizzare il criterio di Provider anonimo. In questo scenario, il. Attributo HREF dell'elemento CODEBASE del file OSD deve apparire come nell'esempio seguente.HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft?Customer=Anonymous"Nota: Se il nome del criterio di Provider che segue ?Customer = non esiste, Microsoft SoftGrid Impossibile avviare l'applicazione.
Per ulteriori informazioni sulle condizioni di utilizzo, visitare il seguente sito Web Microsoft: