Viene chiesto di salvare le modifiche al modello generale Normal. dot o Normal. dotm ogni volta che si chiude Word

Riepilogo

Quando si chiude Word, potrebbe essere richiesto di salvare sempre le modifiche al modello Normal. dot. o Normal. dotm prima, è possibile disattivare il prompt dei comandi e Word salva automaticamente le modifiche, ma potrebbe essere un problema. In secondo luogo, il modello Normal. dot o Normal. dotm potrebbe essere infettato da un virus macro. Per risolvere questo problema, è necessario installare o aggiornare il software antivirus nel computer in uso. In terzo luogo, è possibile che un componente aggiuntivo che causa il problema. Per risolvere questo problema, è necessario determinare quale componente aggiuntivo causa il problema e rimuoverlo dalle cartelle di avvio di Office o Word.

Sintomi

Ogni volta che si chiude Word, viene visualizzato il seguente messaggio:

Sono state apportate modifiche che influenzano il modello generale Normal. dot. Si desidera salvare le modifiche apportate?

Causa

Questo problema può verificarsi per i seguenti motivi.

Causa 1: Il "Richiedi salvataggio modello Normal" casella di controllo

Questo messaggio viene visualizzato se è selezionata la casella di controllo Richiedi salvataggio modello Normal .

Soluzione alternativa

Per disattivare questo messaggio, attenersi alla seguente procedura.

Importante Se si disattiva il messaggio in Word, potrebbe essere un problema. Word salverà automaticamente le modifiche nel modello Normal. dot o Normal. dotm, ma non verrà richiesto. Comunque è necessario eseguire la procedura descritta in questo articolo.

Se si utilizza Microsoft Office Word 2003 o una versione precedente di Word:

  1. Scegliere Opzioni dal menu Strumenti.

    alternate text

  2. Nella scheda Salva , fare clic per deselezionare la casella di controllo Richiedi salvataggio modello Normal .

    alternate text

Se si utilizza Microsoft Office Word 2007:

  1. Nell'angolo superiore sinistro dello schermo, fare clic sul pulsante di Office .

  2. Nell'area in basso a destra della casella di riepilogo a discesa, fare clic su Opzioni di Word.

  3. Nella pagina Opzioni di Word, fare clic su Avanzate nel menu a sinistra.

  4. Utilizzare la barra di scorrimento per scorrere fino alla sezione Salva .

  5. Nella sezione salvare , fare clic per deselezionare la casella di controllo Richiedi salvataggio modello Normal .

Causa 2: Un componente aggiuntivo installato o una macro installata viene modificato il modello globale Normal. dot o Normal. dotm

Venga visualizzato il messaggio che è elencato nella sezione "Sintomi", se un componente aggiuntivo o una macro sul computer modificato il modello Normal. dot o Normal. dotm. Componenti aggiuntivi che notoriamente causano questo problema sono i seguenti:

  • Postage Stamps.com Internet

  • Componente aggiuntivo di Works Suite per Microsoft Word

Un componente aggiuntivo installato in Word può aggiungere uno o più dei seguenti elementi al computer:

  • File WLL

  • Modelli

  • Componente aggiuntivo COM

  • Macro automatiche

Soluzione alternativa

Rimozione di componenti aggiuntivi WLL e modelli nelle cartelle di avvio di Office e Word

Quando si avvia Word, vengono caricati automaticamente modelli e componenti aggiuntivi che si trovano nelle cartelle di avvio. Problemi in Word potrebbero essere il risultato di conflitti o di problemi con un componente aggiuntivo. Per determinare se il problema è causato da un elemento in una cartella di avvio, svuotare temporaneamente la cartella.

Gli elementi di Word vengono caricati dalla cartella Startup di Office e la cartella Startup di Word. Per rimuovere elementi dalle cartelle esecuzione automatica, attenersi alla seguente procedura:

  1. Chiudere tutte le istanze di Word. Se si utilizza Word come editor di posta elettronica, assicurarsi di chiudere anche Outlook.

  2. Sul desktop di Windows, fare doppio clic su Risorse del Computere quindi individuare la cartella Startup di Office. Il percorso predefinito è:

    C:\Program Files\Microsoft Office\Office\Startup Nota: Per Office 2000 e versioni precedenti, la cartella di Office è Office. Per Office XP, la cartella di Office è Office10. Per Office 2003, la cartella di Office è Office11.

  3. Trascinare ciascun elemento dalla cartella di avvio sul desktop. (O creare una cartella sul desktop e trascinare tutti gli elementi in questa nuova cartella.)


    Nota: Per creare una nuova cartella sul desktop, fare un'area vuota del desktop, scegliere Nuovoe quindi fare clic su cartella.

  4. Individuare la cartella Startup di Word e quindi trascinare ciascun elemento dalla cartella di avvio sul desktop. (O creare una cartella sul desktop e trascinare tutti gli elementi in questa nuova cartella.) Il percorso predefinito della cartella Startup di Word dipende dal sistema operativo.


    In Microsoft Windows 98 e Windows Millennium Edition senza profili attivati, il percorso è:

    C:\Windows\Application Data\Microsoft\Word\StartupIn Windows 98 e Windows Me con profili abilitati o in Windows NT 4.0, il percorso è:

    C:\Windows\user name\Application Data\Microsoft\Word\StartupIn Windows 2000, Windows XP e Windows Server 2003, il percorso è:

    C:\Documents and Settings \ \Application Data\Microsoft\Word\Startupnome utente

  5. Avviare Word.

    Se non è possibile riprodurre il problema e si rimossi più elementi dalla cartella di avvio o cartelle, è possibile provare a isolare il problema ripristinando i file nella cartella di avvio appropriata, uno alla volta. Provare a riprodurre il problema dopo ogni aggiunta per determinare quale file causa il problema.

Rimozione di componenti aggiuntivi COM

Componenti aggiuntivi COM possono essere installati in qualsiasi posizione. Componenti aggiuntivi COM sono installati da programmi che interagiscono con Word. Per visualizzare l'elenco dei componenti aggiuntivi COM installati, attenersi alla seguente procedura:

Se si utilizza Word 2003 o una versione precedente di Word:

  1. Dal menu Strumenti , fare clic su Personalizza.

    alternate text

  2. Fare clic sulla scheda comandi .

    alternate text

  3. Nella scheda comandi , fare clic su Strumenti nell'elenco categorie .

    alternate text

  4. Utilizzare il mouse per trascinare il comando componenti aggiuntivi COM su una barra degli strumenti.

    alternate text

  5. Fare clic su Chiudi per chiudere la finestra di dialogo Personalizza .

    alternate text

  6. Fare clic sul nuovo pulsante di Componenti aggiuntivi COM per visualizzare i componenti aggiuntivi COM caricati con Word.

    alternate text

Se nella finestra di dialogo Componenti aggiuntivi COM sono elencati i componenti aggiuntivi, disattivarli temporaneamente dei componenti aggiuntivi. A tale scopo, fare clic per deselezionare la casella di controllo per ogni componente aggiuntivo COM elencato e quindi fare clic su OK. Quando si riavvia Word, Word viene avviato senza caricare i componenti aggiuntivi COM è disattivata.

Se il problema viene risolto dopo la disattivazione di componenti aggiuntivi COM, fra i componenti aggiuntivi COM elencati è la causa del problema. Se si dispongono di più componenti aggiuntivi elencati, si consiglia di determinare quale di essi causa il problema specifico. A tale proposito, riattivare i componenti aggiuntivi COM uno alla volta e quindi riavviare Word.

Se si utilizza Word 2007:

  1. Nell'angolo superiore sinistro dello schermo, fare clic sul pulsante di Office .

  2. Nell'area in basso a destra della casella di riepilogo a discesa, fare clic su Opzioni di Word.

  3. Nella pagina Opzioni Word scegliere componenti aggiuntivi dal menu a sinistra.

  4. Nella parte inferiore della pagina, selezionare componenti aggiuntivi COM di gestione: discesa elenco e quindi fare clic su Vai.

    Nota: Se nella finestra di dialogo Componenti aggiuntivi COM sono elencati i componenti aggiuntivi, disattivare temporaneamente ogni componente aggiuntivo. A tale scopo, fare clic per deselezionare la casella di controllo per ogni componente aggiuntivo COM elencato. Quindi, fare clic su OK. Quando si riavvia Word, Word viene avviato senza caricare i componenti aggiuntivi COM è disattivata.

    Se il problema viene risolto dopo la disattivazione di componenti aggiuntivi COM, uno dei componenti aggiuntivi COM è la causa del problema. Se si dispongono di più componenti aggiuntivi elencati, si consiglia di determinare quale di essi causa il problema specifico. A tale proposito, riattivare i componenti aggiuntivi COM uno alla volta e quindi riavviare Word.

Rimozione di macro automatiche di Word

Alcune macro sono definite le macro "auto". Vengono eseguite automaticamente all'avvio di Word. Nella tabella seguente sono elencate queste macro automatiche. Per avviare Microsoft Word senza eseguire le macro automatiche, tenere premuto MAIUSC mentre si avvia Word. A tale scopo, fare clic su Start, scegliere programmi, quindi tenere premuto MAIUSC e fare clic su Microsoft Word.

Macro

Percorso di archiviazione

Viene eseguito automaticamente

AutoExec

Nel modello Normal o in un componente aggiuntivo globale

Quando si avvia Word

AutoNew

In un modello

Quando viene creato un nuovo documento basato sul modello

AutoOpen

Nel documento o modello

Quando un documento basato sul modello o che contiene la macro è aperta

AutoClose

Nel documento o modello

Quando un documento basato sul modello o che contiene la macro è chiuso

AutoExit

Nel modello Normal o un componente aggiuntivo globale

Quando si chiude Word

Word le macro con un nome che inizia con "Auto" vengono riconosciute come macro eseguite automaticamente quando si verifica la situazione a cui viene applicata. È possibile impedire temporaneamente l'esecuzione di una macro automatica tenendo premuto MAIUSC durante l'esecuzione dell'azione che causa l'esecuzione della macro. Ad esempio, per impedire l'esecuzione di una macro AutoOpen, tenete premuto MAIUSC mentre si apre un documento o un modello.

Se il problema viene risolto tenendo premuto il tasto MAIUSC quando si avvia Word o quando si esegue un'azione in Word apre un documento, una macro automatica è il problema. Per risolvere questo problema, attenersi alla seguente procedura:

Se si utilizza Word 2003 o una versione precedente di Word:

  1. Fare clic su Start e quindi fare clic su Esegui.

    alternate text

  2. Nella casella Apri , digitare winworde quindi fare clic su OK.

    alternate text

  3. Scegliere Macrodal menu Strumenti e quindi fare clic su macro.

    alternate text

  4. Nella finestra di dialogo macro , potrebbe apparire un elenco di macro. Se sono presenti macro che inizia con "Auto", si consiglia di rimuovere la macro. Per rimuovere una macro automatica, fare clic sulla macro e quindi fare clic su
    Eliminare.

    alternate text

    Nota: Una macro automatica può essere stati aggiunti da un componente aggiuntivo di Word. Per determinare il modello che contiene la macro automatica, modificare le macro in
    casella per un modello elencato. Dopo aver determinato il modello che contiene la macro automatica, si consiglia di rimuovere tale modello dal computer. Rimozione di un modello che è stato aggiunto un componente aggiuntivo di Word può ridurre o interrompere la funzionalità del componente.

  5. Fare clic su Annulla o fare clic su Chiudi per chiudere la finestra di dialogo macro .

  6. Dal menu File , fare clic su Esci per uscire da Microsoft Word.

    alternate text

Se il problema viene risolto dopo il riavvio di Word, la macro automatica era il problema.


Se si utilizza Word 2007:

  1. Nell'angolo superiore sinistro dello schermo, fare clic sul pulsante di Office .

  2. Nell'area in basso a destra della casella di riepilogo a discesa, fare clic su Opzioni di Word.

  3. Nella pagina Opzioni di Word, fare clic su Impostazioni generali nel menu a sinistra.

  4. Nella sezione Opzioni principali per l'utilizzo di Word , fare clic per selezionare la casella di controllo Mostra scheda Sviluppo sulla barra multifunzione e quindi fare clic su OK.

  5. Nella parte superiore della finestra di Word, fare clic sulla scheda sviluppatore .

  6. Nella scheda Developer , fare clic su macro nel gruppo di codice .

    Nella finestra di dialogo macro , potrebbe apparire un elenco di macro. Se tutte le macro elencate inizia con "Auto", si consiglia di rimuovere la macro. Per rimuovere una macro automatica, fare clic sulla macro e quindi fare clic su
    Eliminare.

    Nota: Una macro automatica può essere stati aggiunti da un componente aggiuntivo di Word. Per determinare il modello che contiene la macro automatica, modificare le macro in
    casella per un modello elencato. Dopo aver determinato il modello che contiene la macro automatica, si consiglia di rimuovere tale modello dal computer. Rimozione di un modello che è stato aggiunto un componente aggiuntivo di Word può ridurre o interrompere la funzionalità del componente.

Causa 3: Word è infetto da un virus macro

Questo problema può verificarsi se il computer è infettato da un virus che ha modificato il modello globale (Normal. dot o Normal. dotm). Per evitare infezioni da virus, mantenere il software antivirus e i virus le definizioni aggiornate con le versioni più recenti. Chiedete al vostro fornitore di software antivirus per informazioni aggiornate.

Per informazioni su come contattare il fornitore del software antivirus, fare clic sul numero dell'articolo appropriato nell'elenco seguente per visualizzare l'articolo della Microsoft Knowledge Base:

65416 hardware e software recapiti, A-K

60781 hardware e software recapiti, L-P

60782 hardware e software recapiti, Q-Z Per ulteriori informazioni, fare clic sui numeri seguenti per visualizzare gli articoli della Microsoft Knowledge Base:

233396 come ridurre le possibilità di infezione da virus macro

211607 domande frequenti sui virus macro in Word
 
 

Riferimenti

I prodotti di terze parti descritti in questo articolo sono forniti da società indipendenti da Microsoft. Microsoft esclude ogni garanzia, implicita o esplicita, relativamente alle prestazioni o all'affidabilità di questi prodotti.

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

×