Excel のデータのインポートと分析のオプション

適用先
Excel for Microsoft 365 Excel 2024 Excel 2021

[データ オプション] ダイアログ ボックスで、ピボットテーブルの既定値、データ モデルの動作、アドイン、パフォーマンス設定、従来のインポート ウィザードへのアクセスなど、Excel のデータ インポートおよび分析オプションを変更します。

データのニーズに合わせて、インポートおよび分析中に Excel が受け取ったデータ (数値、日付、形式など) を自動的に変換する方法も制御できます。

これらのオプションを見つけるには、[ ファイル>オプション>データ] を選択します。

データ オプション

  • ピボットテーブルの既定のレイアウトを変更する
    新しいピボットテーブル用に、複数の 既定のレイアウト オプション から選ぶことができます。 たとえば、常にコンパクトではなく表形式で新しいピボットテーブルを作成することを選択するか、更新時に列幅の自動調整をオフにします。
  • 大規模なピボットテーブル更新操作の元に戻しを無効にして更新時間を短縮する
    元に戻す機能を無効にする場合は、無効にするタイミングのしきい値として行数を選択します。 既定値は 300,000 行です。
  • ピボットテーブル、クエリ テーブル、データ接続を作成するときに Excel データ モデルを優先する
    データ モデルは複数のテーブルのデータを統合し、Excel ブック内にリレーショナル データ ソースを効率的に構築します。
  • 大規模なデータ モデル操作の元に戻すことを無効にします。
    元に戻す機能を無効にする場合は、無効にするタイミングのしきい値としてファイル サイズの MB 単位を選択します。 既定値は 8 MB です。
  • データ分析アドインを有効にする: Power Pivot、Power View、および 3D Maps。
    [アドイン] タブではなく、ここでデータ分析アドインを有効にします。
  • ピボットテーブルの日付/時刻列の自動グループ化を無効にします。
    既定では、日付と時刻の列は、横に + 記号が付いてグループ化されます。 この設定では、その既定値を無効にします。

レガシ データのインポート ウィザードを表示する

リボンの [データ] タブから利用できる Power Query は、従来のデータ インポート ウィザードと比較して、最新のデータ コネクタと変換機能を提供します。 ただし、これらのウィザードのいずれかを使用してデータをインポートしたい場合もあります。 たとえば、データ ソース認証の資格情報をブックの一部として保存する場合などです。

セキュリティ 資格情報を保存することはお勧めできません。セキュリティとプライバシーの問題、またはデータの侵害につながる可能性があります。

注

Web (レガシ) データ インポート ウィザードは非推奨です。 新しい Web クエリには、Power Query Web コネクタを使用します。 古い Web クエリを Power Query に移動するには、「古い Web クエリを Power Query に移動する」を参照してください。

レガシ データ インポート ウィザードを有効にする

  1. [ファイル] を選択します>オプション>データ。

  2. 1 つ以上のウィザードを選択して、Excel リボンからのアクセスを有効にします。

    • Access (レガシ)
    • Web (レガシ) (非推奨)
    • テキスト (レガシ)
    • SQL Server (レガシ)
    • OData データ フィード (レガシ)
    • XML データのインポート (レガシ)
    • データ接続ウィザード (レガシ)
    • Microsoft Query (レガシ)
  3. ブックを閉じてからもう一度開き、アクティブ化されたウィザードを表示します。

  4. [ データ>データの取得>従来のウィザード] を選択し、目的のウィザードを選択します。

    Get & Transform Legacy メニュー オプション

ウィザードを無効にするには、手順 1 から 3 を繰り返し、手順 2 で説明したチェック ボックスをオフにします。

自動データ変換

テキストを Excel に入力、貼り付け、または読み込むときに、すべての既定のデータ変換を有効にします。 このチェック ボックスをオフにすると、選択を解除して、次のオプションの 1 つ以上が選択されます。

  • 先頭のゼロを削除して数値に変換する このオプションを無効にすると、数値に変換されて先頭のゼロを失うのではなく、先頭のゼロが文字列として格納され、先頭のゼロが保持されます。 たとえば、 00123 はテキスト内では 00123 のままであり、 数値 123 には変換されません。
  • 長い数値の最初の 15 桁を保持し、指数形式で表示 するこのオプションをオフにすると、最初の 15 桁のみを保持して指数形式で表示される可能性のある数値に変換するのではなく、16 桁以上の数値データをテキストとして保存し、すべての数字を保持します。 たとえば、 12345678901234567890 はテキスト内では 12345678901234567890 のままであり、数値 12345678901234500000 に変換されたり、指数表記で 1.23457E+19 として表示されたりすることはありません。
  • 文字 "E" を囲む数字を指数形式の数値に変換 するこのチェック ボックスをオフにすると、文字 "E" を囲む数値データが指数表記の数値に変換されるのではなく、テキストとして格納されます。 たとえば、 123E5 はテキストでは 123E5 のままであり、指数表記では数値 1.23E+07 に変換されません。
  • 連続文字と数字を日付に変換する このチェック ボックスをオフにすると、日付に変換されるのではなく、文字と数字が連続する "日付に似た" 値が文字列として格納されます。 たとえば、JAN1 はテキスト内では JAN1 のままであり、1 月 1 日の日付には変換されません。 JAN 1 や JAN-1 のように、スペースやその他の文字を含むデータは、引き続き日付として扱われる場合があります。

その他のオプション

.csv ファイルまたは同様のファイルを読み込むときに、データが自動変換されたことを通知 するこのオプションを無効にすると、どのデータ変換が発生するかを示すダイアログ ボックスの表示が停止します。 既定では、ダイアログ ボックスが表示されます。 ただし、前述のオプションをすべて無効にした場合、ダイアログ ボックスも表示されません。

関連項目