Excel でデータを消去する

適用先
Excel for Microsoft 365 Excel 2021

注

このバージョンのデータのクリーンアップは、Excel for the web と Windows にあり、Copilot のお客様が利用できます。 Microsoft は段階的に利用できるようにしており、一部の国や地域ではまだ利用できない場合があります。

Excel の AI ベースのデータのクリーンアップ機能を使用すると、ボタンを押すだけでデータをクリーンアップできます。 一貫性のないテキストの問題、一貫性のない表示形式の問題、および余分なスペースの 3 種類の提案が提供されます。

これらの機能のいずれかを使用するには、リボンの [データ] タブで [データの消去] メニュー項目を選択します。

同じ値のセル内の一貫性のないテキスト

この機能は、問題の原因となる可能性のある同じ値間のバリエーションを識別します。 たとえば、次のような状況では、間違った集計が発生する可能性があります。

  • セルに大文字と小文字のテキストが混在している列。 
  • 句読点や分音記号の違いが含まれる列内のセル。

データの消去機能を使用すると、このようなインスタンスを簡単に修正できます。

一貫性のないテキストの提案カードを示すスクリーンショット。

列内の一貫性のない数値の表示形式

この機能は、誤った計算につながる可能性があるテキストと数値の両方の形式のセルが混在している列を識別します。 データの消去では、このような矛盾が特定され、'テキスト' 形式のセルを数値形式に変換するのに役立ちます。

一貫性のない数値形式の提案カードを示すスクリーンショット。

余分なスペースの削除に関する提案

この特定のデータのクリーンアップ機能は、余分な先頭スペース、末尾のスペース、値の間のスペースなど、検査対象のテーブル内の不要なスペースの削除を検出し、提案します。

余分なスペースの提案カードを示すスクリーンショット。

値の間の余分なスペースの例を示すスクリーンショット。

実用的なヒント

データの消去を最大限に活用するのに役立ついくつかのポイントを次に示します。

  • データのクリーンアップは、最大 100 列、最大 50,000 行の表形式データに最適です。
  • データの消去は、Excel の表として書式設定されたデータで最もうまく動作します。 Excel テーブルを作成するには、データ内の任意の場所に移動し、[ ホーム] > [スタイル] > [テーブルとして書式設定] を選択します。
  • Clean Data は英語に限定されませんが、最初は英語で最高のパフォーマンスを発揮します。

機能とフィードバック

この記事では、最初のリリースについて説明します。 チームは常にクリーン データを改善しています。 期待どおりに動作しない可能性があります。 期待通りのデータのクリーンアップの提案が得られない場合、不正確な提案が得られない場合、または何らかのフィードバックがある場合は、[ ファイル > フィードバック ] に移動するか、サイド ウィンドウの右下にある [データのクリーンアップに関する ご意見 ] を選択して、チームに連絡してください。