Word ドキュメントに Excel グラフを挿入する
Excel スプレッドシートから Word ドキュメントにグラフを挿入する最も簡単な方法は、コピー アンド ペースト コマンドを使用することです。
グラフの変更、更新、再設計は、Word を離れることなく行うことができます。 Excel でデータを変更すると、Word でグラフが自動的に更新されます。
Excel でグラフを選択し、Ctrl + C を押すか、[ ホーム>コピー] に移動します。
Word文書でグラフを表示する場所をクリックまたはタップし、Ctrl+V を押すか、[ホーム>ペースト] に移動します。
注
グラフは元の Excel スプレッドシートにリンクされます。 スプレッドシートの中のデータが変化した場合は、グラフが自動的に更新されます。
グラフを更新する
- Word でグラフを選択します。
- [グラフ デザイン] または [グラフ ツール] の順に移動する Design>Data>Refresh Data。
Word でグラフのデザインやデータを変更できます。
注
図として挿入されたグラフを編集することはできませんが、調整することはできます。 グラフを選択し、[ 図の書式設定] または [ 図ツールの書式] でオプションを選択します。
Word でグラフを編集する
グラフを選択します。
[グラフ デザイン] または [グラフ ツール] [デザイン]>[データ>編集] の順に移動し、次のいずれかを選びます。
- [データの編集] を選択して、Word でグラフを編集します。
- [Excel でのデータの編集] を選びます。
グラフの選択時に表示される 4 つのボタンのいずれかを使用して、Word のグラフを変更することもできます。
次のボタンがあります。
-
レイアウト オプション
オブジェクトが周囲のテキストとどのように相互作用するかを選択します。 -
グラフ要素
タイトル、凡例、枠線、データ ラベルなどのグラフ要素を追加、削除、または変更します。 -
グラフ スタイル
グラフのスタイルと配色を設定します。 -
グラフ フィルター
グラフに表示するデータ ポイントと名前を編集します。
任意のボタンを選択して、使用可能なオプションを表示します。
Excel グラフを挿入するその他の方法
Excel グラフを Word に貼り付けるには、5 つのオプションがあります。 そのうち 2 つのオプションでは、ブック全体のコピーが埋め込まれ、別の 2 つでは埋め込むのではなくグラフを元のブックにリンクした状態のままになり、最後の 1 つではグラフが画像に変換されます。 これらのオプションがどれも目的とおりに動作しない場合は、[ 形式を選択して貼り付け] を選択することもできます。
Excel から
- Excel で、Wordに貼り付けるグラフを選択し、Ctrl + C キーを押すか、[ホーム>コピー] に移動します。
Word
- Word で、[ホーム] を選択し、[貼り付け] リストで、5 つの貼り付けオプションのいずれかを選択します。
注
オプションの説明を表示するには、ボタンをポイントします。
| 貼り付けのオプション | 配色テーマ | データの更新 |
|---|---|---|
| ブックを埋め込む & 貼り付け先のテーマを使用 | Word のテーマに合わせる | Excel ブックのコピーをグラフと共に埋め込みます。 グラフは元のブックとはリンクされません。 グラフを自動的に更新するには、埋め込まれたブックのデータを変更します。 |
| ブックの埋め込み & 元の書式設定を保持する | Excel のテーマのままにする | Excel ブックのコピーをグラフと共に埋め込みます。 グラフは元のブックとはリンクされません。 グラフを自動的に更新するには、埋め込まれたブックのデータを変更します。 |
|
リンク先のテーマを使用 & データのリンク これが既定の貼り付けオプションです (Ctrl + V)。 |
Word のテーマに合わせる | グラフを元のブックにリンクさせた状態のままにします。 グラフを自動的に更新するには、元のブックのデータを変更します。 [グラフ ツール]>[デザイン]>[データの更新] を選択することもできます。 |
| リンク データ & 元の書式を保持 | Excel のテーマのままにする | グラフを元のブックにリンクさせた状態のままにします。 グラフを自動的に更新するには、元のブックのデータを変更します。 [グラフ ツール]>[デザイン]>[データの更新] を選択することもできます。 |
| 図 | 画像になる | データの更新やグラフの編集はできませんが、グラフの外観を調整することはできます。 [ 図ツール] で、[ 書式] を選択します。 |
Word で Excel ワークシートをリンクまたは埋め込む
リンク オブジェクトと埋め込みオブジェクトの主な違いは、データが保存されている場所と、Word 文書に挿入された後にデータを更新する方法です。
-
リンク オブジェクト
Word でリンクされたオブジェクトの情報はソース ファイルに保存され、ソース ファイルが変更された場合は更新できます。 ファイル サイズを考慮する必要がある場合は、リンク オブジェクトを使います。 -
埋め込みオブジェクト
Word に埋め込んだ Excel オブジェクトの情報は、元の Excel ファイルを変更しても変更されません。 埋め込まれた後のオブジェクトはソース ファイルの一部ではなくなり、ソース ファイルに対する変更は反映されません。
[ 挿入>テキスト>オブジェクト] に移動します。
[ファイルから作成>参照] に移動し、Word ドキュメントに挿入するファイルを見つけます。
次のいずれかのオプションを選びます。
- ファイルをリンク オブジェクトとして追加するには、[ ファイルにリンク]、[ OK] の順に選択します。
- ファイルを埋め込みオブジェクトとして追加するには、[ アイコンで表示] を選択し、[ OK] を選択します。