リンクされたデータ型の FAQ とヒント

適用先
Excel for Microsoft 365 Excel for Microsoft 365 for Mac Excel 2024 Excel 2024 for Mac Excel 2021 Excel 2021 for Mac

リンクされたデータ型でできることはたくさんあります。 数式で接続されたデータ型を参照する場合や、単に制限事項の一部について学習する場合にかかわらず、Excel のデータ型を最大限に活用する方法の詳細については、以下のコンテンツチェックしてください。

よく寄せられる質問

リンクされたデータ型にアクセスする方法 要件は何ですか?

注

リンクされたデータ型は、世界中のマルチテナント クライアント (標準の Microsoft 365 アカウント) でのみ使用できます。

Bing などの外部データ ソースにリンクするデータ型にアクセスするには、以下の要件を満たす必要があります。 現在使用可能なデータ型を確認するには、「Excel で使用できるリンクされたデータ型は何ですか?」を参照してください。 

株価および地理データ型の場合

  • アクティブな Microsoft 365 サブスクリプション または無料の Microsoft アカウントを持っていること。

  • 英語、フランス語、ドイツ語、イタリア語、スペイン語、ポルトガル語の編集言語を Office の言語設定に追加します。 他の言語は最終的に追加される可能性があります。

  • 最新の Excel アプリまたは Excel for the web を使用します。

    注

    Microsoft 365 サブスクリプションをお持ちでない場合は、Microsoft アカウントで Excel for the web にサインインしている場合にのみ、これらのデータ型を使用できます。 

リンクされたデータ型にアクセスするとエラーが発生する

データ型を含むブックを開いたとき、またはデータ型を変更または更新しようとしたときに、これらのデータ型にアクセスできないというエラー メッセージが表示される場合は、次の手順を試してください。

  • Microsoft 365 サブスクリプションに関連付けられているアカウントで Excel にサインインしていることを確認します。
  • [ファイル>アカウント>] に移動し、Excel に最新の更新プログラムがあることを確認します。 Excel for the web を使用している場合は、[ ファイル>情報] に移動します。 macOS の場合は、メニュー バーで [ヘルプ>Updatesの確認] を選択し、利用可能な更新プログラムをインストールします。
  • データ型を取得するための要件を満たしていることを確認します。
  • 問題が解決しない場合は、ブックを Excel for the web で開いてみてください。

注

リンクされたデータの表示のみをサポートするバージョンの Excel で、データ型を含むブックを最初に開いた可能性があります。 たとえば、ブックには [株価] データ型が含まれているので、カードやアクセスのフィールドを引き続き表示できます。 ただし、データ型を更新または変更することはできません。 データ型を使用するには、サブスクリプションに関連付けられているアカウントで Excel for the web にサインインしていることを確認します。

リンクされたデータ型の種類

いくつかのデータ型を使用できます。 種類とその下にあるリボン ボタンを確認するには、「 Excel で使用できるリンクされたデータ型は何ですか?」を参照してください。 

リンクされたデータ型は、Bing などのオンライン ソースから信頼できるデータをプルします。 特定のデータ型の型またはソースを表示する場合は、セル内のデータ型アイコンを選択してカードを開き、一番下までスクロールしてデータ プロバイダーとデータ型に関する情報を見つけることができます。

データ型についてフィードバックする方法

Excel のデータ型の改善に継続的に取り組んでいます。 結果が見つからない、データが間違っている、欠落している、あるいはタスクを達成できない場合... 私たちはすべてを把握したいです! お客様の貴重なフィードバックを使用して、エクスペリエンスと機能を改善します。

求めているフィードバック

  • データ品質 (誤っている、不適切な、不完全なデータなど)
  • データ カバレッジ (不足しているデータ)
  • 経験 (データ型とデータを使用)
  • 提案とアイデア

株価、地理のデータ品質について

  1. データ型に変換したら、セルのデータ型アイコンを選択してカードを開きます。
  2. カードの下部までスクロールし、フラグ アイコンを選択します。
  3. 短いアンケートに入力し (Excel のデスクトップ バージョンを使用している場合)、送信します。 より具体的になるほど、問題を理解して修正するのが簡単になります。

カードの下部にあるフラグ アイコンを選択します。

データ カバレッジに関するフィードバックについては

  1. データ型に変換すると、セルに青い疑問符が表示される場合があります。 これは、結果の検索や照合に問題が発生したことを意味します。 データ選択ウィザードがまだ開いていない場合は、このアイコンを選択します。
  2. [データ選択ウィザード] ウィンドウで、[ フィードバックの送信] を選択します。
  3. 簡単なアンケートに記入して送信してください。 より具体的になるほど、問題を理解して修正するのが簡単になります。

一般的なデータ型のフィードバックまたは提案

データ型を使用した全体的なエクスペリエンスに関する一般的なフィードバックを Excel アプリから直接送信することもできます。

  1. [ ヘルプ ] タブ >フィードバック] に移動します。 詳細については、「Microsoft Office に関するフィードバックを送信する操作方法」を参照してください。
  2. 何が好きか、何が嫌いか、ご意見をお寄せください。 できるだけ具体的にフォームを送信してください。

はい。 セルのリンクを解除することで、データ型を参照している数式への接続を削除できます。 デスクトップ バージョンの Excel を使用している場合は、データ型がリンクされているセルを選択し、 Ctrl+C または Mac の Cmd+C を押してコピーします。 Mac では、 Ctrl キー + Alt キー + V キーまたは Cmd キー + Control キー + V を押して 、[ 値] を選択します。 これにより、データ型が新しいセルに貼り付けられ、データ プロバイダーへの接続が失われることはありません。

ブックを同僚や友人に送信した場合、これらの新しいデータ型は動作しますか?

はい。ただし、特定のデータ型を使用するには 、要件を満たす 必要があります。 要件を満たしていないユーザーにブックを送信した場合、そのユーザーはデータ型からデータを表示できますが、データ型を変更または更新することはできません。

この機能は他のバージョンの Excel で動作しますか?

現時点では、リンクされたデータ型をサポートしているのは Excel for Microsoft 365 と Excel for the web のみです。 これらの新しいデータの種類をサポートしていないバージョンの Excel で開くと、対象のセルに #VALUE! と表示されます。 そして #NAME?これらのデータ型を参照する数式の代わりに表示されます。

フィル ハンドルはデータの種類に対して動作しますか?

はい。 ほとんどの Excel 機能はデータ型で動作し、統合の改善に継続的に取り組んでいます。 フィル ハンドルは、行または列のデータ型が同じで、セルに同じフィールドを入力する場合に機能します。 そのフィールドにデータがない場合、または見つからない場合は、#FIELD エラーが表示されます。

データ型のリストの最後のセルに変換するテキストを入力することもできます。Excel は自動的にテキストの照合を試みてテキストを変換します。

その他の知っておくべき制限事項はありますか?

一部の従来の Excel 機能は、リンクされたデータ型ではうまく機能しない場合があります。 たとえば、データ型の情報に基づいてピボットテーブルを作成する場合、シートに明示的に追加された情報のみを使用できます。 また、Power Pivot、Power Query、または一部のグラフでこれらのデータの種類を使用すると、意図したとおりに動作しない可能性があります。 

これらのデータの種類はどの言語で使用できますか?

現時点では、一部のデータ型は特定の言語でのみ使用できます。 アクセスして使用するには、 Office の言語設定に編集言語を追加できます。

  • 株価と地理データ型: 英語、スペイン語、フランス語、ドイツ語、イタリア語、ポルトガル語のみ。 今後、さらに多くの言語を追加できるように取り組んでいます。

ヒントとテクニック

迅速かつ簡単に活用できるキーボード ショートカット

カードを開く:

Windows の場合は Ctrl+Shift+F5 、Mac の場合は Cmd+Shift+F5 を押します。

データを更新する方法

リンクされたデータ型は、オンライン データ ソースに接続します。 テキストをリンクされたデータの種類に変換すると、ブック内で外部データ接続が確立されます。 そうすれば、データがオンラインで変更された場合に、Excel で更新して、レコードを更新することができます。

データを更新するには、リンクされたデータ型のセルを右クリックし、[ データ型>更新] をクリックします。 これにより、選択したセルと、同じデータ型の他のセルが更新されます。

リンクされたすべてのデータ型と、ブックに含まれる可能性があるすべてのデータ接続 (クエリ、他のデータ接続、ピボットテーブルを含む) を更新する場合は、[ データ>すべて更新] をクリックします。

データ型カードから画像を挿入する

データ型カードを使用すると、通常の値だけでなく、それ以上のものを抽出できます。 地理データ型などの一部のデータ型カードには、ブックに挿入できる画像が含まれています。 これらの画像は、テキストや数字と同様にセル内に含まれています。

  1. セルを選択し、[ データ ] タブ >データ型 グループ) に移動し、目的のデータ型を選択して、テキストをデータ型に変換します。
  2. 変換されると、セル値の左側にアイコンが表示されます。 それを選択してカードを表示します。
  3. カード内の画像にカーソルを合わせると、[データの挿入] 列の追加ボタン アイコンが表示されます。 これを選択して、画像をブックに挿入します。
  4. 画像はセル内に収まるように拡大縮小されます。 サイズを変更するには、行または列を調整してセルのサイズを大きくします。

テキストに変換してデータ型を削除します。

セルをリンクされたデータ型にしない場合は、セルを右クリックし、[ データ型>テキストに変換] をクリックします。 データの種類が削除され、オンライン接続がなくなり、セルの値がテキストに変換されます。

重要

データ型をテキストに変換すると、そのデータ型から値を抽出したすべての列または数式に #FIELD! が表示されます。 エラーが表示されることに注意してください。

データ型を参照する数式を作成する

データ型とそこから挿入したデータは、他のデータと同様に、数式や計算に使用できます。  データがテーブル内にない場合でも、リンクされたデータ型の値を参照する数式を記述することもできます。 詳細については、「データ型を参照する数式を作成する方法」を参照してください。

並べ替えとフィルタリング

[フィルター] メニュー、[値の表示] メニュー、リンクされたデータの種類からのフィールドが一覧表示されます

列ヘッダーのフィルター ボタンを使用すると、いつでも Excel でデータを並べ替えたりフィルター処理したりすることができます ([データ] をクリックしてフィルター ボタンを有効にします>フィルター。)

ただし、デスクトップ バージョンの Excel を使用している場合は、データ型を持つセルに関するヒントがあります。アイコン付きのセルの上にあるフィルター ボタンをクリックします。 次に、並べ替えやフィルター処理の方法を決定します。 表示名を使用してこの操作を行う場合は、[フィールドの選択] の下の [表示値] を選択したままにします。 リンクされたデータの種類の別のフィールドを使用して並べ替えまたはフィルター処理を行う場合、[フィールドの選択] でそのフィールドを選択します。

この例では、フィールド領域を選択しました。 次に、Excel はそれを以下のフィルター チェック ボックスの基準として使用し、テーブルにある国/地域の人口を表示します。

補足情報:[フィールドの選択] で選択するフィールドに応じて、[数値フィルター] メニューは変わります。

リンクされたデータ型の詳細

Excel データ型: 株価と地理

Excel を Power BI セマンティック モデルに接続する

データ型を作成する (Power Query)