データ プレビューの管理 (Power Query)

適用先
Excel for Microsoft 365 Excel 2024 Excel 2021

Power Query エディターでは、さまざまなオプションを設定することで、データ プレビューのいくつかの側面を管理できます。 これらのオプションのいくつかはパフォーマンスへの影響があり、知っておくと役立ちます。   

マージ コマンドを説明するために使用されるサンプル データを示すスクリーンショット。

バックグラウンド データ オプションを設定する

プレビュー データのダウンロード方法を直接またはバックグラウンドで制御できます。

  1. 次のいずれかの操作を行います。

    • Excel で、[データ]>データの取得>クエリ オプションの順に選択します。
    • Power Query エディターで、[ファイル>オプションと設定]> [クエリ オプション] を選択します。
  2. 左側のウィンドウの [グローバル] で [データの読み込み] を選択し、[ バックグラウンド データ] で次のオプションのいずれかを選択します。

    • 常にバックグラウンドでのデータ プレビューのダウンロードを許可する
    • 各ファイルの設定に従って、バックグラウンドでデータ プレビューをダウンロードできるようにする
    • バックグラウンドでのデータ プレビューのダウンロードを許可しない
  3. 左側のウィンドウの [現在のブック] で [データの読み込み] を選択し、[ バックグラウンド データ] で [バックグラウンドでの データ プレビューのダウンロードを許可する] をオンまたはオフにします。

データ プレビューを表示する方法別を設定する

等幅フォントでデータを表示したり、改行などの特殊文字を表示したりできます。

現在のプレビュー データのオプションを設定する

  1. Power Query エディターで、[ 表示] を選択し、[ データ プレビュー] グループで次のいずれかのオプションをオンまたはオフにします。

    • 等幅 等幅フォントを使用してプレビュー コンテンツを表示します。
    • ホワイトスペースを表示 空白文字と改行文字を表示します。
    • 列の品質 データ プレビューに列の品質の詳細を表示します。
    • 列の分布 データ プレビューに列の値の分布を表示します。
    • 列のプロファイル 詳細ウィンドウに列のプロファイルを表示します。

すべてのブックのオプションを設定する

  1. [ファイル>オプションと設定]>[クエリ オプション]>[Power Query エディター]>[データ プレビュー] を選択します。

  2. 左側のウィンドウの [グローバル] で、[Power Query エディター] を選択します。

  3. 右側のウィンドウの [データのプレビュー] で、次のオプションをオンまたはオフにします。

    • 等幅フォントを使用してプレビュー コンテンツを表示する
    • 空白文字と改行文字を表示する

列プロファイルを設定する

既定では、列のプロファイルは Power Query エディターでの作業中のパフォーマンスを向上させるために、最初の 1,000 行のデータに基づいています。 より完全な統計情報とプロファイリング情報については、データセット全体に基づくプロファイリングに切り替えることができます。 このオプションは、大規模なデータセットの計算に時間がかかる場合があります。

  1. クエリを開くには、Power Query エディターから以前に読み込んだクエリを見つけ、データ内のセルを選択して、[クエリ>編集] を選択します。 詳細については、「 Excel (Power Query) でクエリを作成、読み込む、または編集する」を参照してください。

  2. [データ プレビュー] ウィンドウの右下隅で、[列] と [行数] の右側にあるコマンドのいずれかを選択します。

    • 上位 1000 行に基づく列のプロファイル
    • データセット全体に基づく列のプロファイル

関連項目

Power Query for Excel のヘルプ