外部データ範囲のプロパティを変更して、データベース、Web クエリ、テキスト ファイルなどの外部データ ソースへの接続を通じてワークシートにインポートされたデータを制御できます。
外部データ範囲とそのプロパティの詳細
外部データ範囲は、ワークシートに取り込まれるデータの場所を定義する定義された名前またはテーブル名です。 外部データに接続すると、Excel は外部データ範囲を自動的に作成します。 唯一の例外は、データ ソースに接続されているピボットテーブル レポートです。ピボットテーブル レポートでは、外部データ範囲は使用されません。 Excel では、他のデータと同様に、外部データ範囲を書式設定してレイアウトしたり、計算に使用したりできます。
外部データ範囲のプロパティ
外部データ範囲には、セルの書式設定や列幅の保持など、データの制御に使用できる追加のプロパティ (クエリ プロパティや接続プロパティと混同しないでください) があります。 これらの外部データ範囲プロパティを変更するには、[データ] タブの [接続] グループの [プロパティ] をクリックします。その後、次の操作に従って変更を加えます。
- Microsoft Query およびデータ接続ウィザードから作成された外部データ範囲の場合は、[ 外部データのプロパティ] ダイアログ ボックスを使用します。
- インポートしたテキスト ファイルまたは HTML データを取得する Web クエリから作成された外部データ範囲の場合は、[ 外部データ範囲のプロパティ] ダイアログ ボックスを使用します。
- XML データを取得する Web クエリから作成された外部データ範囲の場合は、[ XML マップ プロパティ] ダイアログ ボックスを使用します。
外部データ範囲を検索する
- 外部データ範囲を検索するワークシートを選びます。
- 数式バーで [ 名前] ボックスの横にある矢印をクリックし、目的の外部データ範囲の名前をクリックします。
外部データ範囲の名前を変更する
- [ 数式>名前の管理] を選択します。
- [ 名前の管理] ダイアログ ボックスで、外部データ範囲の名前をクリックし、[ 編集] をクリックします。 名前をダブルクリックすることもできます。
- [ 名前の編集 ] ダイアログ ボックスの [ 名前 ] ボックスに参照の新しい名前を入力します。
注
[ 閉じる ] ボタンは、[ 名前マネージャー ] ダイアログ ボックスのみを閉じます。 既に行った変更をコミットするために [閉じる ] をクリックする必要はありません。
外部データ範囲の基になるクエリを変更する
Microsoft Query、インポートされたテキスト ファイル、Web クエリ、またはデータ接続ウィザードから作成された外部データ範囲の基になるクエリを変更できます。
Microsoft Query から作成された外部データ範囲の基になるクエリを変更する
- 基になるクエリを変更する外部データ範囲内のセルをクリックします。
- [ データ>プロパティ] を選択します。
- [外部データのプロパティ] ダイアログ ボックスで、[接続プロパティ] をクリックします

- [ 接続のプロパティ ] ダイアログ ボックスで、[ 定義 ] タブをクリックし、[ クエリの編集] をクリックします。
Microsoft Query でのクエリの作成と編集の詳細については、Microsoft Query のヘルプを参照してください。
インポートされたテキスト ファイルから作成された外部データ範囲の基になるクエリを変更する
- 基になるクエリを変更する外部データ範囲内のセルをクリックします。
- [ データ>接続] & [クエリ]>[接続 ] タブを選択し、目的の接続を右クリックして、[ プロパティ] を選択します。
- [ 接続のプロパティ ] ダイアログ ボックスで、[ 定義 ] タブをクリックし、[ クエリの編集] をクリックします。
- [ テキスト ファイルのインポート ] ダイアログ ボックスで、[ インポート] をクリックします。
- テキスト インポート ウィザードでインポートしたテキスト ファイルを変更し、[ 完了] をクリックします。
テキスト ファイルのインポートの詳細については、「 テキスト ファイルのインポートまたはエクスポート」を参照してください。
Web クエリから作成された外部データ範囲の基になるクエリを変更する
- 基になるクエリを変更する外部データ範囲内のセルをクリックします。
- [ データ>プロパティ] を選択します。
- [ データ>接続] & [クエリ]>[接続 ] タブを選択し、目的の接続を右クリックして、[ プロパティ] を選択します。
- [ 接続のプロパティ ] ダイアログ ボックスで、[ 定義 ] タブをクリックし、[ クエリの編集] をクリックします。
- [ Web クエリの編集 ] ダイアログ ボックスで Web クエリを変更し、[ 完了] をクリックします。
Web クエリの作成と編集の詳細については、「 Web ページに接続する」を参照してください。
データ接続ウィザードを使用して作成した外部データ範囲の基になるクエリを変更する
基になるクエリを変更する外部データ範囲内のセルをクリックします。
[ データ>プロパティ] を選択します。
[外部データのプロパティ] ダイアログ ボックスで、[接続プロパティ] をクリックします

[ 接続のプロパティ ] ダイアログ ボックスで、[ 定義 ] タブをクリックします。
次のいずれかの操作を行います。
[ コマンドの種類] ボックスで [テーブル ] をクリックし、[ コマンド] テキスト ボックスで値を適切なテーブル、ビュー、またはクエリの名前に変更します。
[ コマンドの種類] ボックスで [SQL ] または [既定値 ] をクリックし、[ コマンド] テキスト ボックスで SQL ステートメントを編集します。
注
接続の定義方法によっては、[ コマンドの種類] ボックスが使用できない場合があります (淡色表示されます)。
外部データ範囲とその基になるクエリをコピーする
- 数式バーで [ 名前] ボックスの横にある矢印をクリックし、コピーする外部データ範囲の名前を選択します。
Excel テーブルの場合は、範囲の名前を選択し、Ctrl + A キーを押してテーブルのヘッダーを選択します。
外部データ範囲に含まれない列見出しまたは数式を含める場合は、コピーする列見出しまたは数式を含むセルを選択します。 数式バーの [名前] ボックス の横にある矢印をクリックし、コピーする外部データ範囲の名前をクリックします。 - [ホーム>コピー] を選択します。
- 外部データ範囲を貼り付けるブックに切り替えます。
- 貼り付け領域の左上隅のセルをクリックします。
外部データによって既存のデータが置き換えられないようにするには、ワークシートで、クリックしたセルの下または右にデータが含まれていないことを確認します。 - [ホーム] タブの [クリップボード] グループで [貼り付け] をクリックします。
注
外部データ範囲の一部のみをコピーした場合、基になるクエリはコピーされず、コピーしたデータを更新することはできません。
外部データ範囲に新しいデータを追加する方法を指定する
データの更新時に Excel に返される、より小さい/大きなデータ セットを処理する方法を制御できます。
[ データ>プロパティ] を選択します。
[ 外部データ範囲のプロパティ ] ダイアログ ボックスの [ 更新時にデータ範囲の行数が変わった場合] で、次のいずれかをクリックします。
新しいデータのセルを挿入し、使用していないセルを削除する
注
- データ ソースに 1 つ以上の行が追加されると、外部データ範囲のすぐ下のセルは下に移動しますが、外部データ範囲の右側のセルは移動しません。
- データ ソースで 1 つ以上の行が削除されると、外部データ範囲のすぐ下にあるセルは上に移動しますが、外部データ範囲の右側にあるセルは移動しません。
新しいデータの行全体を挿入し、使用されていないセルをクリアする
注
- データ ソースに 1 つ以上の行が追加されると、外部データ範囲のすぐ下と右側のセルが下に移動します。
- データ ソースで 1 つ以上の行が削除されても、外部データ範囲のすぐ下または右側にあるセルは移動しません。
既存のセルを新しいデータで上書きし、未使用のセルをクリアします
注
- データ ソースに 1 つ以上の行が追加されると、外部データ範囲の直下にあるセルは上書きされますが、外部データ範囲の右側にあるセルは移動しません。
- データ ソースで 1 つ以上の行が削除されても、外部データ範囲のすぐ下または右側にあるセルは移動しません。
データの書式設定とレイアウトを指定する
[ データ>プロパティ] を選択します。
[データの書式設定とレイアウト] で、次のうちの 1 つまたは複数の操作を行います。
フィールド名を 1 行目として含めるには、[フィールド名を含める] チェック ボックスをオンにします。
行番号の列を追加するには、[行番号を含める] チェック ボックスをオンにします。
注
このチェック ボックスは、インポートされたテキスト ファイル、XML ファイル、または Web クエリでは使用できません。
適用するセル書式を保持するには、[セル書式を保持する] チェック ボックスをオンにします。
注
Web クエリの場合は、[オプション] ダイアログ ボックスで [完全な HTML 書式] を選ぶと、このオプションは自動的にオフになります。 [クエリの編集] ダイアログ ボックスから [オプション] ダイアログ ボックスにアクセスします。
設定した列幅を保持するには、[列幅を調整] チェック ボックスをオンにします。
適用する列の並べ替え、フィルター処理、レイアウトを保持するには、[列の並べ替え/フィルター/レイアウトの保持] チェック ボックスをオンにします。
注
このチェック ボックスは、Web クエリでは使用できません。
適用する列フィルターを保持するには、[列フィルターを保持する] チェック ボックスをオンにします。
注
このチェック ボックスは、XML データに基づく Web クエリでのみ使用できます。
外部データ範囲内のデータを固定する
外部データ範囲を凍結すると、データは保持されますが、基になるクエリは保持されないため、凍結した外部データ範囲を更新できなくなります。
Excel テーブルのデータを固定する
- データ接続を削除する Excel テーブルが含まれているワークシートをクリックします。
- 数式バーで [ 名前] ボックスの横にある矢印をクリックし、データ接続を削除する外部データ範囲の名前をクリックします。 データ範囲が選択されます。
- [ ツール] タブの [外部テーブル データ ] グループで、[ リンク解除] をクリックします。 データ範囲は同じ名前のままになりますが、接続は削除されます。
外部データ範囲を削除する
- 削除する外部データ範囲が含まれているワークシートをクリックします。
- 数式バーで [ 名前] ボックスの横にある矢印をクリックし、削除する外部データ範囲の名前をクリックします。
外部データ範囲が Excel テーブルの場合は、Ctrl + A キーを押してテーブル全体を選択します。 - 外部データ範囲を削除するには、Del キーを押します。
- 基になるクエリを削除するには、Excel からのプロンプトが表示されたら、[ はい ] をクリックします。