ブックを Microsoft SharePoint ライブラリに発行すると、Excel をコンピューターにインストールしなくても Web ブラウザーでブックを表示または編集できます。 発行は、基本的に保存と同じですが、いくつかの組み込みのオプションを使って、ユーザーがブラウザーでブックを開いたときに表示される内容を制御できます。
ブックを中央の SharePoint サイトに保存または発行するための組織全体の規則を採用すると、同じブックのわずかに異なるバージョンが電子メールで送信されても、組織全体に広まらないようにすることができます。
発行オプションを設定することによって、グラフなどのブックの特定の部分を強調したり、ブラウザーの表示から他の部分を除外したりすることができます。 たとえば、基になるデータを表示せずにグラフだけを表示することができます。 または、特定のワークシートだけを必要なユーザーに表示し、他のワークシートを隠すことができます。
この記事では、Excel for Windows からブックを発行する方法について説明しますが、SharePoint ページの Excel Web Access Web パーツにブックまたはブック データを接続する方法については説明していません。
ブックを SharePoint サイトに発行すると、ブック全体が SharePoint に保存されます。 必要な SharePoint 権限を持つユーザーは、ブラザーまたは Excel デスクトップ プログラムでブック全体を表示して操作することができます。
Office for the web が SharePoint に展開されている場合、ブラウザーでデータを表示して操作することは、Excel デスクトップ プログラムでデータを操作することと非常に似ています。 実際には、Excel デスクトップ プログラムとは異なり、複数のユーザーがブラウザー グリッドで同時にブックを編集できます。 ブラウザーでブックを表示して、[Excel Online で編集] ボタンが表示されている場合は、Office for the web を使用する準備ができていることがわかります。
ブックを準備する
ブックを発行する前に、ブラウザーで表示するシートまたはアイテムを選択することができます。 このモードでは、表示可能な内容を制限できますが、ワークシートの全体のコンテンツは依然として SharePoint サーバーに保存されています。
グラフやピボットテーブルなどの他のアイテムに加えてワークシート全体をアイテムとして含める場合は、ワークシート全体を名前付き範囲として定義します。 ワークシート全体を選んで、名前付き範囲を定義します。 この名前付き範囲は、発行の準備ができたときに使用可能なアイテムとして [発行オプション ] ダイアログ ボックスに表示されます。
ユーザーがセルに値を入力して別のセルで数式を使用できるようにするには、ブックを発行する前に Excel で定義済みの名前としてそのセルを設定します。 その後、[ブラウザーの表示オプション] ダイアログ ボックスの [パラメーター] タブで、その定義済みの名前をパラメーターとして追加できます。
たとえば、次の例では、"利率" という名前が定義されたセル D2 が示されています。ブラウザーで、[パラメーター] ウィンドウの [レート] ボックスに値 5.625 を入力し、[適用] をクリックします。 この値は、セル D2 に表示され、A2 の数式が D2 の値を使います。 数式の結果は再計算され、A2: $1,151.31 に表示されます。
注
Excel の表用のスライサーを作成して、表とスライサーを含むセルの範囲の名前を定義し、その定義した範囲を発行する場合、ブラウザーでスライサーを使用して表にフィルターを適用することはできません。 表、ワークシート全体、またはブックを発行すると、スライサーはブラウザーで期待どおりに機能します。
ブックを発行する
[ファイル] タブをクリックし、[名前を付けて保存] をクリックして、[参照] をクリックします。
[ 現在]、[ 最近使用したファイル]、または [ 古いもの] の下に SharePoint フォルダーが表示されている場合は、目的のフォルダーをクリックします。
[名前を付けて保存] ダイアログ ボックスが表示されます。それ以外の場合は、[ 参照] をクリックし、SharePoint サイトの Web アドレスを入力して、ブックを発行するフォルダーを参照します。
ブックから発行する個別のワークシートまたはアイテムを選ぶには、[ブラウザーの表示オプション] を選びます。
[表示] タブと [パラメーター] タブが表示されます。
ブック全体を発行する場合は、[保存] をクリックします。 それ以外の場合は、以下のいずれかの操作を行います。
- ブラウザーにブック全体を表示するには、[表示] タブのリスト ボックスで [ブック全体] を選びます。
- 特定のワークシートのみをブラウザーに表示するには、[表示] タブのリスト ボックスで [シート] を選んで、ブラウザーで表示しないシートのチェック ボックスをオフにします。
既定では、すべてのシートが選択されます。 いくつかのチェック ボックスをオフにした後ですべてのシートをすばやく表示可能にするには、[すべてのシート] チェック ボックスをオンにします。 - 特定のアイテム (名前付き範囲、グラフ、表、またはピボットテーブルなど) のみをブラウザーに表示するには、[表示] タブのリスト ボックスで [ブック内のアイテム] を選んで、表示するアイテムのチェック ボックスをオンにします。
- [パラメーター] タブで、使用する定義済みの名前を追加し、ユーザーがブラウザーでブックを表示したときに編集できるセルを指定して、[OK] をクリックします。
ブックを保存します。
注
- 同じ名前の複数のアイテム (グラフとその基になる表データなど) を選択する場合は、ブラウザーでいずれかのアイテムのみを使用できます。 すべてのアイテムを表示するには、ブック内の各アイテムに固有の名前が付けられていることを確認します。
- [プロパティ] グループの [デザイン] タブでテーブルの名前を変更したり、[ピボットテーブル] グループの [オプション] タブでピボットテーブルの名前を変更したり、[プロパティ] グループの [レイアウト] タブでグラフまたはピボットグラフの名前を変更したりできます。 [定義された名前] グループの [数式] タブの名前付き範囲など、他の重複するアイテムの名前を変更します。