Windows 10 バージョン 20H2 に更新した後、サインイン オプションまたはユーザーの MMC スナップインにアクセスするときにエラーが発生する場合があります

適用対象: Windows 10, version 20H2, all editionsWindows 10, version 2004, all editions

要約


Windows 10 バージョン 2004 または Windows 10 バージョン 20H2 に更新しようとすると、更新の互換性による保留が発生し、以下のようなメッセージを受信します。「この PC は Windows 10 にアップグレードできません。このバージョンの Windows 10 では、お使いの PC 設定はまだサポートされていません。これらの設定がサポートされている場合、Windows Update はこのバージョンのWindows 10 自動的に提供します。」

screenshot of safeguard hold dialog

原因


Windows 10、バージョン 20H2 に更新した後、ユーザーを一覧表示するダイアログウィンドウを操作すると、LSASS.exe で「PC は 1 分で自動的に再起動します」というテキストでエラーが表示される場合があります。たとえば、サインイン オプション設定アプリ ページまたはローカル ユーザーとグループの MMC スナップインのユーザー フォルダーにアクセスする場合です。この問題は、管理者ゲストなど、ローカルの組み込みアカウントの名前が変更されたデバイスにのみ影響します。また、イベントID 1015 のアプリケーション イベン トログに、LSASS.EXE がステータスコード C0000374 で失敗したというエラーが表示される場合があります。C0000374 は、ヒープの破損に関連しています。

この問題は、Windows 10 バージョン 20H2 への更新中に、同じセキュリティ識別子 (SID) と相対識別子 (RID) で重複する組み込みユーザー アカウントが作成されることが原因で発生します。組み込みユーザー アカウントの SID と RID は、ここに記載されているようによく知られており、特定のデバイスで一意である必要があります。

更新エクスペリエンスを保護するために、これらのデバイスに互換性保持を適用して、Windows 10 バージョン 2004 または Windows 10 バージョン 20H2 のインストールまたは提供を停止しています。 組織で Update Compliance を使用している場合、セーフガード ID は 30103339 です。

回避策


 デバイスでこの問題がすでに発生している場合は、こちらの手順を使用して以前のバージョンの Windows に戻ることにより、アンインストール ウィンドウ内でこの問題を軽減できます。 アンインストール ウィンドウは、環境の構成と更新するバージョンによって 10 日または 30 日かかる場合があります。 その後、問題が解決したら、Windows 10 の新しいバージョンに更新する必要があります。 注: アンインストール ウィンドウ内で、DISM コマンド/Set-OSUninstallWindow を使用して、以前のバージョンの Windows10 に戻るまでの日数を増やすことができます。 既定のアンインストール ウィンドウが消える前に、この変更を行う必要があります。 詳細については、「DISM オペレーティング システムのアンインストール コマンドライン オプション」を参照してください。 

この問題を防ぎ、セーフガード ホールドを受け取らないようにするには、Windows 10 バージョン 2004 または Windows 10 バージョン 20H2 に更新する前に、すべての組み込みユーザー カウントを既定の名前に戻す必要があります。

次の手順


Microsoft では現在この問題の解決に取り組んでおり、今後のリリースで更新プログラムを提供する予定です。今後数週間以内に、問題を防ぐために更新されたバンドルとメディアが提供されます。

注意 このセーフガードが解除されるまで、[今すぐ更新] ボタンまたはメディア作成ツールによる手動更新を試みないことをお勧めします。