Exchange Server 2019 および 2016 の AuthServer の DomainName が原因で ELC MRM アーカイブが失敗する

適用先
Exchange Server 2019 Exchange Server 2016

現象

たとえば次のようなシナリオを考えてみます。

このシナリオでは、処理は行われません。 また、 Export-MailboxDiagnosticLogs コマンドレットはアーカイブ中に次のエラー メッセージを生成します。

      

Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcEwsException:

ELC EWS が失敗し、エラーの種類:

      

'ArchiveExchangeWebServiceNotAvailable'. メッセージ: アーカイブ EWS の URL が不明です。

原因

Exchange Server 2016 CU18 または Exchange Server 2019 CU7 をインストールすると、新しいパラメータ DomainName が *-AuthServer オブジェクトに導入されます。 インストール後、このパラメーターの値は空 ("") になります。 ただし、Exchange ハイブリッド構成ウィザード (HCW) バージョン 17.0.5494.0 を実行すると、HybridConfiguration オブジェクトのドメインによって DomainName パラメーターが設定されます。 このパラメーターは、マルチテナント (1:N) を有効にするために導入されました。 そのため、HCW はテナントごとに複数の ACS 認証サーバーを作成します。 これにより、"MRM/ELC" <MailboxAssistant> をアーカイブしてExchange Onlineメールボックスをアーカイブするプロセスが失敗します。 その結果、メール メッセージをクラウド アーカイブにアーカイブすることはできません。

解決策

この問題を解決するには、次のいずれかの更新プログラムをインストールします。

Exchange Server 2019 の場合は、Exchange Server 2019 用の累積的な更新プログラム 8 または Exchange Server 2019 用のそれ以降の累積的な更新プログラムをインストールします。

Exchange Server 2016 の場合は、Exchange Server 2016 の累積的な更新プログラム 19 またはそれ以降の Exchange Server 2016 の累積的な更新プログラムをインストールします。

参考資料

マイクロソフトでソフトウェア更新プログラムの説明に使用する用語集を参照してください。