行と列を挿入および削除して、ワークシートをきれいに整理します。
注
Excel ワークシートは、最大 16,384 列、1,048,576 行をサポートします。
列を挿入または削除する
- 列内の任意のセルを選択し、[ホーム]>[挿入]>[シート列の挿入] または [ホーム] >[削除]>[シート列の削除] に移動します。
- または、列の上部を右クリックして、[挿入] または [削除] を選択します。
行を挿入または削除する
- 行内の任意のセルを選択し、[ホーム]>[挿入]>[シート行の挿入] または [ホーム]>[削除]>[シート行の削除] に移動します。
- または、行番号を右クリックして、[挿入] または [削除] を選択します。
列を挿入すると、Excel は隣接する列から書式設定を適用することがあります。 書式設定を変更するには、列を挿入した後で [挿入オプション ] ボタンを選択し、書式設定オプションを選択します。
[挿入オプション] ボタンが表示されない場合は、[ファイル>オプション]>詳細設定に移動します。 [ 切り取り、コピー、貼り付け] で、[挿入 オプション ボタンの表示] を選択します。
行の挿入
Excel for the web で新しいスプレッドシートを開きます。
1 行を挿入するには: 新しい行を挿入する行全体を右クリックし、[1 行上に挿入] を選択します。
複数の行を挿入するには: 挿入する行数と同じ数を選択します。 選択範囲を右クリックし、その上に行を挿入するオプションを選択します。 コマンドに表示される数値は、選択した行の数によって異なります。
列の挿入
1 列を挿入するには: 新しい列を追加する場所の右側にある列全体を右クリックし、[ 1 列左に挿入] を選択します。
複数の列を挿入するには: 挿入する列の数と同じ数を選択します。 選択範囲を右クリックし、左に列を挿入するオプションを選択します。 コマンドに表示される数値は、選択した列の数によって異なります。
セル、行、または列を削除する
既存のセル、行、または列が不要な場合は、次の方法で削除します。
- 削除するセル、行、または列を選びます。
- 選択範囲を右クリックし、[ 削除] を選択します。 メッセージが表示されたら、[ セルを左にシフト] や [セルを上にシフト] などの適切な削除オプションを選びます。
行または列を削除する場合は、他の行または列が自動的に上方向または左方向にシフトします。
ヒント
セル、行、または列を削除した直後に気が変わった場合は、 Ctrl+Z キーを押すだけで復元できます。
セルを挿入する
1 つのセルを挿入するには:
- 新しいセルを挿入するセルを右クリックします。
- [ 挿入] を選択し、[ セルを右にシフト] または [セルを下にシフト] を選択します。
複数のセルを挿入するには:
- 挿入するセルと同じ数のセルを選択します。
- 選択範囲を右クリックし、[セルを右に挿入>シフト] または [セルを下にシフト] を選択します。
補足説明
Excel 技術コミュニティの専門家にいつでも質問するか、コミュニティでサポートを受けることができます。
関連項目
Excel の基本的な作業
Excel の数式の概要