データ モデルを使用すると、複数のテーブルのデータを統合し、1 つのブック内にリレーショナル データ ソースExcelできます。 このExcelデータ モデルは透過的に使用され、ピボットテーブルとピボットグラフで使用される表形式のデータを提供します。 データ モデルはフィールド リスト内のテーブルのコレクションとして視覚化され、ほとんどの場合、テーブルがそこに含まれています。

データ モデルの使用を開始する前に、データを取得する必要があります。 この場合は、& Transform (Power Query)エクスペリエンスを使用します。そのため、一歩戻ってビデオを視聴したり、& Transform と Power Pivot の取得に関する学習ガイドに従ってください。

Power Pivot とは

  • Excel 2016 & Excel for Microsoft 365 - Power Pivot はリボンに含まれています。

  • Excel 2013 - Power Pivot は Excel Office Professional Plus エディションの一部ですが、既定では有効になっていません。 Excel 2013の Power Pivot アドインの開始に関する詳細を確認してください。

  • Excel 2010 - Power Pivotアドインをダウンロードし、Power Pivot アドインをインストールします

Get & Transform (Power Query) の場所

  • Excel 2016 & Excel for Microsoft 365 - Get & Transform (Power Query) は、[データ] タブの Excelと統合されています。

  • Excel 2013 - Power Query は、Excel に含まれているアドインですが、アクティブ化する必要があります。 [File > Options >アドイン]に移動し、ウィンドウの下部にある [管理] ドロップダウンで、[COMアドイン] を選択>移動します。 [Microsoft Power Query] で [Excel]をオンにし、[OK] をクリックしてアクティブ化します。 [Power Query] タブがリボンに追加されます。

  • Excel 2010 - Power Query アドインをダウンロードしてインストールします。. アクティブにすると 、[Power Query] タブがリボンに追加されます。

はじめに

まず、データを取得する必要があります。

  1. Excel 2016 および Excel for Microsoft 365では、データ> Get & Transform Data > Get Dataを使用して、テキスト ファイル、Excel ブック、Web サイト、Microsoft Access、SQL Server、または複数の関連テーブルを含む別のリレーショナル データベースなど、任意の数の外部データ ソースからデータをインポートします。

    2013 Excel 2010 では、[Power Query >外部データの取得] に移動し、データ ソースを選択します。

  2. テーブルの選択を求める画面が表示されます。 同じデータ ソースから複数のテーブルを取得する場合は、[複数のテーブルの選択を有効 にする] オプションをオン にします。 複数のテーブルを選択するとExcelデータ モデルが自動的に作成されます。

    注: これらの例では、クラスと成績に関する架空Excelを含むブックを使用しています。 Student Data Model サンプル ブック をダウンロードし、その後に続きます。 完成した データ モデルを含むバージョンをダウンロードできます。.

    Get & Transform (Power Query) ナビゲーター
  3. 1 つ以上のテーブルを選択し、[読み込み] を クリックします

    ソース データを編集する必要がある場合は、[編集] オプションを 選択 できます。 詳細については、「クエリ エディター (Power Query) の概要」を参照してください

これで、インポートしたすべてのテーブルを含むデータ モデルが作成され、ピボットテーブル フィールド リスト に 表示されます

注: 

  • 2 つ以上のテーブルを同時に Excel にインポートすると、暗黙的にモデルが作成されます。

  • PowerPivot アドインを使用してデータをインポートすると、明示的にモデルが作成されます。 アドインでは、モデルは Excel に似たタブ付きレイアウトで表され、各タブには表形式のデータが含まれている必要があります。 Power Pivot アドインを使用したデータの取得に関するページを参照して、データベースを使用したデータ インポートの基本SQL Serverしてください。

  • テーブルを 1 つだけ含むモデルを作成することもできます。 1 つのテーブルを基にモデルを作成するには、そのテーブルを選んで、PowerPivot の [データ モデルに追加] を選びます。 これは、データセットのフィルター処理、計算列、計算フィールド、KPI、階層などの PowerPivot の機能を使いたい場合に行います。

  • プライマリ キーおよび外部キーのリレーションシップを持つ関連テーブルをインポートする場合、テーブルのリレーションシップは自動的に作成されます。 Excel では、データ モデル内のテーブルのリレーションシップの基準として、通常はインポートしたリレーションシップ情報を利用できます。

  • データ モデルのサイズを小きくする方法のヒントについては、「Power Pivot と Power Pivot を使用してメモリ効率の高いデータ モデルを作成Excel」を参照してください

  • 詳細については、「チュートリアル: データをデータ にインポートする」および「Excelモデルの作成」を参照してください

ヒント: ブックにデータ モデルが含まれていますか。 [管理] PowerPivot>に移動します。 ワークシートのようなデータが表示される場合は、モデルが存在します。 詳細については、「 ブックのデータ モデルで使用されている データ ソースを確認する」を参照してください。

テーブル間のリレーションシップを作成する

次の手順では、テーブル間にリレーションシップを作成して、テーブルからデータをプルできます。 各テーブルには、主キーまたは一意のフィールド識別子 (学生 ID、クラス番号など) が必要です。 最も簡単な方法は、これらのフィールドをドラッグ アンド ドロップして、Power Pivot のダイアグラム ビュー で接続 する方法です

  1. [Power Pivot > 管理] に 移動します

  2. [ホーム] タブで 、[ダイアグラム ビュー] を選択します

  3. インポートしたテーブルはすべて表示され、各テーブルのフィールド数に応じて、テーブルのサイズ変更に時間がかかる場合があります。

  4. 次に、主キー フィールドを 1 つのテーブルから次のテーブルにドラッグします。 次の例は、学生テーブルのダイアグラム ビューです。

    Power Query データ モデルのリレーションシップ ダイアグラム ビュー

    次のリンクを作成しました。

    • tbl_Students |学生 ID > tbl_Grades |学生 ID

      言い換えると、[学生 ID] フィールドを [学生] テーブルから [成績] テーブルの [学生 ID] フィールドにドラッグします。

    • tbl_Semesters |セメスター ID > tbl_Grades |セメスター

    • tbl_Classes |クラス番号> tbl_Grades |クラス番号

    注: 

    • リレーションシップを作成するためにフィールド名を同じにする必要はないが、同じデータ型である必要がある。

    • ダイアグラム ビューのコネクタ には 、一方の側に "1"、もう一方に "*" があります。 つまり、テーブル間に一対多リレーションシップが作成され、ピボットテーブルでのデータの使い方が決まれます。 詳細については、「 データ モデル内のテーブル間のリレーションシップ」 を参照してください。

    • コネクタは、テーブル間にリレーションシップが含まれています。 実際には、どのフィールドが互いにリンクされているのかは表示されます。 リンクを表示するには、Power Pivotの [リレーションシップの管理] >[リレーションシップ>>]>移動します。 このExcel、Data > Relationships に移動できます

データ モデルを使用してピボットテーブルまたはピボットテーブルを作成ピボットグラフ

1 Excel 1 つのブックに含まれるデータ モデルは 1 つのみですが、そのモデルには複数のテーブルが含まれており、ブック全体で繰り返し使用できます。 既存のデータ モデルには、いつでもテーブルを追加できます。

  1. [PowerPivotで、[管理] に移動します

  2. [ホーム] タブで 、[ピボットテーブル] を選択します

  3. ピボットテーブルを配置する場所 (新しいワークシートまたは現在の場所) を選択します。

  4. [OK]をクリックExcel、右側に [フィールド リスト] ウィンドウが表示された空のピボットテーブルが追加されます。

    Power Pivot ピボットテーブル のフィールド リスト

次に、ピボットテーブル を作成するか、ピボット グラフ を作成します。 テーブル間にリレーションシップを既に作成している場合は、ピボットテーブル内の任意のフィールドを使用できます。 Student Data Model サンプル ブックにリレーションシップが既に作成されています。

既存の関連しないデータをデータ モデルに追加する

モデルで使用する大量のデータをインポートまたはコピーしたが、データ モデルに追加していないとします。 この場合、新しいデータをモデルに追加するのは意外と簡単です。

  1. まず、モデルに追加するデータ内の任意のセルを選択します。 任意の範囲のデータを指定できますが、テーブルとして書式設定されたExcel最適です。

  2. 以下のいずれかの方法を使用してデータを追加します。

  3. [PowerPivot]、[データ モデルに追加] の順にクリックします。

  4. [挿入]、[ピボットテーブル] の順にクリックし、[ピボットテーブルの作成] ダイアログ ボックスで [このデータをデータ モデルに追加する] チェック ボックスをオンにします。

これで、範囲またはテーブルがリンク テーブルとしてモデルに追加されます。 モデル内でのリンク テーブルの利用方法については、「Power Pivot の Excel リンク テーブルを使用してデータを追加する」を参照してください。

テーブルにデータを PowerPivot する

PowerPivot では、Excel  ワークシートで使用できるような新しい行を直接入力する方法では、テーブルに行を追加できません。 ただし、 をコピーして貼 り付け、ソース データを更新して Power Pivot モデルを更新することで、 行を追加できます

補足説明

Excel 技術コミュニテでは、いつでも専門家に質問できます。また、Answers コミュニティでは、サポートを受けられます。

関連項目

変換& Power Pivot 学習ガイドを取得する

クエリ エディターの概要 (Power Query)

Power Pivot と Power Pivot を使用してメモリ効率Excelデータ モデルを作成する

チュートリアル: データを Excelにインポートし、データ モデルを作成する

ブックのデータ モデルで使用されているデータ ソースを探す

データ モデルのテーブル間のリレーションシップ

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Office Insider に参加

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×