従来の Outlook 検索の問題に最もよく当てはまるシナリオを選択してください。
従来の Outlook 検索で結果が返されない
Outlook の検索を使用して結果が表示されない場合は、表示されている順序で次の手順を実行します。
Windows Search トラブルシューティング ツールを実行する
-
Windows 11: [スタート] ボタンを選択し、[設定]>[プライバシー]& [セキュリティ] を選択して、[Windows のアクセス許可] で、[Windows の検索] を見つけて選択します。 下にスクロールし、 [ インデクサーのトラブルシューティング ツール] を選択します。
-
Windows 10:[スタート] ボタンを選択し、[設定]>[セキュリティ & 更新]、[トラブルシューティング] の順に選択します。 [ 検索とインデックス作成] を見つけて選択し、[ トラブルシューティング ツールの実行] を選択します。
従来の Outlook でインデックス作成が完了したことを確認する
従来の Outlook を起動し、[ 検索 ] ボックスを選択します。
リボンの [検索] メニューから [検索ツール>インデックス作成の状態] を選択します。
[ インデックスの作成の状態 ] ダイアログが表示され、次のような内容が表示されます。
従来の Outlook のインデックス作成が完了していない場合は、インデックス作成が残っているアイテム数に注意し、5 分待ってから、もう一度チェックします。 アイテムの数が減っていない場合は、次の手順に進みます。
データ ファイルが選択されていることを確認する
- 従来の Outlook を起動し、[ 検索 ] ボックスを選択します。
- リボンの [検索] メニューから [検索ツール>検索する場所] を選択します。
- 表示されるすべてのデータ ファイルおよびストアが選択されていることを確認します。
Windows Search サービスが有効で実行されていることを確認する
- Windows の [スタート] メニューを選択し、[ 検索 ] ボックスを選択します。
- 「services.msc」と入力し、Enter キーを押します。
- [名前] 列で、[Windows Search] を見つけてダブルクリックします。
- まだ設定されていない場合は、[スタートアップの種類] を [自動 (遅延開始)] に設定します。
-
サービスの状態に [実行中] と表示されない場合は、その下の [開始] ボタンを選択してサービスを開始します。
インデックス作成時に従来の Outlook データを含める
- クラシック Outlook を終了します。
- Windows の [コントロール パネル] で、[インデックスのオプション] を開きます。
- [インデックスのオプション] ダイアログ ボックスで、[Microsoft Outlook] が [含まれる場所] 列に表示されていることを確認します。
-
Microsoft Outlook が一覧に表示されていない場合は、[変更] を選択し、Microsoft Outlook の横にあるチェック ボックスを選択して有効にします。
- [OK] を選択し、[閉じる] を選択します。
インデックス作成のオプションが正しく構成されていることを確認するには、次の手順に従います。
- クラシック Outlook を終了します。
- Windows の [コントロール パネル] で、[インデックスのオプション] を開きます。
- [インデックスのオプション] ダイアログ ボックスで、[詳細設定] を選びます。
- [ファイルの種類] タブを選択します。
- [拡張子] 列で [msg] が見つかるまで下にスクロールします。
- [プロパティとファイルのコンテンツのインデックスを作成する] オプションがオンになっていることを確認します。
- [OK] を選択し、[閉じる] を選択します。
注
[フィルターの説明] 列に [Office Outlook MSG IFilter] が表示されていることを確認します。 表示されていない場合は、Windows Search サービスが正常に動作していないか、または Microsoft Outlook でフィルターが正しくインストールされていないことになります。 いずれの場合も、Microsoft サポートにお問い合わせいただき、問題に関するサポートを依頼してください。
従来の Outlook の検索カタログを再構築する
- クラシック Outlook を終了します。
- Windows の [コントロール パネル] で、[インデックスのオプション] を開きます。
- [インデックスのオプション] ダイアログ ボックスで、[詳細設定] を選びます。
- [詳細オプション] ダイアログ ボックスで、[再構築] を選択します。
- [OK] を選択し、[閉じる] を選択します。
インデックス作成が完了しない場合は、Microsoft サポートにお問い合わせいただき、Windows デスクトップ サーチに関するサポートを依頼してください。
従来の Outlook の新しいプロファイルで検索が機能するかどうかを確認する
新しいプロファイルを作成して検索をテストするには、次の手順に従います。
- 従来の Outlook で、[ファイル] >[アカウント設定] >[プロファイルの管理] を選択します。 または、Outlook を終了し、Windows のコントロール パネルで メール を開くこともできます。
- [メール設定 - Outlook ] ダイアログ ボックスで [プロファイルの表示] を選択し、[全般] タブで [追加] を選択します。
- [プロファイル名] ボックスに新しいプロファイルのための名前を入力し、[OK] を選択します。
- メッセージが表示されたら、メール アドレスやパスワードなどのアカウント情報を入力し、[次へ] を選択します。
- [完了] を選びます。 追加した新しいプロファイル名が [メール] ダイアログ ボックスの [全般] タブに表示されます。
- [Microsoft Outlook の起動時に使用するプロファイル] で、[使用するプロファイルを選択する]、[OK] の順に選択します。
- Outlook を再起動します。
- [プロファイルの選択] ダイアログ ボックスのドロップダウン リストで、作成した新しいプロファイルの名前を選択し、[OK] を選択します。
- [ 検索 ] ボックスを選択して、検索します。
検索が動作する場合は、古いプロファイルに問題がある可能性があります。 新しいプロファイルを既定のプロファイルとして使用し、古いプロファイルから新しいプロファイルへ情報を移動する必要があります。
フィルターを使用して検索を絞り込み、古いメール メッセージを表示する
古い結果を検索する場合は、フィルターを使用して検索条件を絞り込むことができます。 従来の Outlook で検索される結果が多すぎる場合、古いアイテムが表示されない可能性があります。 フィルターの使用方法の詳細については、「 Outlook で検索条件を絞り込む方法の詳細」を参照してください。
コントロール パネルから Office を修復する
修復ツールにアクセスする手順は、オペレーティング システムごとに異なります。
Windows 10 または 11
[スタート] ボタンを右クリック
では [インストールされているアプリ] を選択するか、Windows 10 ではポップアップ メニューで [アプリと機能] を選択します。
修復する Microsoft Office 製品を選択して、[変更] を選択します。 オプションが表示されない場合は、右側の 3 つのドットを選択します。
注
これにより、Word や Excel など 1 つのアプリケーションのみを修復したい場合でも、Office スイート製品全体が修復されます。 単体のアプリをインストールしている場合は、アプリケーションを名前で検索することができます。
Office のコピーがクイック実行であるか、MSI ベースのインストールであるかに応じて、修復を実行するための以下のオプションが表示されます。 インストールの種類に応じた手順に従います。
クイック実行
[ Office プログラムをどのように修復しますか] ウィンドウで、[ オンライン修復>修復 ] を選択して、すべて修復します。 (より高速な [クイック修復] オプションも利用できます。ただし、問題を検出して、破損したファイルを置き換えるだけです)。
MSI ベース
[インストールを変更してください] で、[修復] を選択して [続行] をクリックします。
画面に表示される手順に従って操作を行い、修復を完了します。
Office をアンインストールし、再インストールする
アンインストールのトラブルシューティング ツールを使用して、Windows PC から Microsoft 365、Office 2021、Office 2019、または Office 2016 をアンインストールします。
アンインストールのトラブルシューティング ツールを開始するには、下のボタンを選択します。
「このサイトが問い合わせを開こうとしています」というポップアップ ウィンドウが表示された場合は、[開く] をクリックします。
残りの画面の指示に従い、メッセージが表示されたら、コンピューターを再起動します。
インストールまたは再インストールする Office のバージョンの手順を選択します。
Microsoft 365 | Office 2024 | Office 2021 | Office 2019 | Office 2016
重要
- アンインストールのトラブルシューティング ツールは現在、Office 2024 をアンインストールできません。
- アンインストールする Microsoft 365 または Office 製品と同じ Windows PC でトラブルシューティング ツールを実行します。
- トラブルシューティング ツールを実行するには、Windows 10 以上を使用している必要があります。
ヒント
Microsoft 365 のアンインストールのトラブルシューティング ツールを実行しても PC から Microsoft 365 または Office が完全にアンインストールされない場合は、 Office の手動アンインストールを試すことができます。
従来の Outlook 検索で不完全な結果が返されるか、古いメールが見つからない
Outlook 検索を使用して不完全な結果が返された場合は、記載されている順序で次の手順を実行します。
削除済みアイテム フォルダーを含める
見つからない検索結果が [削除済みアイテム] フォルダーにある場合は、次のフォルダーを検索結果に追加できます。
- 従来の Outlook を起動します。
- [ ファイル>オプション] を選択し、[ 検索] を選択します。
- [ すべてのアイテムを検索するときに、各データ ファイルの削除済みアイテム フォルダーにあるメッセージを含める ] チェック ボックスをオンにして、[ OK] を選択します。
- Outlook を再起動します。
同期スライダーを大きくして過去のメールをダウンロードする
メール アカウントのオフライン設定の時間を増やして、より多くのまたはすべてのメールがインデックス作成のためにローカルにキャッシュされるようにすることができます。 目的
- 従来の Outlook を起動します。
-
[ファイル>アカウント設定]>[アカウント設定] を選択します。
- [Email] タブで、メール アカウントを選択し、[変更] を選択します。
- [過去のメールをダウンロード:] スライダーを目的の時間または右端の [すべて] にドラッグします。
- [ 次へ ]、[ 完了] の順に選択します。 ウィンドウを閉じて、Outlook を再起動します。
検索範囲として [現在のフォルダー] を選択する (アーカイブ メールボックスの不完全な検索結果の場合のみ)
従来の Outlook で [すべてのメールボックス] または [すべての Outlook アイテム] スコープを使用して検索すると、アーカイブ メールボックスに対して限定された結果が返されるか、結果が返されません。 自動拡張されたアーカイブ メールボックスに移動されたアイテムは、フォルダー自体を検索するだけで検索できます。 フォルダー一覧でアーカイブ フォルダーを選択して、検索範囲として [現在のフォルダー] オプションを選択します。 自動拡張ストレージ領域のフォルダーにサブフォルダーが含まれている場合は、各サブフォルダーを個別に検索する必要があります。 詳細については、「 Microsoft 365 での無制限のアーカイブの概要」を参照してください。
共有メールボックス: 検索結果の問題
共有メールボックス検索で期待した結果が得られない場合、またはエラーが表示される場合は、次のいずれかの手順に従います。
[すべてのメールボックス] スコープを使用する場合、結果は返されません
共有メールボックスを検索するには、メールボックスを選択し、[ 現在のフォルダー] スコープを使用します。 これは、将来の更新プログラムでは変更されない設計上の制限です。 どのスコープがいつサポートされるかの詳細については、「 検索スコープについて」ブログ を参照してください。
この問題を回避するには、共有メールボックスをセカンダリ Exchange アカウントとしてプロファイルに追加します。 まず、共有メールボックスが既にプロファイルのアカウントとして一覧表示されているかどうかをチェックする必要があります。 その場合は、削除する必要があります。 手順は次のとおりです。
-
[ファイル] メニューから [アカウント設定] を選択し、もう一度 [アカウント設定] を選択します。
- Exchange アカウントをダブルクリックします。
- [ 詳細設定] を選び、[ 詳細設定 ] タブを選びます。
- [ これらの追加のメールボックスを開く] セクションで、共有メールボックスを選択し、[ 削除] を選択します。
次の手順に従って、共有メールボックスをセカンダリ アカウントとしてプロファイルに追加します。
- [ ファイル ] メニューから [ アカウントの追加] を選択します。
- このダイアログ ボックスに、メールボックスのフル ネーム (例: support@company.com) を入力します。
- パスワードの入力を求められたら、[ 別のアカウントでサインイン して、共有メールボックスへのアクセス許可を持つ Exchange アカウントの資格情報を使用する] オプションを選択します。