現象
Microsoft Dynamics CRM 4.0 でレポートを印刷しようとすると、次のエラー メッセージが表示されます。
注
クライアント印刷コントロールを読み込むことができません。
この問題は、SQL Server 2005 Service Pack 2 General Distribution Release (GDR) の更新プログラムをインストールした場合に発生します。
SQL Server 2005 Service Pack 2 GDR の更新プログラムの詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を参照してください。
954606 MS08-052: GDI+ for SQL Server 2005 Service Pack 2 GDR のセキュリティ更新プログラムの説明: 2008 年 9 月 9 日
原因
この問題は、SQL Server 2005 Service Pack 2 GDR の更新プログラムによって RSClientPrint クラスのバージョン番号が更新されるために発生します。 そのため、レポートビューャー コントロールも更新する必要があります。
解決策
この問題を解決するには、次のいずれかの方法を使用します。
レポート ビューアー再頒布可能パッケージ 2005 Service Pack 1 をインストールします。 レポート ビューアー再頒布可能パッケージ 2005 Service Pack 1 を入手するには、次の Microsoft Web サイトを参照してください。
displaylang=en http://www.microsoft.com/download/details.aspx?familyid=82833F27-081D-4B72-83EF-2836360A904D&SQL Server 2005 Service Pack 2 用の累積的な更新プログラム パッケージ 9 をインストールします。
SQL Server 2005 Service Pack 2 の累積的な更新プログラム パッケージ 9 の詳細については、Microsoft サポート技術情報の記事を表示するには、次の記事番号をクリックしてください。
SQL Server 2005 Service Pack 2 の953752累積的な更新プログラム パッケージ 9
累積的な更新プログラム パッケージ 9 をインストールした後に「現象」セクションに記載されているエラー メッセージが引き続き表示される場合は、RSClientPrint クラスを削除します。 このためには、次の手順を実行します。
Windows Internet Explorer を起動します。
[ツール] メニューの [インターネット オプション] をクリックします。
適切な手順に従います。
- Windows インターネット エクスプローラー 7 で、[閲覧履歴] 領域の [設定] をクリックし、[オブジェクトの表示] をクリックします。
- Microsoft Internet エクスプローラー 6 で、[一時インターネット ファイル] 領域の [設定] をクリックし、[オブジェクトの表示] をクリックします。
[RSClientPrint クラス] を右クリックし、[削除] をクリックします。
参考資料
詳細については、次のマイクロソフト Web サイトを参照してください。