現象
Microsoft Dynamics CRM 4.0 の Sales Force Automation エンティティのアクティビティ リストから [既存のアクティビティの追加] をクリックすると、検索ページに予定レコードとサービス アクティビティ レコードは表示されません。 この問題は、アクティビティの状態が [スケジュール済み] の場合に発生します。
原因
この問題は、Lookupdata.aspx ページのアクティビティを取得するために使用される既定の FetchXml ステートメントがスケジュールされたアクティビティを取得しないために発生します。
解決策
重要: このセクション、メソッド、またはタスクには、レジストリの変更方法が記載されています。 ただし、レジストリを誤って変更すると、深刻な問題が発生する可能性があります。 そのため、この手順は必ず慎重に行ってください。 さらなる保護のため、レジストリは変更する前にバックアップしてください。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリのバックアップ方法および復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法
この問題は、Microsoft Dynamics CRM 4.0 の最新の累積的な更新プログラムのロールアップで修正されています。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。
949256 Microsoft Dynamics CRM 4.0 の更新プログラムと修正プログラム
注 この問題は、もともと、Microsoft Dynamics CRM 4.0 の更新プログラムロールアップ 13 で修正されました。
詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。
Microsoft Dynamics CRM 4.0 の更新プログラムのロールアップ 13 2267499使用できます
Microsoft Dynamics CRM 4.0 を実行しているコンピューターでこの修正プログラムを有効にするには、次の手順を実行します。
- Microsoft Dynamics CRM サーバーの **HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\**registry サブキーの下に、次のREG_DWORD レジストリ エントリを追加します。
LookupActivityPointerScheduled - 1 に追加したレジストリ エントリの値を設定します。
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
追加情報
ソフトウェア更新プログラムに関する用語の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
824684 Microsoft ソフトウェア更新プログラムの説明に使用される標準用語の説明 Microsoft Business Solutions CRM ソフトウェア修正プログラムと更新プログラム パッケージの用語の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を表示します。
887283 Microsoft Business Solutions CRM ソフトウェア修正プログラムと更新プログラム パッケージの名前付け標準