KB4016850 - 修正: SQL Server管理オブジェクトを使用してフルテキスト検索インデックスのスクリプトを生成すると、結果が正しくない

適用先
SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

現象

たとえば次のようなシナリオを考えてみます。

  • データベース上でレプリケーションを構成します。
  • 記事にフルテキスト検索インデックスを作成します。
  • フルテキスト検索インデックスをレプリケートするようにレプリケーションを構成します。

このシナリオでは、SQL Server 管理オブジェクト (SMO) を使用してフルテキスト検索インデックスのスクリプトを生成すると、正しくない結果が得られます。 さらに、ディストリビューション エージェントが失敗します。

解決策

この問題の修正プログラムは、次の更新プログラムに含まれています。

SQL Server 2016 のビルドについて

SQL Server 2016 の新しいビルドには、以前のビルドに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server 2016 の最新ビルドをインストールすることをお勧めします。

状態

Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。

参考資料

Microsoft がソフトウェア更新プログラムについて説明するために使用する 用語について説明します 。