現象
Pacemaker クラスター上の SQL Server 2017 の Always On 可用性グループを使用するとします。 クラスターがプライマリ レプリカをフェールオーバーしようとすると、接続のタイムアウトなどの問題が原因で、クラスターが現在のプライマリ レプリカを降格しないことがあります。 この場合、クラスターはエラーを無視し、別のレプリカをプライマリに昇格し続けます。 その結果、可用性グループのプライマリ レプリカである 2 つの SQL Server インスタンスが生成されます。
解決策
この修正プログラムは、次の SQL Server の更新プログラムに含まれています。
SQL Server 2017 の累積的な更新プログラム 8
SQL Server ビルドについて
SQL Server の新しいビルドには、以前のビルドであったすべての修正プログラムとセキュリティ修正プログラムが含まれています。 ご使用のバージョンの SQL Server 用の最新ビルドをインストールすることをお勧めします。
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
参考資料
マイクロソフトでソフトウェア更新プログラムの説明に使用されている標準の用語については、用語集を参照してください。