KB2963658 - 修正: TDE 対応データベースが、SQL Server での WRITELOG または LOGBUFFER 待機時に無限に応答しなくなる

適用先
SQL Server 2008 Service Pack 3 SQL Server 2008 Standard SQL Server 2008 Developer SQL Server 2008 Enterprise SQL Server 2008 R2 Service Pack 2 SQL Server 2008 R2 Developer SQL Server 2008 R2 Enterprise SQL Server 2008 R2 Standard

現象

Microsoft SQL Server 2008 または SQL Server 2008 R2 で透過的なデータ暗号化 (TDE) が有効になっているデータベースがある場合、データベースに対する書き込み操作は WRITELOG または LOGBUFFER で無期限に待機します。

データベースが完全復旧モードで、スケジュールされたログ バックアップが定期的に実行されている場合、問題が発生した後のログ バックアップでは、SQL Server エラー ログの最初と最後のログ シーケンス番号 (LSN) 番号は同じです。 この期間中にユーザー アクティビティが予想されるかどうかを確認することをお勧めします。 ユーザー アクティビティの欠如による書き込み操作がないため、LSN 番号は変更されない場合があります。 関連する SQL Server エラー ログのエントリは次のとおりです。

注

ログがバックアップされました。 データベース: <DataBaseName>、作成日時: <日付><時刻>、最初の LSN: 76383:11154:1、最後の LSN: 76383:11154:1..... これは唯一の情報メッセージです。 ユーザー操作は必要ありません。
ログがバックアップされました。 データベース: <DataBaseName>、作成日時: <日付><時刻>、最初の LSN: 76383:11154:1、最後の LSN: 76383:11154:1..... これは唯一の情報メッセージです。 ユーザー操作は必要ありません。

この問題は完全復旧モードのデータベースに固有のものではありません。他の復旧モードのデータベースでも同じ問題が発生する傾向があります。 さらに、システム テーブル sys.sysprocesses でロールバック状態の SPID が表示される場合もあります。

原因

この問題は、TDE に関する何らかの根底にある例外が原因で発生します。

解決策

この問題は、次の SQL Server の累積的な更新プログラムで最初に修正されました。 この修正プログラムを適用すると、問題が発生したときに SQL Server はデータベースをオフラインにします (WRITELOG または LOGBUFFER を無期限に待機するのではなく)、SQL Server サービスを再起動せずにデータベースをオンラインに戻すことができます。 一部のシナリオでは、データベースは人間の介入なしに SQL Server によって自動的にオンラインに戻ります。 関連情報は SQL Server エラー ログに記録されます。

この修正プログラムを適用しても、問題は完全には解決されません。 ただし、問題が再び発生すると、追加の診断情報 (エラーの種類と重大度に基づく) が SQL Server エラー ログに記録される場合があります。 実際の例外を特定し、修正プログラムの適用後に取得する可能性のある追加の診断情報を利用して修正する必要があります。

SQL Server 2008 R2 SP2 の累積的な更新プログラム 13 /en-us/help/2967540

SQL Server 2008 SP3 の累積的な更新プログラム 17 /en-us/help/2958696

SQL Server 用の累積的な更新プログラムについて

SQL Server 用の新しい累積的な更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server の最新の累積的な更新プログラムを確認してください。

      

状態

Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。