現象
Microsoft SQL Server のインストールを SQL Server 2012 または SQL Server 2014 にアップグレードしようとすると、次のエラー メッセージが表示される場合があります。
注
次のエラーが発生しました。フォルダー 'C:\Program Files\Microsoft SQL Server\MSSQL10_50.INSTANCEID\MSSQL\JOBS' が存在しません。 アクセス許可を設定するために、フォルダーが存在する必要があります。 フォルダーが存在しない理由を調べて、再作成します。
原因
この問題は、JOBS フォルダーが既定のディレクトリから削除されている場合に発生します。 アップグレード中、アップグレード プロセスは JOBS フォルダーに必要なアクセス許可を設定しようとします。 ただし、フォルダーがなくなっている場合は、アクセス許可を適用できず、アップグレードは失敗します。
解決策
この問題は、次の SQL Server の累積的な更新プログラムで最初に修正されました。
SQL Server 2014 用の累積的な更新プログラム 8 /en-us/help/3067836
SQL Server 2012 SP2 用の累積的な更新プログラム 6 /en-us/help/3052468
SQL Server 用の累積的な更新プログラムについて
SQL Server 用の新しい累積的な更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server の最新の累積的な更新プログラムを確認してください。
この問題を解決するには、JOBS フォルダーを再作成し、失敗したアップグレードをアンインストールしてから、アップグレードをもう一度実行します。 手順は次のとおりです。
Summary.txt ファイルを参照として使用して、セットアップ プロセスで必要な JOBS フォルダーのパスを見つけて、フォルダーを再作成します。 たとえば、Summary.txt 次のようなものが含まれる場合があります。
注
エラーの説明: フォルダー C:\Program Files\Microsoft SQL Server\MSSQL11。ProdSQL\MSSQL\JOBS' は存在しません。 アクセス許可を設定するために、フォルダーが存在する必要があります。 フォルダーが存在しない理由を調べて、再作成します。
手順 1 で参照したものと同じ Summary.txt ファイルを使用して、アンインストール コマンドを見つけます。 たとえば、Summary.txt ファイルには次のようなものが含まれている場合があります。
SQLEngine の次の手順: SQL Server のアップグレード プロセスが失敗しました。 アップグレード プロセスを続行するには、次の情報を使用してエラーを解決します。 次に、次のコマンド ラインを使用して SQL Server をアンインストールします。setup /q /action=uninstall /instanceid=ProdSQL /features=SQLENGINE,FULLTEXT,REPLICATION
次に、SQL Server セットアップをもう一度実行します。コマンド プロンプトを開き、アップグレード セットアップ メディアが含まれているディレクトリを見つけます。 たとえば、SQL Server 2012 から SQL Server 2014 にアップグレードする場合は、SQL Server 2014 セットアップ メディアを使用します。
部分的インストールを削除するには、コマンド プロンプトで手順 2 のコマンドをコピーして実行します。 たとえば、アップグレードに失敗した "ProdSQL" のインスタンス ID を含むインスタンスをアンインストールするには、次のコマンドを実行します。
setup /q /action=uninstall /instanceid=ProdSQL /features=SQLENGINE,FULLTEXT,REPLICATION
注: アンインストール コマンドを実行しても、アップグレードしようとしている元のインスタンスは削除されません。 新しいバージョンの非アクティブ / 部分的なインストールのみが削除されます。
アップグレード プロセスを再度実行してください。
追加情報
詳細については、「SQL Server 2014 へのアップグレード」を参照してください。