現象
リモート管理者接続が有効で、Linux 上の Microsoft SQL Server 2019 または 2017 のホストで IPV6 が無効になっている場合、SQL Server は IPV6 でリッスンしようとしますが、起動しないことがわかります。
DateTime サーバー エラー: 26024、重大度: 16、状態: 1。
DateTime サーバー サーバーは 'any' <ipv6> 1434 をリッスンできませんでした。 エラー: 0x2742。 続行するには、システム管理者に通知してください。
DateTime エラー 0x2742、状態コード: 0x1 のため、サーバー専用管理者接続のサポートを開始できませんでした。 通常、このエラーは、ポートが既に使用されているなど、ソケットベースのエラーを示しています。
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
解決策
この問題は、次の SQL Server の累積的な更新プログラムで修正されています。
SQL Server の累積的な更新プログラムについて:
SQL Server 用の新しい累積的な更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server の最新の累積的な更新プログラムを確認してください。
参考資料
マイクロソフトでソフトウェア更新プログラムの説明に使用する用語集を参照してください。