現象
まれに、複数の結合を使用する複雑なクエリを実行すると、新しいアダプティブ結合機能が有効になっている場合 (既定) に SQL Server 2017 でアクセス違反エラーが生成されることがあります。
アダプティブ参加機能が原因でアクセス違反エラーが発生しているかどうかを確認するには、セッション レベルでトレース フラグ 9398 を使用して機能を無効にします。 次に、これらの種類のクエリを実行している間、プログラムを監視して、問題がまだ発生するかどうかを判断します。
解決策
この問題の修正プログラムは、SQL Server 2017 の累積的な更新プログラム 6 に含まれています。
SQL Server 2017 のビルドについて
SQL Server 2017 の新しいビルドには、以前のビルドであったすべての修正プログラムとセキュリティ修正プログラムが含まれています。 SQL Server 2017 の最新ビルドをインストールすることをお勧めします。
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
参考資料
Microsoft がソフトウェア更新プログラムについて説明するために使用する標準 的な用語について説明します 。