この修正プログラムは、Microsoft SQL Server 2012 Reporting Services (SSRS 2012) に適用されます。
現象
SSRS 2012 でセキュリティ アサーション マークアップ言語 (SAML) ベースのクレーム認証を使用するように構成された SharePoint Web アプリケーションがあることを想定しています。 Web アプリケーションで SharePoint ドキュメント ライブラリのサブスクリプションを作成しようとするとします。 この場合、サブスクリプションの作成が失敗し、次のようなエラー メッセージが表示されます。
注
Microsoft.ReportingServices.Diagnostics.Utilities.InvalidExtensionParameter: 拡張機能パラメーターの 1 つが次の理由で無効です: 配信設定 PATH の検証に失敗しました。 指定されたユーザー DOMAIN\Username が見つかりませんでした。
原因
この問題が発生するのは、SSRS 2012 が SharePoint Web アプリケーションに、SAML クレームでエンコードされたログオン名の代わりに、従来の認証でエンコードされたログオン名を渡すことが原因です。 さらに、SAML 要求が有効な SharePoint Web アプリケーションは、EnsureUser メソッドを呼び出してクラシック認証ログオン名を渡します。
解決策
累積的な更新プログラムの情報
SQL Server 2012 Service Pack 1 の累積的な更新プログラム CU 38
この問題の修正プログラムは、累積的な更新プログラム 5 で最初にリリースされました。 SQL Server 2012 Service Pack 1 用のこの累積的な更新プログラム パッケージを入手する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
2861107 SQL Server 2012 Service Pack 1 の累積的な更新プログラム パッケージ 5 注: ビルドは累積的であるため、新しい修正プログラムの各リリースには、以前のリリースの SQL Server 2012 Service Pack 1 の修正プログラムに含まれていたすべての修正プログラムおよびセキュリティ更新プログラムが含まれています。 この修正プログラムが含まれている最新リリースの修正の適用を検討することを推奨します。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。
2772858 SQL Server 2012 Service Pack 1 以降にリリースされた SQL Server 2012 のビルド
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。