KB3040675 - 修正: SSRS 2012 または SQL Server 2014 で電子メール配信が失敗すると、電子メール通知付きのデータドリブン サブスクリプションに "0 エラー" が表示される

適用先
SQL Server 2014 Business Intelligence - duplicate (do not use)

現象

たとえば次のようなシナリオを考えてみます。

  • Microsoft SQL Server 2012 Reporting Services (SSRS 2012) または SQL Server 2014 Reporting Services (SSRS 2014) を使用しています。
  • 電子メール配信拡張機能を使用するように設定されている Data-Driven サブスクリプションを実行します。
  • 電子メール システムの問題や SMTP サーバーが存在しないなどの理由により、電子メール通知の配信が失敗します。

このシナリオでは、サブスクリプションの状態フィールドは、処理中にエラーが発生しなかったと誤って報告します。

解決策

累積的な更新プログラムの情報

この問題は、次の SQL Server の累積的な更新プログラムで最初に修正されました。

推奨事項: SQL Server の最新の累積的な更新プログラムをインストールする

SQL Server 用の新しい累積的な更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server の最新の累積的な更新プログラムをダウンロードしてインストールすることをお勧めします。

      

状態

Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。