現象
レポート マネージャーから SQL Server Reporting Services 2014 (SSRS) のReport Builderを開始しようとすると、アクションは失敗します。 さらに、以下のエラー メッセージが表示されます。
警告
System.Deployment.Application.InvalidDeploymentException (HashValidation)
- ファイル(Microsoft.AnalysisServices.dll)には、マニフェストで指定されたハッシュとは異なる計算ハッシュがあります。
- ソース: System.Deployment
- スタック トレース:
at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, Hash hash)
at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, HashCollection hashCollection)
at System.Deployment.Application.ComponentVerifier.VerifyComponents()
at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)
at System.Deployment.Application.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
at System.Deployment.Application.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
解決策
累積的な更新情報
この問題は、SQL Serverの次の累積的な更新プログラムで最初に修正されました。
推奨事項 SQL Serverの最新の累積的な更新プログラムをインストールする