KB3171085 - SQL Server 2016 で Web ブラウザーがしばらくアイドル状態になった後に、自動的に更新するように構成されたレポートでエラーが発生する Reporting Services

適用先
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

現象

SQL Server 2016 Reporting Services レポートの自動更新プロパティを構成して、そのデータが自動的に更新されるとします。 Web ブラウザーでレポートを開いてからしばらくアイドル状態にすると、次のようなエラー メッセージが表示されます。

注

レポート実行 session_id の有効期限が切れているか、見つかりません。 (rsExecutionNotFound)

さらに、次のようなエラー メッセージが Reporting Services サービスのトレース ログに記録されます。

注

ライブラリ!ReportServer_0-2!2258!日時:: i 情報: GetPermissionsAction(/USERIDAutoRefresh) を呼び出します。

ライブラリ!ReportServer_0-2!2258!date time:: i INFO: GetSystemPropertiesAction() を呼び出します。

ライブラリ!ReportServer_0-2!2258!date time:: i 情報: GetPropertiesAction(/USERIDAutoRefresh, PathBased) を呼び出します。

ライブラリ!ReportServer_0-2!2258!date time:: i INFO: GetSystemPermissionsAction() を呼び出します。

ライブラリ!ReportServer_0-2!22B8!date time:: i INFO: GetSystemPropertiesAction() を呼び出します。

ライブラリ!ReportServer_0-2!22B8!date time:: e エラー: Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerStorageException をスローしています: , レポート サーバー データベース内でエラーが発生しました。 これは、データベース内の接続障害、タイムアウト、またはディスク不足状態が原因である可能性があります。;

session!ReportServer_0-2!22B8!date time:: e エラー: セッション データの取得中にエラーが発生しました。セッション session_id が NT Service\ReportServer に属していません

session!ReportServer_0-2!22B8!date time:: i INFO: LoadSnapshot: Item with session: session_id, reportPath: /USERIDAutoRefresh, userName: NT Service\ReportServer not found in the database

ライブラリ!ReportServer_0-2!22B8!日時:: e エラー: Microsoft.ReportingServices.Diagnostics.Utilities.ExecutionNotFoundException をスローしています: , Microsoft.ReportingServices.Diagnostics.Utilities.ExecutionNotFoundException: レポート実行 session_id の有効期限が切れているか、見つかりません。;

webserver!ReportServer_0-2!22B8!date time:: e エラー: Reporting Services エラー Microsoft.ReportingServices.Diagnostics.Utilities.ExecutionNotFoundException: レポート実行session_idの有効期限が切れているか、見つかりません。

      

解決策

この問題の修正プログラムは、次の SQL Server の累積的な更新プログラムに含まれています。

SQL Server 2016 の累積的な更新プログラム 1
注: この更新プログラムを適用すると、Reporting Services のログに、管理者が根本的な問題を診断および解決するためのセッションの有効期限が切れた理由に関する詳細な情報が表示されます。

SQL Server 用の累積的な更新プログラムについて

SQL Server 用の新しい累積的な更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server の最新の累積的な更新プログラムを確認してください。

SQL Server 2016 の最新の累積的な更新プログラム
      

状態

Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。

参考資料

Microsoft がソフトウェア更新プログラムについて説明するために使用する 用語について説明します 。