はじめに
この記事では、Microsoft SQL Server 2008 R2 Service Pack 1 (SP1) で修正されるバグの一覧を示します。
メモ
- 記載されていないその他の修正プログラムは、Service Pack に含まれている可能性があります。
- この一覧は、さらに資料が公開されたときに、更新される予定です。
SQL Server 2008 R2 Service Pack の入手方法の詳細については、以下のサポート技術情報番号をクリックしてください。
2527041 SQL Server 2008 R2 の最新の Service Pack を入手する方法
追加情報
この記事に記載されている修正プログラムに加えて、SQL Server 2008 R2 SP1 には、SQL Server 2008 R2 用の累積的な更新プログラム 1 から累積的な更新プログラム 6 に含まれていた修正プログラムが含まれています。 この Service Pack には、2011 年 7 月までにリリースされたすべてのセキュリティ更新プログラムも含まれています。
SQL Server 2008 R2 で利用可能な累積的な更新プログラム パッケージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
981356 SQL Server 2008 R2 のリリース以降にリリースされた SQL Server 2008 R2 のビルド
この Service Pack の修正プログラム
SQL Server 2008 R2 SP1 で修正される問題の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
| VSTS バグ番号 | サポート技術情報番号 | 説明 |
|---|---|---|
| 657377 | 949775 | ターゲット サーバーがドイツ語版またはフランス語版の SQL Server 2005 を実行している場合、ターゲット サーバーはマスター サーバーからマルチサーバー ジョブをダウンロードできません |
| 657404 | 2216478 | SQL Server 2008 を実行しているサーバー上の PowerShell バージョン 2 環境で Get-Command を実行すると、"オブジェクト参照がオブジェクトのインスタンスに設定されていません" というエラー メッセージが表示される |
| 649451 | 2216485 | 修正プログラム: SQL Server 2008 を実行しているサーバーでリソース モニターが非降伏状態になる |
| 649479 | 2216489 | 2008 SP2 に関する懸念事項 [SQL Server Destination [19]] エラー: データ挿入用の SSIS 一括挿入を準備できません |
| 649504 | 2216497 | 修正: 内部リングを持つ空間ストレージ ジオメトリ ポリゴン データ型が、さまざまなジオメトリ操作で間違ったデータを返す |
| 649529 | 2216501 | 修正: マルチサーバー ジョブが、MSX ロールの SQL Server 2000 から TSX ロールの SQL Server 2008 にダウンロードされない |
| 649457 | 2448971 | 修正プログラム: SQL Server 2008 でテーブルに多数の行を挿入しても、テーブルのロックがエスカレートされない |
| 628428 | 2463682 | 修正プログラム: データベース暗号化キーの暗号化に使用される証明書が削除されると、透過的なデータ暗号化が有効になっているデータベースにアクセスできなくなる可能性があります。 |
| 625028 | 2494517 | 修正: レポートをハード改ページ レンダラーにエクスポートした後、Tablix ヘッダーで参照されている非表示のテキスト ボックスの値が最初のページにのみ表示されるようになりました |
| 447613 | 2515006 | SharedDataSetまたはParameter処理中に適用されたDataSetフィルタが正しくない照合設定を使用している |
| 697406 | 2525273 | 修正: K-means アルゴリズムを使用するクラスタリング モデルで、SQL Server 2008 R2 Analysis Services の PredictOnly 列の影響を受ける異なる結果が生成される |
| 649480 | 2216491 | SQL ダンパー ユーティリティは、アドバンスト/エンタープライズ フェールオーバー クラスター インストール上の SQL Server 2008 または SQL Server 2008 R2 フェールオーバー クラスターでエラー ダンプ ファイルを生成できません |
| 649339 | 2216460 | SQL Server 2008 または SQL Server 2008 R2 でプロジェクトを開こうとすると、"見つかったアセンブリのマニフェスト定義がアセンブリ参照と一致しません" というエラー メッセージが表示される |
| 405512 | 2105809 | 接続モードからローカル モードに切り替えると、"コンピューター <コンピューター名> で ReportServer サービスを停止できません" というエラーが表示される |
| 405514 | 981588 | SharePoint 要求サイトを作成した後、SSRS 2008 R2 レポート サーバーを直接参照しようとするとエラー メッセージが表示される |
| 665971 | 2546901 | 修正: 8 個以上の CPU を搭載したコンピューターで SQL Server 2005、SQL Server 2008、または SQL Server 2008 R2 でランク付け関数を使用するパラレル クエリを実行すると、異なる結果が返される |
| 650006 | 2563828 | Assert in function = Microsoft.ReportingServices.ReportProcessing.ParameterBase.Cast file = line = 0 expression = Unhandled managed exception: Type = System.InvalidCastException, Message = 'System.Boolean' 型のオブジェクトを 'Syste. |
| 689073 | 2531482 | 修正: Visual Studio 2010 SP1 のインストール後に、SSMS 2008 R2 の IntelliSense 機能が動作しなくなることがある |
| 649856 | 2584903 | 修正: データ コレクター ジョブが SQL Server 2008 R2 の MDW データベースからデータを消去するのに時間がかかる |
この Service Pack のその他の修正
以下の問題に対する解決策は、SQL Server 2008 R2 SP1 にも含まれています。
| ID | 説明 |
|---|---|
| 418521 | レポートの ConsumeContainerWhitespace プロパティが TRUE に設定されている場合、および入力できる水平方向の空白がある場合、HTML レンダラーは ArgumentOutOfRangeException 例外をスローしなくなりました。 |
| 346804 | 修正: "FORCESEEK" インデックス ヒント構文がオプション パラメーターを受け取るようになりました。 新しい FORCESCAN クエリ ヒントが追加されます。 詳細については、「クエリ ヒント (Transact-SQL)」(http://msdn.microsoft.com/en-us/library/ms181714.aspx) を参照してください。 |
| 405562 | SQL Server Native Client 2008 では、ローカル インスタンスに接続するために、'server="tcp:"' や 'server="np:"' などの接続文字列がサポートされています。 この修正により、これらの接続文字列が SQL Server Native Client 2008 R2 で動作し、ローカル インスタンスへの接続が可能になります。 |
| 447996 | インデックス付きビューのパーティション化された列が、ベース パーティション テーブルのパーティション化された列と一致する場合、ロジック チェックの問題は発生しなくなりました。 パーティションにアライメントされていないインデックス ビューでは、テーブルの変更切り替えが有効ではなくなりました。 |
| 471571 | SQL 10.5 BIDS を使用してレポート パーツを SQL Server 2008 R2 (以降のバージョン) に展開すると、レポート サーバーが失敗したり、SQL バージョン管理エラー メッセージが生成されたりしなくなりました。 |
| 512199 | 拡張イベントまたは SQL 監査ファイルが、ファイルを生成したコンピューターとは異なるコンピューターで読み取られた場合に、タイムスタンプが正確になりました。 サーバーの再起動後もタイムスタンプが正確になるようになりました。 |
| 528501 | レポート名にスペースが含まれている場合は、Reporting Services 2008 R2 を使用して同期表示モードでレポートをレンダリングする Web パーツを表示できるようになりました。 StreamNotFound エラー メッセージは生成されなくなりました。 |
| 538455 | "StyleStream" DeviceInfo 設定を TRUE に設定して HTML に表示する場合、アクションが定義されている場合、テキスト ボックスまたはテキスト上のスタイル設定は失われなくなります。 |
| 540725 | エンジン サービスと分析サービス用に 2 つの新しいトレース テンプレート ファイルが生成されます。 これにより、プロファイラーはエンジンと分析サービスの両方のすべてのイベントと列を表示できます。 |
| 550635 | 修正: VertiPaq モードで実行されている Analysis Services について SP 2010 Health Analyzer からエラー メッセージが返される場合の、誤ったテキストのレポートが表示される。 |
| 550947 | 入れ子になったコンテナー レポート項目 (Rectangle と Tablix) を含む行が 20 以上ある Tablix レポート項目では、Tablix メンバーの上下に新しい行を挿入しても、BIDS シェルが応答しなくなることはなくなりました。 |
| 555701 | DBM オブジェクトの起動時に、アウト オブ オーダー メッセージによってアクセス違反エラーが発生しなくなりました。 |
| 617987 | [新しいサーバーのインストール] で、BI アプライアンスのインストール時に Secure Store マスター キーが生成されないという報告がなくなりました。 (メッセージは、インストールが成功した場合でも生成されました。) |
| 623819 | クエリ オプティマイザーがパーティション分割ビューに対する一部のクエリのプランを生成できなかった場合にエラー メッセージが表示される問題を修正しました。 これについては、「Microsoft Connect の問題 620614」を参照してください。 この修正は、traceflag の下にあります (サポート技術情報の記事 974006 を参照してください)。 |
| 624909 | 1 つの SharePoint ページに複数の Web パーツがある場合に、レポート ビューアーを使用したり HTML に表示したりしても、パフォーマンスが低下しなくなりました。 |
| 624951 | ReportViewer コントロールを含む WPF アプリケーションを閉じるときに、"appdomain のアンロード中にエラーが発生しました" という例外が表示されなくなりました。 |
| 626205 | Analysis Services は、不明なメンバーに関連するディメンション メンバーを持つサーバー キューブからローカル キューブを作成できません。 |
| 626243 | SQL Server 共有コンポーネントが既定以外の場所にインストールされている場合、PowerPivot は既存のファームに正常にインストールされるようになりました。 |
| 629973 | 次の操作を行っても、BIDS と Report Builder 3 がクラッシュしなくなりました。表のセルの罫線でドラッグし、"レポート アイテムの移動" モードに入り、テーブルの外にオブジェクトを移動し、Esc キーを押しながらマウス ボタンをクリックしたまま押します。 |
| 636999 | Upgrade Advisor がトレース・ファイルをスキャンできない場合、Upgrade Advisor は、意味のあるエラー・メッセージをユーザーに表示できるようになりました。 |
| 639182 | Report Builder 3.0 の [ログオン] ダイアログ ボックス。 これは、フォーム認証が SSRS に使用されている場合に呼び出され、[新しいレポート ウィザード] モーダル ダイアログ ボックスによって隠されなくなりました。 (この問題のため、ユーザーはログオンが要求されていることに気付かない可能性があります)。 |
| 643961 | すべての特定のユーザー アカウント オプションがデータ ソース スケジュールで機能するようになりました。 |
| 646473 | .NET Framework 4.0 環境で設計されたアプリケーションでは、RBS が構成情報を見つけられない場合でも失敗しなくなりました。 この情報は、.NET Framework 4.0 と ..NET Framework 3.5 の両方の構成ファイルで検索されるようになりました。 |
| 658405 | IT 管理ダッシュボードの .odc ファイルを使用して、カスタム レポートを作成できるようになりました。 |
| 665971 | 並列処理演算子の転送行が正しい順序になっているようになりました。 オプティマイザーは、最適でないプランを選択できるようになりました。 したがって、この修正プログラムには traceflag が必要です。 この修正プログラムを使用するには、traceflag 4134 を有効にする必要があります。 |
| 674357 | エンジン サービス用と分析サービス用に 2 つの新しいトレース テンプレート ファイルが生成されるようになりました。 これを行うと、Profiler が両方のサービスのすべてのイベントと列を表示できることを確認します。 |
| 679035 | サーバーの管理ページの軽微な入力ミスを修正しました。 |
| 684435 | StringCchPrintf_l想定されている出力先バッファーのサイズ (文字数)。 サイズはバイト単位で渡されました。 したがって、OACR エラー - BUFFER_OVERFLOWが発生しました。 正しい長さを渡すことで、コードを修正しました。 |
| 649475 | SQL インスタンス名が仮想ネットワーク名と同じ場合、クラスターでパフォーマンス カウンターを収集すると、コレクション セットが正しく機能しません。 |
| 649357 | 特定のデータベースで、任意のシステム ビューを含む select ステートメント用に宣言されたサーバー ポインターを使用すると、データベースがアタッチされて再アタッチされた後に正しくない結果が得られる可能性があります。 |
| 649391 | SQL Server 2008 R2 の照合順序で、日本語拡張記号に続く Jamo シーケンスを含む文字列を使用すると、DBCC 破損エラーが発生する。 |
| 657399 | 間違ったバージョン番号が SQL Server Management Studio と SQL Server Reporting Services に表示されます。 これにより、アップグレードの実行後に表示される番号が RTM バージョン番号と異ならないため、混乱が生じます。 |
| 649476 | 修正: パラメーターの処理中に特定の条件が発生した場合に、詳細出力の InvalidReportParameterException に関する追加情報がログに記録されるようになりました。 |
| 649557 | 修正: Microsoft Active Accessibility の "Symbol" の名前が null であるために発生するアクセシビリティの問題。 Microsoft Active Accessibility の名前が更新され、検出可能になりました。 |
| 649447 | ReportBuilder 2.0 ユーザーが SharePoint 12 Web サイトから ReportBuilder 2.0 を使用してレポートを編集すると、ClickOnce の起動時に空白のレポートが表示されます。 |
| 649575 | [放射状スケール プロパティ] ダイアログ ボックスの MSAA 名が正しくなく、アクセシビリティに準拠していません。 |
| 519534 | LOB 列にテーブル値パラメーターを使用すると、サーバーでアクセス違反が発生する可能性があります。 |
| 645824 | 高ストレス条件下で拡張ストアド プロシージャを実行すると、アクセス違反エラーが発生する場合があります。 |
| 649559 | 修正: 多くのパーティションを持ち、データが含まれていないテーブルの DDL ステートメントによるインデックス作成のパフォーマンスが向上しました。 以前は、パーティションの数が増えるにつれて、このプロセスに必要な時間は幾何学的な数列で増加していました。 必要な時間は、直線的な進行で増加します。 |
| 649537, 448009 | 特定の条件では、エラー メッセージ 11405 のパーティション分割された列名が間違っている場合があります。 これにより、誤った列名が印刷されます。 |
| 649530 | Analysis Services が Watson ダンプ ファイルを生成すると、セカンダリ例外が発生する場合があります。 これは、実際の例外のために Watson ダンプ・ファイルが生成されるか、特定のエラーでダンプするための明示的な要求のために生成されるかに関係なく当てはまります。 2 次例外が発生した場合、サーバーでは無限再帰が発生する可能性があります。 これにより、多数のダンプ ファイルが生成され、サーバーがシャットダウンされます。 |
| 649524 | ユーザーが同じトランザクションでユーザー定義型とテーブル値関数を作成し、その関数にユーザー定義型の列を含む戻りテーブルがある場合、自己デッドロックが発生します。 さらに、これらの操作を実行しようとする接続は停止されます。 |
| 649532 | 列名に CELL_ID、CELL_ATTRIBUTES、または SRID を使用するテーブルでは、空間インデックスを安全に作成することはできません。 |
| 657405 | SQL Server によって、"リソース プール 'internal' にこのクエリを実行するためのシステム メモリが不足しています" というエラー メッセージが生成されることがあります。 この状況は多くの場合、防ぐことができます。 |
| 649434 | SQLBindParameter 関数によってバインドされたパラメーターに長さ SQL_DATA_AT_EXEC を指定すると、実行のためにパラメーター値が指定されたときに SQLPutData 関数が SQL_NULL_DATA の長さを指定すると、SQL Server 2008 R2 Native Client ODC ドライバーによってアクセス違反が発生します。 |
| 512170 | MARS を使用する場合、sys.dm_os_tasks ビューでは、各タスクに関連付けられている正しい値が報告されるのではなく、すべてのタスクのrequest_id列に同じ値が表示されます。 |
| 649425 | sys.dm_os_wait_stats ビューには、[その他の] 待機の種類の重複行が表示されます。 これにより、監視ツールで問題が発生する可能性があります。 |
| 649346 | 非同期バケット ターゲットは、dm_xe_map_values で使用可能な情報と比較すると、マップされたフィールドに対して正しくない値/文字列のペアを表示します。 |
| 649340 | 修正: syscolpars システム ベース テーブルに重複する行が表示されました。 この修正プログラムでは、DBCC checkcatalog にプロシージャ番号を追加することで、それらを区別します。 |
| 649427 | 修正: CLR v4 などの新しいランタイムに対してビルドされた CLR アセンブリをユーザーが登録しようとすると、新しいエラー コード (6257) が返されます。 前のエラー メッセージ (コード 6218) は混乱を招き、実際の問題を示していませんでした。 詳細については、バグを参照してください。 |
| 649433 | エッジ ケースは、"設定identity_insert TABLE_NAMEオン" モードで、現在の範囲外の ID 値を挿入します。 この問題は、バックアップ/復元操作でも発生します。 |
| 649450 | BCP.exe が列メタデータ情報を取得するときに、誤った列照合順序情報が返されます。 |
| 649527 | Null メンバー パラメーターを持つ PeriodsToDate 関数を使用すると、"予期しない例外" エラーが発生する可能性があります。 |
| 649341 | クエリにsys.dm_server_audit_statusビューの列を参照するフィルターがある場合、フィルターは無視され、すべての行がsys.dm_server_audit_statusから返されます。 |
| 629570 | サーバー上にオンラインではないデータベースがある場合、ユーザーが Management Data Warehouse を構成しようとすると、エラー 955 が発生します。 |
| 649374 | リング バッファーが XML 出力のサイズ制限に達すると、不完全なイベント データ (dm_xe_session_targetsからのイベント出力) が表示されます。 |
| 677560 | SQL Server 2008 R2 でリモート クエリによって 7359 エラー コードが発生する問題を修正します。 この問題は、ユーザー定義関数がリンク テーブルのシノニムを使用し、ユーザー定義関数の実行プランがローカル サーバーに存在し、リンク テーブルのスキーマ バージョンがリモート サーバーで更新される場合に発生します。 |
| 562310 | データベース db1 が作成され、db1 のクエリがキャッシュされてから db1 が削除され、2 つ目のデータベースが作成され、db1 が再度作成され、キャッシュされたクエリが再実行されたときに発生する「Read AV in FullXactImpBase::GetXdes xact.cpp @ 2536」エラーを修正します。 |
| 623804 | トリガー本体内で実行されるクエリからの正しくない結果を修正します。 このシナリオでは、一意のフィルター インデックスが必要です。 トリガーには、列がテーブル全体に対して一意であるかどうかによって影響されるクエリが含まれている必要があります。 |
| 636156 | データベースで透過的なデータベース暗号化が有効になっていて、ページ チェックサムがオンになっていて、バックアップでチェックサムが使用されている場合に、バックアップが破損する問題を修正します。 |
| 657511 | 修正プログラム: この修正プログラムは、多くのサブスクリプションが同時に処理されるときにサブスクリプション処理中に発生する可能性があるタイムアウトとデッドロックを解決します。 この修正プログラムは、Reporting Services が SharePoint 統合モードで展開されている場合に適用されます。 |
| 676139 | 顧客が並べ替えを行う必要があり、並べ替えページがディスクにスピルしてしまう問題を修正します。 さらに、TDE スキャンは、その特定のページと同時に接触します。 コンピューターを再起動すると、問題を回避できます。 ただし、TDE を無効にしない限り、この問題を完全に回避することはできません。 |
| 676491 | VSTS のバグ 473052 で説明されている修正プログラムを適用した後に発生する可能性のある問題を修正します。 |
| 679886 | 収集された拡張イベントまたは SQL 監査証跡ファイルに誤ったタイム スタンプ情報が表示される可能性がある問題を修正します。 |
| 686401 | C# の null 値が永続化する前に dbNull に変換される問題を修正します。 |
| 620861 | 修正: Microsoft SQL Server 2008 R2 SP1 の Datacenter、Enterprise、Developer、および Evaluation エディションのテーブルとインデックスで最大 15,000 個のパーティションがサポートされます。 このサポートを有効または無効にする方法、その制限事項、およびいくつかの既知の問題と回避策の詳細については、「15,000 パーティションのサポート」ホワイト ペーパーを参照してください https://go.microsoft.com/fwlink/?linkid=199773 |
| 296354 | 修正: SqlDumperDumpTimeOut プロパティの既定値が、Microsoft SQL Server 2008 R2 SP1 の有効な範囲内にありません。 有効な値の範囲は 0 (ミリ秒) から MAXDWORD です。 |
| 417616 | 修正: サービス アカウントの SPN を取得するロジックが常にログに記録されるように設定されるようになりました。 この修正プログラムを適用する前に、ロジックは EP がオンになっている場合にのみログに記録されるように設定されています。 この情報は、Kerberos の問題のトラブルシューティングに使用できます。 |
| 517329 | プログラムの欠陥により、さまざまな診断ツールでクエリが、実際に実行されたデータベースではなく、マスター データベースで実行されたと報告される。 |
| 615697 | Microsoft SQL Server 2008 以降のバージョンの SQL Server では、重要な機能の SQM ポイントがありません。 この修正により、顧客の使用状況メトリックを追跡するのに役立つ重要な SQM ポイントがいくつか追加されます。 |
| 645245 | 修正: 再接続と再実行ロジックが、SQL エディターのクエリ実行コード パスから削除されます。 Microsoft SQL Azure のアイドル接続タイムアウト期間が 30 分に増えたため、この情報は不要になりました。 |
| 674580 | Profiler がすべてのイベントと列を表示できるように、Analysis Services の新しいトレース テンプレート ファイル ("Microsoft Analysis Services TraceDefinition 10.50.0.xml") を再生成して、新しく追加したトレース イベントを含める必要があります。 |
| 707007 | ダラスのシナリオではインポートが失敗します。 |
| 710263 | Internet エクスプローラー 9 がブラウザーとして使用されている場合、レポート ギャラリーでスナップショットを生成しようとするとエラーが返されます。 |
| 710433 | 修正プログラム: .sql ファイルをダブルクリックしたときに、ssms.exe へのパラメーターとしてファイル名が渡されるようにレジストリが更新されます。 |
| 656177 | 修正プログラム: ストアド プロシージャまたはユーザー定義関数を使用して SQL Server 2008 または SQL Server 2008 R2 でテーブル変数を作成すると、アクセス違反が発生する |
参考資料
現在の SQL Server のバージョンとエディションを確認する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
321185
SQL Server のバージョンとエディションを識別する方法
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。