はじめに
この記事では、Microsoft SQL Server 2008 R2 Service Pack 2 (SP2) で修正されるバグの一覧を示します。
メモ
- ドキュメントに記載されていないその他の修正プログラムも、Service Pack に含まれている可能性があります。
- この一覧は、さらに資料が公開されたときに、更新される予定です。
SQL Server 2008 R2 Service Pack の入手方法の詳細については、以下のサポート技術情報番号をクリックしてください。
2527041 SQL Server 2008 R2 の最新の Service Pack を入手する方法
追加情報
この記事に記載されている修正プログラムに加えて、SQL Server 2008 R2 SP2 には、SQL Server 2008 R2 Service Pack 1 (SP1) の累積的な更新プログラム 1 から累積的な更新プログラム 5 に含まれていた修正プログラムが含まれています。
注: SQL Server 2008 R2 SP1 累積的な更新プログラム 6 からアップグレードする場合は、SQL Server 2008 R2 SP2 にアップグレードした後、SQL Server 2008 R2 SP2 以降の累積的な更新プログラムを適用して、すべての修正プログラムを入手する必要があります。
SQL Server 2008 R2 SP1 で利用可能な累積的な更新プログラム パッケージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
2567616 SQL Server 2008 R2 Service Pack 1 以降にリリースされた SQL Server 2008 R2 のビルド
この Service Pack で修正される問題
SQL Server 2008 R2 SP2 で修正される問題の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
| VSTS バグ番号 | サポート技術情報番号 | 説明 |
|---|---|---|
| 820875 | 922578 | 修正:SQL Server 2005、SQL Server 2008、または SQL Server で SQL Server プロファイルを使用すると、SQL Server 2005、SQL Server 2008、または SQL Server 2008 R2 エラーログ ファイルに、メッセージ ID 19030、メッセージ ID 19031 のメッセージを多数記録する2008 R2 |
| 728527 | 2216456 | SQL Server 2008 Service Pack 2 および SQL Server 2008 R2 Service Pack 2 による Analysis Services の "操作が取り消されました" エラー メッセージ テキストへの機能強化 |
| 820858 | 2550375 | 修正: 多数のデータベースから 1 つのセカンダリ サーバー sys.dm_database_encryption_keysログ配布を実行すると、SQL Server 2008 R2 の DMV でデッドロックが発生する可能性がある |
| 820878 | 2565683 | 修正: SQL Server 2008 または SQL Server 2008 R2 環境で、サブクエリに集計関数、結合関数、個別関数を含む複雑なクエリを実行すると、誤った結果が得られる場合がある |
| 820756 | 2588050 | 修正: データベース エンジンがインストールされている場合、SQL インスタンスに新しい機能を追加すると、SQL Server 2008 または SQL Server 2008 R2 Service Pack のスリップストリーム インストールが失敗する |
| 901689 | 2653857 | 修正: JRE 6 Update 29 以降のバージョンにアップグレードすると、JDBC Driver for SQL Server を使用して SQL Server に接続できない |
| 873603 | 2682488 | 修正: 変更追跡を有効にした後、SQL Server 2008、SQL Server 2008 R2、または SQL Server 2012 データベースでバックアップ操作が失敗する |
| 958983 | 2719217 | 修正: ヒープ テーブルがある場合、および SQL Server 2008 R2 または SQL Server 2012 でデータ圧縮が有効になっている場合のラッチ タイムアウト エラー |
この CTP バージョンの Service Pack で修正されるその他の問題
以下の問題に対する解決策は、SQL Server 2008 R2 SP2 にも含まれています。
| VSTS バグ番号 | 説明 |
|---|---|
| 820845 | BindParameter メソッドの使用と、このメソッドで使用される長い型のパラメーターの参照にうれしく思います。 |
| 852397 | ConfigurationState をリセットするときに RebuildDatabase シナリオを含めるUpdates UpgradeIncompleteFeatureConfigEventHandler.cs。 |
| 887672 | [ブラウザーでドキュメントを開く] 設定が [クライアント アプリケーションで開く] に設定されているドキュメント ライブラリの場合、GetSnapshot.exe は構成を無視し、設定が [ブラウザーで開く] であるかのように常にExcel Servicesを使用してブックを表示します。 |
| 820805 | 修正: Reporting Services Configuration Manager のロシア語ローカライズされたビルドでは、実行アカウント情報にクリップされた文字列が含まれています。 |
| 718430 | ExpectedCount と ExpectedElapsedMs の使用回数は、実際の回数を反映するように更新されます。 |
| 737914 | データベースの同期中に SQL Server 2008 R2 Analysis Services がクラッシュする問題を修正します。 |
| 788389 | トレース フラグ 1264 が削除されるため、プロセス名は、生成されないシナリオ ダンプで既定で収集されます。 非生成シナリオ ダンプ ファイルのスレッド レコード数が 1K から 16K に増加しています。 |
| 820762 | SQL Server 2008 R2 では、イベントをログに記録する必要がある場合に FireAgain パラメーターを True に変更します。 ただし、一部のコードが誤って削除された後、FireAgain パラメーターは外部イベント リスナーによってのみ決定されるため、一部のログが失われます。 この修正プログラムを適用すると、問題は解決されます。 |
| 820764 | 次のような状況を想定します。 SQL Server 2008 R2 のベース テーブルとベース以外のテーブルのビュー プロジェクト列にインデックスが付けられている。 ベース テーブル以外の列の注文 ID と型は、ベース テーブルの列と同じです。 このシナリオでは、SQL Server 2008 R2 によってパーティションが切り替わります。 修正プログラムを適用すると、パーティションが切り替わる代わりに、SQL Server 2008 R2 でエラーが発生します。 |
| 820792 | SOS_Task PMO に割り当てられたオブジェクトが、有効期間が異なる別のタスクでも使用される可能性がある問題を修正します。 この Service Pack では、オブジェクトの割り当てに正しい PMO が使用されます。 |
| 820796 | 修正プログラムを適用すると、オプティマイザーは、CRYPT_GEN_RANDOM が同じ入力に対して異なる出力を返す可能性があることを認識します。 |
| 820859 | SCOPE_IDENTITY() を実行したときに間違った値が返される問題を修正します。 |
| 820864 | Shiloh OLAP SP3a を使用して SxS をインストールすると、SQL Server 2008 R2 のセットアップがクラッシュする問題を修正します。 この問題は、Shiloh OLAP SP3a でバージョン レジストリ キーが誤って "Service Pack 3.0" と書き込まれるために発生します。 |
| 820873 | 並列クエリ プランが関係している場合に、誤った CPU 時間が sys.dm_exec_query_stats によって報告される問題を修正します。 |
| 820880 | 内部の非同期ファイル読み取りバッファーによって複数文字の列区切り記号が 2 つの部分に分割されるときに発生する問題を修正します。 この問題を解決するには、バッファーが切り替えられた後に、現在の解析ポインターが正しくリセットされるようになっています。 |
| 847805 | 同期は、SQLWixCompilerExtension 操作がキャンドルで実行された場合にのみ使用します。 |
| 890643 | 階層の派生部分にのみ適用される明示的な上限の特定のコード パスを回避するように、HierarchyGet 操作を変更します。 更新プログラムは、危険度の低い 1 行の更新プログラムです。 |
| 731796 | snapshots.notable_query_text から消去するときにステートメントにエラーが表示される問題を修正します。 |
| 820829 | フラット ファイルから解析される不適切な GUID 値がエラーの原因になることがあります。 この修正プログラムでは、ソース バッファーが GUID 文字列の最大サイズより大きい場合、切り捨てモードにフォールバックします。 |
| 677173 | 起動時の計算エラーによる変動を回避するために、ラッチ プロモーションしきい値を定期的に再計算します。 |
| 725819 | 推奨される修正方法は、発信者と呼び出されたユーザーの間で通話規則を一致させることです。 |
| 769975 | コンピューターに空のプロセッサ スロットがある場合、または再起動オプション /setgroupsize が使用されている場合の起動時のクラッシュを修正します。 |
| 788233 | スピンロックが発生したときにラッチがバックオフする時間を短縮します。 これにより、パフォーマンスが向上します |
| 840461 | XE セッションの起動中に SQL Server のクラッシュを引き起こす可能性がある競合状態を修正します。 |
参考資料
現在の SQL Server のバージョンとエディションを確認する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
321185
SQL Server のバージョンとエディションを識別する方法
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。