現象
データベース ファイルをAzure Premium Storageに保存することを想定しています。 SQL Server 2014 のデータベースで DBCC CHECKDB を実行すると、次のようなエラー メッセージが表示されることがあります。
注
メッセージ 1823、レベル 16、状態 2、行 3
データベース スナップショットは、起動に失敗したため作成できません。
メッセージ 1823、レベル 16、状態 8、行 3
データベース スナップショットは、起動に失敗したため作成できません。
メッセージ 5120、レベル 16、状態 147、行 3
物理ファイル blob_storage_URL_pathを開くことができません。 オペレーティング システム エラー 24: "24(プログラムはコマンドを発行しましたが、コマンドの長さが正しくありません)。)。
メッセージ 7928、レベル 16、状態 1、行 3
オンライン チェック用のデータベース スナップショットを作成できませんでした。 前のエラーで理由が示されているか、基になるボリュームのいずれかがスパース ファイルまたは代替ストリームをサポートしていません。 オフラインでチェックを実行するために排他的アクセスを取得しようとしています。
メッセージ 5030、レベル 16、状態 12、行 3
操作を実行するためにデータベースを排他的にロックできませんでした。
メッセージ 7926、レベル 16、状態 1、行 3
Check ステートメントが中止されました。 データベースを作成できなかったスナップショット、データベースまたはテーブルをロックできなかったので、データベースをチェックできませんでした。 この動作が予期されるタイミングと、どのような回避策が存在するかの詳細については、「オンライン ブック」を参照してください。 詳細については、以前のエラーも参照してください。
解決策
この問題は、SQL Serverの次の累積的な更新プログラムで最初に修正されました。
SQL Server 2014 Service Pack 1 の累積的な更新プログラム 8
SQL Server 2014 SP2 の累積的な更新プログラム 2
SQL Server 用の累積的な更新プログラムについて
SQL Serverの各新しい累積的な更新プログラムには、すべての修正プログラムと、以前の累積的な更新プログラムに含まれていたすべてのセキュリティ修正プログラムが含まれています。 SQL Serverの最新の累積的な更新プログラムを確認してください。
SQL Server 2014 SP1/SP2 の最新の累積的な更新プログラム
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
参考資料
Azure Storage 上のデータ ファイルのPremium Storageサポート
SQLXI を使用して Azure Blob Storage に直接SQL Server 2014 データベースを作成する
Microsoft がソフトウェア更新プログラムの説明に使用する 用語 について説明します。