現象
Windows Server 2012 R2 を実行しているサーバーまたは Windows Server 2008 R2 Service Pack 1 (SP1) があることを想定しています。多くのユーザーは、特定リモート デスクトップ アプリケーションを使用してサーバーに接続します。このような場合は、次のレジストリ ハイブのサイズが制限を超える可能性があります。
HKEY_USERS\.DEFAULTしたがって、ユーザーは、サーバーに接続できません。
原因
この問題は、印刷スプーラーのモジュールで発生するエラーのため発生します。ユーザーは、新しいサーバーにリモート デスクトップ セッションを確立すると、ユーザーのプリンターの設定は次のレジストリ サブキーに書き込まれます。
HKEY_USERS\.DEFAULT\Printers\DevModes2ただし、プリンターの設定は削除されません。したがって、次のレジストリ ハイブのサイズになりより大きなサイズが大きくなると、この現象、さまざまな問題が生じる。
HKEY_USERS\.DEFAULT
解決策
Windows Server 2012 R2 の更新プログラムのロールアップ
Windows Server 2012 R2 でこの問題を解決するには、更新プログラム 2955164 をインストールします。詳細については 2955164 の更新は、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。
2955164 Windows RT 8.1、Windows 8.1 では、Windows Server 2012 R2 更新プログラムのロールアップ: 月 2014年Windows Server 2008 R2 でこの問題を解決するには、この資料に記載されている修正プログラムをインストールします。
Windows Server 2008 R2 の修正プログラムの情報
サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、この資料に記載された問題があったシステムのみに対して適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。
修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。 注: さらなる問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要な場合があります。この修正プログラムの対象外の追加の質問および問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス サポートの電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。http://support.microsoft.com/contactus/?ws=support注: [修正プログラムのダウンロード] フォームには、修正プログラムが提供されている言語が表示されます。お使いの言語が表示されない場合は、その言語の修正プログラムが利用できないためです。
レジストリ ハイブを圧縮します。
サイズが制限を超える場合は、次のレジストリ ハイブを圧縮することをお勧めこの更新プログラムをインストールした後:HKEY_USERS\。デフォルトのでレジストリ ハイブを圧縮する手順を次のマイクロソフト サポート技術情報。
ハイブをレジストリの「肥大化」を圧縮する方法 注: 次の