メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

この資料は、すべての地域の Microsoft Dynamics AX に適用されます。

現象

エンタープライズ ポータルの配置 Microsoft Dynamics AX 2012 の R2 の環境では、ASP.NET の偽装があり、クレーム ベース認証を有効に、配置は失敗します。さらに、次のエラー メッセージが表示されます。

Microsoft.Dynamics.Framework.BusinessConnector.Session.Exceptions.NoKernelSessionException

原因

この問題は、Microsoft SharePoint 製品とテクノロジは、Microsoft .NET Business Connector (BC) のプロキシ アカウントまたは Microsoft Dynamics AX で登録されているアカウントのいずれかを偽装できないために発生します。既定では、クレーム ベース認証が有効になっているときに SharePoint ワーカー プロセスを Authority\IUSR の NT ユーザー アカウントとして実行します。さらに、SharePoint web アプリケーションでは、Web.config ファイルに次の構成設定があります。

AllowAnonymousImpersonation = Trueしたがって、Microsoft Dynamics AX アプリケーション オブジェクト サーバー (AOS) は、AOS にアクセスする要求を拒否します。

解決策

この問題を解決するには、「ファイル情報」セクションに記載されている修正プログラムをインストールします。さらに、次のマイクロソフト web サイトで説明するようにフォーム ベース認証を使用してクレーム ベースのエンタープライズ ポータル サイトを展開する必要があります。

エンタープライズ ポータルおよびロール センター [AX 2012] を展開します。

修正プログラムの情報

サポートされている修正プログラムは、マイクロソフトから入手可能です。このサポート技術情報の記事の上部に「修正プログラムのダウンロード」セクションがあります。発生している問題をダウンロードする、この修正プログラムをインストールした場合、またはその他のテクニカル ・ サポートのご質問がある場合、パートナーにお問い合わせくださいまたは場合は、マイクロソフトから直接サポート プランに登録すると、Microsoft Dynamics のテクニカル サポートに連絡して新しいサポート要求を作成します。 そのために以下のマイクロソフト ウェブサイトに移動してください。

https://mbs.microsoft.com/support/newstart.aspx国別の電話番号のリンクを使用して、電話で Microsoft Dynamics のテクニカル サポートに問い合わせるもできます。 これを行うには、次のマイクロソフト web サイトのいずれかを参照してください。

パートナー

https://mbs.microsoft.com/partnersource/support/お客様

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmかかる料金が免除されるテクニカル サポート担当者 Microsoft Dynamics および関連製品のことは、通常は特別な場合は、特定の更新プログラムは、問題を解決するにを決定します。追加の質問および問題の特定の更新プログラムの対象とならない問題は、通常のサポート料金が適用されます。

インストール情報

メソッドまたはこの修正プログラムの影響を受けるテーブルの 1 つ以上のカスタマイズがあれば、運用環境で修正プログラムを適用する前にテスト環境でこれらの変更を適用する必要があります。

この修正プログラムをインストールする方法の詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。

Microsoft Dynamics AX の修正プログラムをインストールする方法を893082

必要条件

Microsoft Dynamics AX 2012 R2 のこの修正プログラムを適用するためにインストールする必要があります。

再起動の必要性

修正プログラムを適用した後、アプリケーション オブジェクト サーバー (AOS) サービスを再起動する必要があります。

この修正プログラムのグローバル バージョンには、次の表に記載されているファイル属性 (またはそれ以降のファイル属性) が含まれています。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

サービス区分

Aximpactanalysis.exe

該当なし

61,136

13-Dec-2012

02:19

x86

該当なし

Axupdate.exe

該当なし

61,120

13-Dec-2012

02:19

x86

該当なし

Dynamicsax2012r2-kb2824690-foundation.axmodel

6.2.1000.619

61,784

08-Mar-2013

03:43

該当なし

該当なし

Dynamicsax2012r2-kb2824690-syplabels.axmodel

6.2.1000.619

1,010,008

08-Mar-2013

03:43

該当なし

該当なし

Clientoba32.msp

該当なし

19,017,728

20-Mar-2013

01:52

該当なし

該当なし

Clientoba64.msp

該当なし

19,185,664

20-Mar-2013

01:52

該当なし

該当なし

Commercedataexchangereal-timeservice.msp

該当なし

49,152

20-Mar-2013

01:52

該当なし

該当なし

Commercedataexchangesynchservice32.msp

該当なし

122,880

20-Mar-2013

01:52

該当なし

該当なし

Commercedataexchangesynchservice64.msp

該当なし

122,880

20-Mar-2013

01:52

該当なし

該当なし

Components32.msp

該当なし

16,834,560

20-Mar-2013

01:52

該当なし

該当なし

Components64.msp

該当なし

34,217,984

20-Mar-2013

01:53

該当なし

該当なし

Objectserver32.msp

該当なし

6,782,976

20-Mar-2013

01:52

該当なし

該当なし

Objectserver64.msp

該当なし

14,688,256

20-Mar-2013

01:55

該当なし

該当なし

Retaildatabaseutility.msp

該当なし

524, 288

20-Mar-2013

01:52

該当なし

該当なし

Retailheadquarters32.msp

該当なし

2,752,512

20-Mar-2013

01:52

該当なし

該当なし

Retailheadquarters64.msp

該当なし

2,752,512

20-Mar-2013

01:52

該当なし

該当なし

Retailonlinechannel.msp

該当なし

2,736,128

20-Mar-2013

01:55

該当なし

該当なし

Retailpos.msp

該当なし

4,280,320

20-Mar-2013

01:55

該当なし

該当なし

Retailposplugins.msp

該当なし

47,906,816

20-Mar-2013

01:55

該当なし

RETAILPOSP

Setupsupport32.msp

該当なし

6,086,656

20-Mar-2013

01:55

該当なし

該当なし

Setupsupport64.msp

該当なし

13,348,864

20-Mar-2013

01:55

該当なし

該当なし

Axsetupsp.exe

6.2.139.8316

1,390,784

13-Dec-2012

02:19

x86

該当なし

Axutillib.dll

6.2.120.0

929,560

20-Mar-2013

02:20

x86

該当なし

Microsoft.dynamics.servicing.operations.dll

6.2.73.8303

37,168

19-Nov-2012

10:17

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

387,368

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

370,984

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

383,272

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

395,560

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

387,368

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

379,176

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

395,560

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

375,080

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

416,040

20-Mar-2013

02:20

x86

該当なし

Axsetupsp.resources.dll

6.2.147.8303

370,984

20-Mar-2013

02:20

x86

該当なし


状況

マイクロソフトは、この問題を「対象製品」セクションに記載されているマイクロソフト製品の問題として認識しています。

注: これは、マイクロソフト サポートの組織内から直接作成した「高速公開」の資料です。ここに含まれる情報は、新たに発生している問題に応じて現状のまま提供されています。速やかに利用できるようにした結果として、内容には誤植が含まれている可能性があり、事前告知なしで改訂する場合があります。その他の考慮事項については、使用条件を参照してください。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×