UML シーケンス図を作成する

適用先
Visio Plan 1 Visio Professional 2024 Visio Professional 2021 Visio Professional 2016

UML シーケンス図は、時間 の経過とともに一連のオブジェクトがプロセス内でどのように相互作用するかを示します。 参加者とシステム内のオブジェクトの間で受け渡されるメッセージと、メッセージが発生する順序を示します。

ATM システムを示す UML シーケンス図のサンプルのスクリーンショット。

シーケンス図を作成するには、 UML シーケンス テンプレートまたは UML シーケンス ステンシルを含むスターター図を使用します。 ステンシルから描画キャンバスに図形をドラッグして図面を作成します。

シーケンス図を開始する

  1. Visio を起動します。 または、既にファイルを開いている場合は、[ ファイル>新規作成] を選択します。
  2. [検索] ボックスに「 UML sequence」と入力します。
  3. UML シーケンス図を選択します。
  4. ダイアログ ボックスで、空のテンプレートまたは 3 つのスターター図のいずれかを選択します。 (選択すると、各項目の説明が右側に表示されます。)次に、[ メートル法 ] または [米国単位] を選択します。
  5. [作成] を選択します。
  6. ダイアグラムが開きます。 図の横に [図形] ウィンドウが表示されるはずです。 表示されない場合は、[表示] >[作業ウィンドウ] に移動し、[図形] が選択されていることを確認します。 それでも表示されない場合は、左側の [ 図形ウィンドウの展開 ] ボタンを選択します。
  7. [表示] タブで、[接続ポイント] の横のチェック ボックスがオンになっていることを確認します。 このオプションをオンにすると、図形の接続を開始するときに接続ポイントが表示されます。
  8. 次に、図に取り込みたい図形を、[図形] ウィンドウからページにドラッグします。 テキスト ラベルの名前を変更するには、ラベルをダブルクリックします。

アクターとオブジェクトの生存線

各参加者には [アクター生存線 ] 図形を使用し、プロセス内のシステム コンポーネントごとに [オブジェクト生存線] 図形を使用します。

UML シーケンスの生存線のスクリーンショット

ヒント

ライフラインを所定の位置にドラッグすると、緑色の配置ガイドが画面に表示され、他のライフライン図形に対してライフラインを並べたり間隔を置いたりするのに役立ちます。

  • 各生存線の見出しボックスをダブルクリックして、名前またはタイトルを入力します。
  • タイムラインを延長または短縮するには、生存線を選択し、生存線の下部にある黄色のコントロール ポイントをドラッグします。

メッセージ

メッセージの図形を使用して、生存線間で送信される情報を表します。

UML シーケンス メッセージのスクリーンショット

ヒント

Visio を使用すると、メッセージのエンドポイントを各生存線に接着できます。 接続ポイントにつながれると、緑色の丸が端点に表示されます。 接続ポイントは、ドラッグが終わると消えます。

  • 開始エンドポイントをメッセージを送信するライフラインにアタッチし、もう一方のエンドポイントをメッセージを受信するライフラインにドラッグします。

  • メッセージ図形をダブルクリックしてテキスト ボックスを作成し、メッセージの名前を入力します。

  • メッセージの図形 (実線) は、情報の要求または送信を表すために使用します。

  • [ 返信メッセージ] 図形 (破線) は、前のメッセージへの応答を表すために使います。

  • Self Message は、操作の再帰呼び出しや、あるメソッドが同じオブジェクトに属する別のメソッドを呼び出すことを表現するために使用します。

  • [非同期メッセージ] の図形を使って、操作をすぐには行わないタイミングを示します。

  • コネクタ メッセージの形状を変更するには:

    1. コネクタを右クリックします。
    2. ポップアップ メニューの下部にある 3 つのオプション (直角、 直線、 曲線) から選択します。
    3. コネクタを選択してドラッグし、形状を変更します。

フラグメント

1 つ以上の相互作用がループを形成する場合、または相互作用を終了するための条件を満たす必要がある場合は、それらの相互作用を フラグメント 図形で囲みます。

  • 標準的な繰り返しの相互作用には、[ループ フラグメント] を使います。
  • 特定の条件が満たされた場合にのみ実行される手順には 、オプションのフラグメント を使用します。
  • if-then または if-then-else のプロセスまたは相互作用には、[ 代替フラグメント ] 図形を使用します。 フラグメントには 2 つのセクションがあり、代替の相互作用を示すことができます。 別の条件を追加するには、[ 交互作用] オペランド を図形にドラッグします。 
    UML シーケンス条件のスクリーンショット
  • フラグメントの図形を、関連する相互作用にドラッグします。 フラグメントの図形にあるサイズ調整ハンドルを使って、関連するすべての相互作用が確実に含まれるようにします。
  • フラグメントの図形のタイトル コーナーをダブルクリックして、フラグメントで囲まれたプロセスのタイトルまたは簡単な説明を追加します。 このプロセスを終了する条件を入力する場合は、タイトルの隅の下にある [パラメーター] プロンプトを選択します。

ライセンス認証

ライフラインに [アクティブ化 バー] の図形を配置すると、そのオブジェクトまたは参加者がプロセスでいつ、どのくらいの時間アクティブであるかが表示されます。 通常、情報の流れを示すために、アクティブ化ボックスに出入りする矢印があります。

[アクティベーション] バーの端点を上下にドラッグして、目的の長さにします。

UML シーケンスのアクティブ化のスクリーンショット

破壊

破棄 は、オブジェクトまたはアクターがシステムに参加したタイミングを示します。 生存線の最後に大きな X が表示されます。 図でオブジェクトの破棄を表示するには:

  • オブジェクトを右クリックし、[ 破壊の表示] を選択します。

関連項目

Visio での UML 図

UML コンポーネント図を作成する

UML コミュニケーション図を作成する

UML 配置図を作成する