증상
Microsoft Outlook 프로필에 추가된 보조 Microsoft Exchange Server 사서함의 폴더에 액세스하려고 하면 임의 성능 문제가 발생할 수 있습니다. 예를 들어 다음과 같은 증상이 발생할 수 있습니다.
-
보조 사서함에서 항목을 볼 때 새 항목이 나타나지 않거나 항목이 누락된 것 같습니다.
-
삭제한 항목은 여전히 보조 사서함에 표시됩니다.
-
Outlook 성능 저하 또는 임의 중단
-
Microsoft Exchange Server 실행하는 서버에서 다음 이벤트와 유사한 이벤트가 애플리케이션 로그
에 기록됩니다. 이벤트 유형: 오류
이벤트 원본: MSExchangeIS
이벤트 범주: 일반
이벤트 ID: 9646
설명:
"objtFolder" 형식의 최대 500개 개체를 초과했기 때문에 Mapi 세션 "/o=Organization/ou=Administrative Group/cn=Recipients/cn=recipient"를 닫습니다.
또한 Outlook 동기화 문제 폴더의 동기화 로그 메시지에서 다음과 유사한 오류를 찾을 수 있습니다.
13:22:28 Synchronizer Version 12.0.6529
13:22:28 Synchronizing Mailbox 'TeamShared'
13:22:28 Synchronizing Hierarchy
13:22:28 Error Synchronizing Hierarchy for Mailbox 'TeamShared'
13:22:28 [80040305-54A-4DE-1900]
13:22:28 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
13:22:28 Microsoft Exchange Information Store
13:22:28 For more information on this failure, click the URL below:
13:22:28 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-1900
13:22:28 Error synchronizing folder
13:22:31 Synchronizing local changes in folder 'TeamShared - Level1'
13:22:31 Error synchronizing folder
13:22:31 [80040305-54A-4DE-421]
13:22:31 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
13:22:31 Microsoft Exchange Information Store
13:22:31 For more information on this failure, click the URL below:
13:22:31 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-421 When this issue occurred, the following synchronization error numbers have also been seen in synchronization messages in the Sync Issues folder:80040305-54A-4DE-822
80004005-501-0-1380
참고 사서함의 동기화 문제 폴더를 보려면 탐색 창에서 폴더 목록 모듈을 선택해야 합니다.
원인
이 문제는 다음 조건이 true인 경우 발생할 수 있습니다.
-
액세스하려는 보조 사서함이 탐색 창에 표시되도록 Outlook 프로필에 추가됩니다.
참고 Microsoft Exchange 대화 상자의 고급 탭을 통해 수동으로 프로필에 보조 사서함을 추가하거나 Exchange에서 "자동 매핑" 기능을 사용하여 자동으로 추가할 수 있습니다. -
이 보조 사서함에는 많은 폴더가 포함되어 있습니다.
-
프로필이 캐시된 Exchange 모드로 구성됩니다.
-
공유 폴더 다운로드의 기본 옵션은 프로필에서 사용하도록 설정됩니다.
이 문제는 Outlook 2010 이상 버전이 보조 사서함에 액세스할 수 있는 모든 폴더(Outlook 데이터 파일 [.ost])를 로컬로 캐시하기 때문에 발생합니다. 이는 이전 버전의 Outlook에서 변경된 것입니다. Outlook 2003은 공유 폴더를 캐시하지 않습니다. 기본적으로 Outlook 2007은 전자 메일(예: 일정, 연락처 및 작업)이 포함되지 않은 공유 폴더만 캐시합니다.
참고 Outlook 2007에서는 Outlook 클라이언트에 다음 레지스트리 데이터도 구성된 경우 이 문제가 발생할 가능성이 높습니다.
하위 키:
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Cached Mode
또는
HKEY_CURRENT_USER\Software\Policies \Microsoft\Office\12.0\Outlook\Cached 모드
DWORD: CacheOthersMail
값: 1
해결 방법
Outlook for Office 365
Outlook에서 공유 폴더 500개 제한 사항 해제
공유 폴더의 동기화가 개선되어 Outlook에서 더 이상 500개의 공유 폴더 제한이 발생하지 않고 Outlook에서 최대 5,000개의 공유 폴더를 수용할 수 있어야 합니다. 새 기능 제한은 Outlook의 사용 가능한 리소스 및 시스템 구성에 따라 달라집니다. 이러한 변경 내용은 버전 1904 릴리스를 사용하여 Office 월 단위(대상 지정) 채널 에 릴리스되었으며 버전 1905(빌드 11629.20196) 릴리스 이상이 포함된 Office 월 단위 채널로 릴리스되었습니다. 또한 일반 Semi-Annual 일정(Semi-Annual 채널의 경우 2019년 9월 및 일반 릴리스의 경우 2020년 1월)에 Semi-Annual 채널 릴리스에 포함됩니다. 자세한 내용은 Outlook에서 500 폴더 제한 해제를 참조하세요.
Outlook 2019, Outlook 2016, Outlook 2013, Outlook 2010 및 Outlook 2007의 경우
이 문제를 해결하려면 다음 방법 중 하나를 사용하세요.
중요
이 섹션의 단계를 주의 깊게 따릅니다. 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 수정하기 전에 문제가 발생할 경우 복원을 위해 레지스트리를 백업 합니다.
방법 1: 공유 사서함의 폴더 수 줄이기
이 문제에 가장 적합한 해결 방법은 특히 사서함이 Office 365 환경에 있는 경우 공유 사서함의 메일 폴더 수를 줄이는 것입니다. 이 문서의 추가 방법 2 및 3에서는 공유 사서함의 메일 폴더 또는 모든 폴더 캐싱을 해제하는 것이 좋습니다. 이러한 솔루션은 작동하지만 느린 네트워크에서 Office 365 사서함 및 사서함에 대해 캐싱을 사용하도록 설정하는 것이 좋습니다. 자세한 내용은 다음 문서를 참조하십시오.
방법 2: 모든 공유 폴더의 캐싱 사용 안 함
Outlook 2010 이상 버전
Outlook 2010 이상 버전에서 모든 공유 폴더의 캐싱을 사용하지 않도록 설정하려면 다음 단계를 수행합니다.
-
파일 탭의 계정 설정 목록에서 계정 설정을 클릭합니다.
-
계정 설정 대화 상자에서 전자 메일 탭을 클릭한 다음 Microsoft Exchange Server 계정을 두 번 클릭합니다.
-
계정 변경 대화 상자에서 추가 설정을 클릭합니다.
-
Microsoft Exchange 대화 상자에서 고급 탭을 클릭합니다.
-
공유 폴더 다운로드 검사 상자를 선택 취소하려면 클릭합니다.
-
확인을 두 번 클릭합니다.
-
다음을 클릭하고 마침을 클릭한 다음 닫기를 클릭합니다.
-
Outlook을 다시 시작합니다.
Outlook 2007
Outlook 2007에서 모든 공유 폴더의 캐싱을 사용하지 않도록 설정하려면 다음 단계를 수행합니다.
-
도구 메뉴에서 계정 설정을 클릭합니다.
-
계정 설정 대화 상자에서 전자 메일 탭을 클릭한 다음 Microsoft Exchange Server 계정을 두 번 클릭합니다.
-
계정 변경 대화 상자에서 추가 설정을 클릭합니다.
-
Microsoft Exchange 대화 상자에서 고급 탭을 클릭합니다.
-
공유 폴더 다운로드 검사 상자를 선택 취소하려면 클릭합니다.
-
확인을 두 번 클릭합니다.
-
다음을 클릭하고 마침을 클릭한 다음 닫기를 클릭합니다.
-
Outlook을 다시 시작합니다.
이렇게 변경하면 오프라인으로 작업할 때 Outlook에서 보조 사서함의 공유 폴더를 사용할 수 없습니다. 그러나 오프라인으로 작업할 때 기본 사서함의 모든 폴더를 계속 사용할 수 있습니다.
그룹 정책 설정을 사용하여 공유 폴더 다운로드를 사용하지 않도록 설정하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료의 문서로 이동합니다.
982697 기본적으로 공유 메일 폴더는 Outlook 2010 및 Outlook 2013에서 캐시된 모드로 다운로드됩니다.
방법 3: 보조 Exchange 사서함의 구성을 프로필의 두 번째 Exchange 계정으로 변경
Outlook 2010 이상 버전만
보조 Exchange 사서함의 모든 폴더를 캐시하려면 다음 단계에 따라 보조 사서함이 두 번째 Exchange 계정으로 추가되도록 Outlook 프로필을 수정합니다.
참고 이러한 단계를 수행하려면 보조 사서함 계정의 암호를 알고 있거나 보조 사서함의 계정에 대한 전체 사서함 권한이 있어야 합니다. 이 정보 또는 권한은 Exchange Server 관리자를 참조하세요.
-
보조 사서함에 대해 자동 매핑이 비활성화되어 있는지 확인합니다. 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하세요.
2646504 Office 365 공유 사서함에 대한 자동 매핑을 제거하는 방법
-
파일 탭의 계정 설정 목록에서 계정 설정을 클릭합니다.
-
계정 설정 대화 상자에서 전자 메일 탭을 클릭한 다음 Microsoft Exchange Server 계정을 두 번 클릭합니다.
-
계정 변경 대화 상자에서 추가 설정을 클릭합니다.
-
Microsoft Exchange 대화 상자에서 고급 탭을 클릭합니다.
-
고급 탭을 클릭합니다. 사서함 섹션에서 보조 사서함을 선택한 다음 제거를 클릭합니다.
-
사서함 제거를 확인하라는 메시지가 표시되면 예를 클릭합니다.
-
확인, 다음, 마침을 차례로 클릭한 다음 닫기를 클릭합니다.
참고 이 시점에서 보조 Exchange 사서함은 더 이상 Outlook 프로필과 연결되지 않습니다. -
Outlook을 끝냅니다.
-
제어판 메일 항목을 엽니다.
-
프로필을 선택한 다음 속성을 클릭합니다.
-
전자 메일 계정을 클릭합니다.
-
계정 설정 대화 상자의 전자 메일 탭에서 새로 만들기를 클릭합니다.
-
새 계정 추가 대화 상자의 서비스 선택 섹션에서 전자 메일 계정을 클릭한 다음 다음을 클릭합니다.
보조 사서함 계정의 암호를 알고 있는 경우 14단계로 이동합니다.
보조 사서함 계정의 암호를 알지 못하지만 계정에 이 보조 사서함에 대한 전체 사서함 권한이 있는 경우 18단계로 이동합니다. -
새 계정 추가 대화 상자의 자동 계정 설정 섹션에서 보조 사서함에 대한 다음 계정 정보를 입력하고 다음을 클릭합니다.
이름
Email 주소
암호 -
계정이 성공적으로 구성되면 마침을 클릭합니다.
-
닫기를 클릭하고 닫기를 클릭한 다음 확인을 클릭합니다.
-
22단계로 이동합니다.
-
새 계정 추가 대화 상자의 자동 계정 설정 섹션에서 수동으로 서버 설정 또는 추가 서버 유형 구성을 클릭한 다음 다음을 클릭합니다.
-
새 계정 추가 대화 상자의 서비스 선택 섹션에서 Microsoft Exchange 또는 호환되는 서비스를 클릭한 다음 다음을 클릭합니다.
-
새 계정 추가 대화 상자의 서버 설정 섹션에서 보조 사서함에 대한 다음 정보를 입력하고 다음을 클릭합니다.
서버(Exchange 서버 이름)
캐시된 Exchange 모드 사용(보조 사서함이 .ost 파일에서 로컬로 캐시되도록 허용)
사용자 이름
-
마침, 닫기, 닫기를 차례로 클릭한 다음 확인을 클릭합니다.
-
Outlook을 시작합니다.
참고 계정에 보조 사서함에 대한 전체 사서함 권한이 없는 경우 보조 사서함에 대한 계정 자격 증명을 묻는 메시지가 표시됩니다. 이 메서드에 지정된 구성을 변경한 후 Outlook을 사용할 때 다음과 같은 특정 문제가 발생할 수 있습니다.
-
두 Exchange 사서함 모두에 대해 새 전자 메일 경고가 표시됩니다.
-
프라이빗으로 표시된 메시지는 첫 번째 Exchange 사서함의 계정이 프라이빗 메시지를 볼 수 있도록 특별히 구성되지 않았더라도 두 번째 Exchange 사서함에서 볼 수 있습니다.
추가 정보
Outlook 프로필에 사서함을 추가하고 공유 사서함 폴더의 캐싱을 사용하도록 설정하면 Outlook은 캐시된 각 사서함의 모든 폴더를 개별적으로 등록합니다. 이러한 등록된 각 폴더는 Exchange Server 실행되는 서버의 objtFolder 형식 제한에 포함됩니다. 사서함당 한도입니다.
"증상" 섹션에 표시된 9646 이벤트에 설명된 대로 사서함당 objtFolder 개체의 기본 제한은 500입니다.
500개 이상의 폴더가 포함된 공유 사서함을 캐시하면 이 제한이 소진되고 "증상" 섹션에 언급된 문제가 발생할 수 있습니다.
또한 많은 수의 공용 폴더 즐겨찾기가 objtFolder 개체 제한을 소진하는 데 기여할 수 있습니다. 많은 공용 폴더를 동기화할 때 발생할 수 있는 오류에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하세요.
2968387 Outlook에서 사서함 또는 공용 폴더를 확장할 때 메모리 부족 오류가 발생합니다.
Microsoft Exchange Server 2007에서 허용되는 서버 리소스의 최대 공유에 대한 자세한 내용은 사용자가 허용되는 최대 서버 공유를 사용 중임을 참조하세요.
Exchange Server 2010 사서함 저장소 세션 제한에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하세요.
사서함 또는 폴더에 있는 폴더 및 하위 폴더의 수를 확인하려면 Get-MailboxFolderStatisticscmdlet을 실행합니다.