Symptoms
Consider the following scenario:
-
You deploy many updates to a Microsoft System Center Configuration Manager 2007 Service Pack 2 (SP2) client.
-
You perform an operation that generates the WM_TIMECHANGE message from the client computer. For example, you perform one of the following operations:
-
You change the system time.
-
You resume a computer from sleep.
-
You resume a computer from hibernation.
-
In this scenario, the computer runs slowly for some time. Additionally, the CPU usage is high, and the computer processes a heavy workload of disk I/O.
Cause
This issue occurs because the System Center Configuration Manager 2007 SP2 client unnecessarily sends many Windows Management Instrumentation (WMI) queries for the WM_TIMECHANGE message.
Resolution
The following hotfix package resolves this issue in the client role of System Center Configuration Manager 2007 SP2.
To resolve this issue, install the following hotfix package on the primary System Center Configuration Manager 2007 SP2 site server, and then deploy the generated package to the System Center Configuration Manager 2007 SP2 client. For more information about the steps to deploy a hotfix package to the System Center Configuration Manager 2007 SP2 site server, click the following article number to view the article in the Microsoft Knowledge Base:2477182 System Center Configuration Manager 2007 hotfix installation guidance Note The following hotfix package can be installed on a System Center Configuration Manager 2007 SP2 site server that is running an x86-based or x64-based version of an operating system:
Sccm2007-sp2-2309968-x86-enu.msi
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Microsoft System Center Configuration Manager 2007 Service Pack 2 (SP2) installed.
Restart requirement
If you close the Configuration Manager Administrator console before you install this hotfix, you do not have to restart the computer.
Hotfix replacement information
This hotfix was replaced by the following update:
2509007 Task sequence that installs many updates stops responding on a System Center Configuration Manager 2007 SP2 client
File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
System Center Configuration Manager 2007 file information notes
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Updatesdeployment.dll |
4.0.6487.2158 |
535,384 |
01-Feb-2010 |
00:15 |
x86 |
Note Other files might be updated because of dependencies. However, their binaries are not changed.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about the WM_TIMECHANGE message, visit the following Microsoft website:
General information about the WM_TIMECHANGE messageFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates