Sintomas
O Microsoft Access Office 2010 ou o Microsoft 2007 Office Access deixa de responder quando tenta executar qualquer uma das seguintes ações num computador HP em que o Serviço de Autenticação Biométrica Digital Persona está ativado:
-
Abrir uma base de dados que tem um formulário de arranque
-
Importar uma folha de cálculo do Microsoft Office Excel
-
Abrir tabelas na vista da folha de dados
No caso da terceira ação, o primeiro valor no primeiro registo da tabela pode ser corretamente exibido, mas o resto da folha de dados é apresentado como um espaço em branco. Pode levar vários minutos para que todos os conteúdos da mesa sejam exibidos.
Causa
O problema ocorre em computadores HP nos quais o HP ProtectTools Security Manager está instalado e no qual o Gestor de Segurança inclui o Serviço de Autenticação Biométrica da Digital Persona (um leitor de impressões digitais) ou qualquer outro dispositivo biométrico.
Resolução
Método 1
Para resolver este problema, descarregue a versão mais recente do HP ProtectTools Security Manager a partir do site da HP. Para isso, siga os passos apropriados para o seu tipo de caderno.
Para cadernos de qualidade de consumidor ("HP Pavilion" ou "HP Envy" ou "HP Touchsmart")
-
Visite o seguinte site da HP: http://search.hp.com
-
Selecione Drivers and Downloads.
-
Clique em "Drivers & Software ".
-
Introduza o número completo do modelo e, em seguida, prima Procurar.
-
Se for apresentada uma lista de números de modelos de cadernos, selecione o número específico do modelo do seu caderno.
-
No menu, selecione Sistema Operativoe, em seguida, clique em Seguinte.
-
Selecione Software - Soluções.
-
Selecione HP SimplePass by Digital Persona.
-
Faça o download do seguinte ficheiro executável, conforme apropriado para o seu sistema:
-
32-bit: SP55910.exe
-
64-bit: SP55909.exe
Para cadernos de qualidade comercial ("ProBook" ou "Elitebook")
-
Visite o seguinte site da HP: http://search.hp.com
-
Selecione Drivers and Downloads.
-
Clique em "Drivers & Software ".
-
Introduza o número completo do modelo e, em seguida, prima Procurar.
-
Se for apresentada uma lista de números de modelos de cadernos, selecione o número específico do modelo do seu caderno.
-
No menu, selecione Sistema Operativoe, em seguida, clique em Seguinte.
-
Na lista de Sistemas Operativos, selecione o seu sistema.
-
Selecione Software - Segurança.
-
Clique no link para HP ProtectTools Security Manager.
-
Clique no separador Histórico de Revisão.
-
Selecione a versão de ficheiro mais recente (5.1.0.736 ou mais recente).
-
Clique em Baixar para descarregar o ficheiro.
-
Execute o executável para atualizar o software do leitor de impressões digitais.
Se tiver alguma dúvida sobre como instalar o Hp Security Manager, contacte a HP clicando no link Contact HP na parte inferior do site de descarregamento da HP.
Método 2
Para resolver este problema, gere o Microsoft Access como um administrador que tem elevado priviliges cada vez que abre o Access. Para tal, siga estes passos:
-
No Windows Explorer, localize o ficheiro msaccess.exe na seguinte pasta, conforme apropriado ao seu sistema:
-
32-bit: C:\Program Files\Microsoft Office\Office14
-
64 bit: C:\Ficheiros de programa (X86)\Microsoft Office\Office14
Nota Se sentir o problema no Microsoft Access 2007, o msaccess.exe estará no Office12, em vez da pasta Office14.
-
-
Clique com o botão direito no ficheiro msaccess.exe.
-
Clique em Executar como administrador.
Pode configurar o Microsoft Access para funcionar sempre como administrador. Para tal, siga estes passos:
-
No Windows Explorer, localize o ficheiro msaccess.exe na seguinte pasta, conforme apropriado ao seu sistema:
-
32-bit: C:\Program Files\Microsoft Office\Office14
-
64 bit: C:\Ficheiros de programa (X86)\Microsoft Office\Office14
-
-
Clique com o botão direito no ficheiro msaccess.exe.
-
Selecione Propriedades.
-
Selecione o separador Compatibilidade.
-
Em Nível Priviliege,clique para selecionar o programa executar este programa como caixa de verificação de administrador.
Nota Tem de ser ligado ao computador como membro do grupo de administradores locais para realizar esta operação. Quando reiniciar o Microsoft Access, clique para permitir as alterações se receber a seguinte mensagem de Controlo de Conta de Utilizador: "Deseja permitir que o seguinte programa escote alterações neste computador? Programa: Microsoft Access."
Método 3
No caso da terceira ação mencionada na secção "Sintomas" (na qual demora vários minutos para que todos os conteúdos da tabela sejam apresentados na vista da folha de dados), abra a tabela Access primeiro na vista Design e, em seguida, mude para a vista datasheet.
Nota Os produtos de terceiros referidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não concede qualquer garantia, implícita ou de outra natureza, relativamente ao desempenho ou à fiabilidade destes produtos.
A Microsoft fornece informações de contacto de outros fabricantes para o ajudar a localizar suporte técnico. Estas informações de contacto poderão ser alteradas sem aviso prévio. A Microsoft não garante a exatidão destas informações de contacto de terceiros.