ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

เมื่อคุณติดตั้ง Windows Anytime Upgrade บนคอมพิวเตอร์ที่ใช้ Windows 7 คุณอาจได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:

Windows Anytime Upgrade ไม่สเร็
จ การอัปเกรดไม่สเร็จ โปรดลองอัปเกรดอีกครั้ง


นอกจากนี้ คุณอาจเห็นข้อผิดพลาดต่อไปนี้ในไฟล์ Windows Anytime Upgrade.log:

  • <วันที่และเวลา> <ใน> ข้อผิดพลาด WAU DoTransmogrify ล้มเหลวเนื่องจาก0x800f081fเกิดขึ้น

  • <วันที่> <เวลา>ข้อผิดพลาดที่ WAU UpgradeSKU ล้มเหลว การออกจากระบบ

  • <ตาม> <เวลา> ข้อผิดพลาด WAU Windows Anytime Upgrade ' ไม่ส>เร็จ

สาเหตุ

ปัญหานี้อาจเกิดขึ้นได้ถ้า Windows 7 Service Pack 1 (SP1) ถูกดาวน์โหลดโดย Windows Update แต่ยังไม่ได้ติดตั้ง For more information about this service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 ข้อมูลเกี่ยวกับService Pack 1 for Windows 7 และ For Windows Server 2008 R2

การแก้ไข

เมื่อต้องการให้เราแก้ไขปัญหานี้ให้คุณ ให้ไปที่ส่วน "แก้ไขปัญหาให้ฉัน" ถ้าคุณต้องการแก้ไขปัญหานี้ด้วยตนเอง ให้ไปที่ส่วน "ให้ฉันแก้ไขด้วยตนเอง"

แก้ปัญหาให้ฉัน



เมื่อต้องการแก้ไขปัญหานี้โดยอัตโนมัติ ให้คลิกปุ่ม หรือ ลิงก์ แก้ไข จากนั้นคลิกเรียกใช้ในกล่องโต้ตอบ ดาวน์โหลดไฟล์แล้วปฏิบัติตามขั้นตอนในตัวช่วยสร้างแก้ไข




หมายเหตุ

  • ตัวช่วยสร้างนี้อาจเป็นภาษาอังกฤษเท่านั้น อย่างไรก็ตาม การแก้ไขอัตโนมัติยังใช้งานได้กับ Windows เวอร์ชันภาษาอื่นด้วย

  • ถ้าคุณไม่ได้อยู่บนคอมพิวเตอร์ที่มีปัญหา คุณควรบันทึก แก้ไขปัญหา ลงในแฟลชไดรฟ์หรือซีดี แล้วเรียกใช้บนคอมพิวเตอร์ที่มีปัญหา


จากนั้นไปที่ส่วน "วิธีนี้แก้ไขปัญหาได้หรือไม่"



ให้ฉันแก้ไขปัญหาเอง

ถอนการติดตั้ง Windows 7 Service Pack 1

เมื่อต้องการแก้ไขปัญหานี้ ให้ถอนการติดตั้ง Service Pack 1 โดยใช้การสั่ง DISM เมื่อต้องการเปิด ให้ปฏิบัติตามขั้นตอนเหล่านี้กับ Windows 7 เวอร์ชันของคุณ

Windows 7 เวอร์ชัน 32 บิต

  1. คลิกเริ่ม แล้วพิมพ์ cmdในกล่องค้นหา

  2. คลิกขวา cmd.exeจากนั้นคลิก เรียกใช้ในฐานะผู้ดูแลระบบ

  3. พิมพ์ตามขั้นตอนต่อไปนี้ แล้วกด Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364t35~x86~~6.1.1.17514

  4. หลังจากที่การเอาออกเสร็จสมบูรณ์ ให้พิมพ์ exit แล้วกด Enter

  5. รีสตาร์ตคอมพิวเตอร์


Windows 7 เวอร์ชัน 64 บิต

  1. คลิกเริ่ม แล้วพิมพ์ cmdในกล่องค้นหา

  2. คลิกขวา cmd.exeจากนั้นคลิก เรียกใช้ในฐานะผู้ดูแลระบบ

  3. พิมพ์ตามขั้นตอนต่อไปนี้ แล้วกด Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364s35~amd64~~6.1.1.17514

  4. หลังจากที่การเอาออกเสร็จสมบูรณ์ ให้พิมพ์ exit แล้วกด Enter

  5. รีสตาร์ตคอมพิวเตอร์


การตรวจสอบว่าคุณติดตั้ง Windows 7 SP1 เวอร์ชันเบต้าหรือไม่

ถ้าคุณติดตั้ง Windows 7 SP1 เวอร์ชันเบต้า คุณจะไม่สามารถอัปเกรดได้ทันทีโดยใช้ Windows Anytime Upgrade คุณต้องถอนการติดตั้งเวอร์ชันเบต้าแล้วรีสตาร์ต Windows Anytime Upgrade เมื่อต้องการถอนการติดตั้งเวอร์ชันเบต้า ให้ปฏิบัติตามขั้นตอนเหล่านี้กับ Windows 7 เวอร์ชันของคุณ

หมายเหตุ ถ้าคุณถอนการติดตั้งเวอร์ชันเบต้าของ Windows 7 SP1 และยังคงได้รับข้อผิดพลาด คุณอาจมี remnants ของเวอร์ชันเบต้าบนพีซีของคุณ ขั้นตอนเหล่านี้จะล้างเวอร์ชันเบต้าออกจากพีซีของคุณด้วย

Windows 7 เวอร์ชัน 32 บิต

  1. คลิกเริ่ม แล้วพิมพ์ cmdในกล่องค้นหา

  2. คลิกขวา cmd.exeจากนั้นคลิก เรียกใช้ในฐานะผู้ดูแลระบบ

  3. พิมพ์ตามขั้นตอนต่อไปนี้ แล้วกด Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364t35~x86~~6.1.1.17105

  4. หลังจากที่การเอาออกเสร็จสมบูรณ์ ให้พิมพ์ exit แล้วกด Enter

  5. รีสตาร์ตคอมพิวเตอร์


Windows 7 เวอร์ชัน 64 บิต

  1. คลิกเริ่ม แล้วพิมพ์ cmdในกล่องค้นหา

  2. คลิกขวา cmd.exeจากนั้นคลิก เรียกใช้ในฐานะผู้ดูแลระบบ

  3. พิมพ์ตามขั้นตอนต่อไปนี้ แล้วกด Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364s35~amd64~~6.1.1.17105

  4. หลังจากที่การเอาออกเสร็จสมบูรณ์ ให้พิมพ์ exit แล้วกด Enter

  5. รีสตาร์ตคอมพิวเตอร์




สามารถแก้ไขปัญหาได้หรือไม่

  • ตรวจสอบว่าปัญหานี้ได้รับการแก้ไขหรือไม่ หากแก้ไขปัญหาได้แล้ว คุณไม่ต้องดำเนินการใดๆ กับส่วนนี้อีก หากปัญหายังไม่ได้รับการแก้ไข คุณสามารถ ติดต่อฝ่ายสนับสนุน

  • เราขอขอบคุณที่ให้ข้อเสนอแนะของคุณ เมื่อต้องการให้ข้อเสนอแนะหรือรายงานปัญหาเกี่ยวกับโซลูชันนี้ ให้ใส่ข้อคิดเห็นบนบล็อก" แก้ไขปัญหาให้ฉัน " หรือส่ง ข้อความอีเมล ถึงเรา

ข้อมูลเพิ่มเติม

คุณอาจเห็นรหัสข้อผิดพลาดของ0x800f081ในไฟล์บันทึกการอัปเกรด Windows Anytime รหัสข้อผิดพลาดนี้ระบุว่า Windows Update ได้ดาวน์โหลดการอัปเดต Windows 7 SP1 แต่ยังไม่ได้ติดตั้งการอัปเดต คุณสามารถตรวจทานบันทึกนี้เพื่อดูว่ามีข้อผิดพลาดเกิดขึ้นหรือไม่ Windows Upgrade.log อยู่ในที่ตั้งต่อไปนี้:

%userprofile%\AppData\Local\Microsoft\Windows\Windows Anytime Upgrade\update.log เมื่อต้องการรีวิวไฟล์บันทึกนี้เพื่อดูว่ามีข้อผิดพลาดเกิดขึ้นหรือไม่ ให้ปฏิบัติตาม
ขั้นตอนเหล่านี้:

  1. คลิกเริ่มแล้วคลิกคอมพิวเตอร์

  2. คัดลอกข้อความต่อไปนี้ คลิกเริ่ม แล้ววางข้อความต่อไปนี้ลงในกล่องค้นหา:

    %userprofile%\AppData\Local\Microsoft\Windows\Windows Anytime Upgrade

  3. คลิกโฟลเดอร์การอัปเกรด Windows ตลอดเวลาในผลลัพธ์การค้นหาที่ด้านบน

  4. ดับเบิลคลิกที่ไฟล์ Update.log ในโฟลเดอร์นี้

  5. ใน Notepad ให้คลิก ค้นหา บนเมนู แก้ไข

  6. คัดลอกและวางข้อความต่อไปนี้ลงในกล่องข้อความสิ่งที่ค้นหา แล้วคลิกค้นหา

    0x800f081

    ขึ้น ถ้าเกิดข้อผิดพลาด คุณจะเห็นรายการในไฟล์บันทึกที่มีลักษณะดังต่อไปนี้:

    • 2011-11-25 15:59:19 ข้อผิดพลาด WAU DoTransmogrify ล้มเหลวเนื่องจาก0x800f081fเกิดขึ้น

    • 2011-11-25 15:59:19 ข้อผิดพลาด WAU UpgradeSKU ล้มเหลว การออกจากระบบ

    • 2011-11-25 15:59:19 ข้อผิดพลาด WAU Windows Anytime Upgrade ' ไม่ประสบความสเร็จ


    โปรดสังเกตวันที่และเวลาที่จุดเริ่มต้นของแต่ละบรรทัดในไฟล์บันทึกจะสัมพันธ์กับเมื่อไฟล์บันทึกได้รับการอัปเดตด้วยข้อมูล

เมื่อต้องการแก้ไขปัญหานี้ ให้ปฏิบัติตามขั้นตอนในส่วน "การแก้ปัญหา"

อ้างอิง

สำหรับข้อมูลเพิ่มเติม โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:

2632965 ข้อผิดพลาดการอัปเกรด Windows Anytime "การอัปเกรดไม่สเร็จ โปรดลองอัปเกรดอีกครั้ง" บนคอมพิวเตอร์ที่ใช้ Windows 7 ที่มีส่วนติดต่อผู้ใช้หลายภาษา (MUI)

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×