Applies ToWindows Vista Business Windows Vista Business 64-bit Edition Windows Vista Enterprise Windows Vista Enterprise 64-bit Edition Windows Vista Home Basic Windows Vista Home Basic 64-bit Edition Windows Vista Home Premium Windows Vista Home Premium 64-bit Edition Windows Vista Starter Windows Vista Ultimate Windows Vista Ultimate 64-bit Edition Windows Server 2008 Datacenter Windows Server 2008 Datacenter without Hyper-V Windows Server 2008 Enterprise Windows Server 2008 Enterprise without Hyper-V Windows Server 2008 for Itanium-Based Systems Windows Server 2008 Foundation Windows Server 2008 Standard Windows Server 2008 Standard without Hyper-V

Symptoms

Assume that you run an application that calls the Microsoft DirectShow API on a computer that is running Windows Vista or Windows Server 2008. If the application repeatedly loads and unloads the Quartz.dll DirectShow component, the application may crash.

Cause

This issue occurs because of an error in the Quartz.dll DirectShow core component.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2).For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service packFor more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Vista and Windows Server 2008 file information notes

Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.0.600 2. 22xxx

    Windows Vista and Windows Server 2008

    SP2

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008 and of Windows Vista

File name

File version

File size

Date

Time

Quartz.dll

6.6.6002.22840

1,314,304

23-Apr-2012

14:50

For all supported x64-based versions of Windows Server 2008 and of Windows Vista

File name

File version

File size

Date

Time

Quartz.dll

6.6.6002.22840

1,570,304

23-Apr-2012

15:28

For all supported IA-64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Quartz.dll

6.6.6002.22840

3,865,600

23-Apr-2012

14:17

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

To reduce the effect of this issue, we encourage you to make sure that your DirectShow application loads quartz.dll only one time and to use that instance for the lifetime of the application. For more information about the Microsoft DirectShow  API, visit the following Microsoft website:

General information about the Microsoft DirectShow APIFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008

File name

X86_340d05e0c6b05e3bb3bbab6076238928_31bf3856ad364e35_6.0.6002.22840_none_e379e62fc4ecf7a5.manifest

File version

Not applicable

File size

703

Date (UTC)

24-Apr-2012

Time (UTC)

14:59

File name

X86_microsoft-windows-directshow-core_31bf3856ad364e35_6.0.6002.22840_none_a8b519e0044a73c4.manifest

File version

Not applicable

File size

122,931

Date (UTC)

23-Apr-2012

Time (UTC)

15:08

Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008

File name

Amd64_263567e1c10b4b6014def6c754483b56_31bf3856ad364e35_6.0.6002.22840_none_93ffdca2df21fbc5.manifest

File version

Not applicable

File size

1,054

Date (UTC)

24-Apr-2012

Time (UTC)

14:59

File name

Amd64_microsoft-windows-directshow-core_31bf3856ad364e35_6.0.6002.22840_none_04d3b563bca7e4fa.manifest

File version

Not applicable

File size

120,117

Date (UTC)

23-Apr-2012

Time (UTC)

15:49

Additional files for all supported IA-64-based versions of Windows Server 2008

File name

Ia64_0f1a12de3076d8fd1e0a48a3a0e94914_31bf3856ad364e35_6.0.6002.22840_none_0c1893fb67d66fff.manifest

File version

Not applicable

File size

1,052

Date (UTC)

24-Apr-2012

Time (UTC)

14:59

File name

Ia64_microsoft-windows-directshow-core_31bf3856ad364e35_6.0.6002.22840_none_a8b6bdd604487cc0.manifest

File version

Not applicable

File size

118,180

Date (UTC)

23-Apr-2012

Time (UTC)

14:30

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