Symptoms
Assume that you install the Remote Desktop (RD) Web Access role service on a computer that is running Windows Server 2008 R2 or Windows Server 2012. You try to change an expired password on the RD Web Access website by using a new password that does not meet the length, complexity, or history requirements. In this situation, you receive a generic error message that resembles the following:
Your password cannot be changed. Please contact your administrator for assistance.
Cause
This issue occurs because Windows does not retrieve the extended error code from the native Lightweight Directory Access Protocol (LDAP) API. Instead, Windows tries to map a generic error code and returns an error message based on the generic code.
Resolution
This hotfix is also available at Microsoft Update Catalog
Hotfix information
After you install this hotfix, you receive the following error message when you change an expired password that does not meet length, complexity or history requirements:
Your new password does not meet the length, complexity, or history requirements of your domain. Try choosing a different new password.
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must be running Windows Server 2012 or Windows Server 2008 R2 service pack 1.Â
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2
Registry information
To apply this hotfix, you do not have to make any changes to the registry.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace a previously released hotfix.
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.-
The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
Version
Product
SR_Level
Service branch
6.1.760
1. 22xxxWindows Server 2008 R2
SP1
LDR
-
The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Tsportalwebpart.dll |
6.1.7601.22317 |
303,104 |
04-May-2013 |
05:25 |
x86 |
Tsportalsetup.exe |
6.1.7601.22317 |
87,552 |
04-May-2013 |
04:06 |
x64 |
Tsportalwebpart.dll |
6.1.7601.22317 |
303,104 |
04-May-2013 |
05:25 |
x86 |
Tswa_migplugin.dll |
6.1.7601.22317 |
150,528 |
04-May-2013 |
05:20 |
x64 |
Windows Server 2012 file information notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
-
The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
Version
Product
Milestone
Service branch
6.2.920 0.20 xxx
Windows Server 2012
RTM
LDR
-
The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Rdwebserviceasp.dll |
6.2.9200.20682 |
14,848 |
11-Apr-2013 |
06:43 |
x86 |
Tsportalwebpart.dll |
6.2.9200.20685 |
415,232 |
11-Apr-2013 |
06:43 |
x86 |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684Description of the standard terminology that is used to describe Microsoft software updates
Additional file information