Applies ToWindows Server 2008 R2 Enterprise Windows Server 2008 R2 Datacenter Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition Windows Server 2012 Datacenter Windows Server 2012 Datacenter Windows Server 2012 Foundation Windows Server 2012 Foundation Windows Server 2012 Standard Windows Server 2012 Standard Windows Server 2012 Essentials

Symptoms

When you try to back up the system state on a computer that’s running Windows Server 2008 R2 or Windows Server 2012, and that has Microsoft Visual Studio 2012 installed, the backup operation fails.

Cause

This issue occurs because Windows Server limits any directory from containing more than 1,000 subdirectories. Visual Studio 2012 installs more than 1,000 subdirectories in the following location:

C:\Windows\Microsoft.NetTherefore, when the system state writer tries to back up the folder, the issue that is described in "Symptoms" section occurs.

Resolution

This hotfix is also available at Microsoft Update Catalog

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1) or Windows Server 2012.For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 1.22xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Crypt32.dll

6.1.7601.22272

1,464,320

02-Mar-2013

05:13

x64

Cryptnet.dll

6.1.7601.22272

139,776

02-Mar-2013

05:13

x64

Cryptsvc.dll

6.1.7601.22272

186,880

02-Mar-2013

05:13

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Crypt32.dll

6.1.7601.22272

2,663,424

02-Mar-2013

04:24

IA-64

Cryptnet.dll

6.1.7601.22272

266,752

02-Mar-2013

04:24

IA-64

Cryptsvc.dll

6.1.7601.22272

386,048

02-Mar-2013

04:24

IA-64

Windows Server 2012 file information notesImportant Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.20 xxx

    Windows Server 2012

    RTM

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Cryptcatsvc.dll

6.2.9200.20649

112,640

26-Feb-2013

23:52

x64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_microsoft-windows-crypt32-dll_31bf3856ad364e35_6.1.7601.22272_none_b9dc659a0dc38ae2.manifest

File version

Not applicable

File size

2,747

Date (UTC)

02-Mar-2013

Time (UTC)

05:48

Platform

Not applicable

File name

Amd64_microsoft-windows-cryptnet-dll_31bf3856ad364e35_6.1.7601.22272_none_7585e4d82bc57d4c.manifest

File version

Not applicable

File size

2,282

Date (UTC)

02-Mar-2013

Time (UTC)

05:48

Platform

Not applicable

File name

Amd64_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.1.7601.22272_none_d46c3d22cabf11f1.manifest

File version

Not applicable

File size

2,393

Date (UTC)

02-Mar-2013

Time (UTC)

05:50

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_microsoft-windows-crypt32-dll_31bf3856ad364e35_6.1.7601.22272_none_5dbf6e0c556422a8.manifest

File version

Not applicable

File size

2,745

Date (UTC)

02-Mar-2013

Time (UTC)

04:58

Platform

Not applicable

File name

Ia64_microsoft-windows-cryptnet-dll_31bf3856ad364e35_6.1.7601.22272_none_1968ed4a73661512.manifest

File version

Not applicable

File size

2,281

Date (UTC)

02-Mar-2013

Time (UTC)

04:58

Platform

Not applicable

File name

Ia64_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.1.7601.22272_none_784f4595125fa9b7.manifest

File version

Not applicable

File size

2,391

Date (UTC)

02-Mar-2013

Time (UTC)

04:59

Platform

Not applicable

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012

File name

Amd64_27c798c8ca34fd114d4b8f317d5ea4bb_31bf3856ad364e35_6.2.9200.20649_none_0d958ffd3d45a9c7.manifest

File version

Not Applicable

File size

1,056

Date (UTC)

27-Feb-2013

Time (UTC)

12:35

Platform

Not Applicable

File name

Amd64_46d2feb999c332cb8434cd9221e3971d_31bf3856ad364e35_6.2.9200.20649_none_3d9f8439bf15327e.manifest

File version

Not Applicable

File size

707

Date (UTC)

27-Feb-2013

Time (UTC)

12:35

Platform

Not Applicable

File name

Amd64_8c12bd5803adc960db86396250e56bd3_31bf3856ad364e35_6.2.9200.20649_none_32b63f79ef3acaca.manifest

File version

Not Applicable

File size

707

Date (UTC)

27-Feb-2013

Time (UTC)

12:35

Platform

Not Applicable

File name

Amd64_microsoft-windows-cryptcatsvc-dll_31bf3856ad364e35_6.2.9200.20649_none_0933324995dbbe51.manifest

File version

Not Applicable

File size

2,471

Date (UTC)

27-Feb-2013

Time (UTC)

02:04

Platform

Not Applicable

File name

Update.mum

File version

Not Applicable

File size

2,673

Date (UTC)

27-Feb-2013

Time (UTC)

12:35

Platform

Not Applicable

File name

Wow64_microsoft-windows-cryptcatsvc-dll_31bf3856ad364e35_6.2.9200.20649_none_1387dc9bca3c804c.manifest

File version

Not Applicable

File size

711

Date (UTC)

27-Feb-2013

Time (UTC)

01:01

Platform

Not Applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.