Applies ToWindows Multipoint Server 2012 Premium

Symptoms

When a duplicate IP address is detected in a Windows Multipoint Server 2012 environment, user sessions are logged off unexpectedly.

Cause

This problem may occur because Windows Multipoint Server 2012 uses Remote Desktop IP Virtualization to assign a unique IP address to each user when users log on. If DHCP cannot provide a unique IP address within the time frame that is allocated for the request, Windows Multipoint Server 2012 does not try again to do this. Instead, it assigns a non-unique IP address to the user session. Therefore, you may detect duplicate IP addresses.

Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Multipoint Server 2012 installed on Windows Server 2012 to apply this hotfix.

Restart information

You must restart the computer after you apply this hotfix.

Replacement information

This hotfix does not replace any previously released hotfix.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2012 file information notesImportant Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.16xxx

    Windows Server 2012

    RTM

    GDR

    6.2.920 0.20xxx

    Windows Server 2012

    RTM

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Tsmsiprxy.dll

6.2.9200.16384

12,800

26-Jul-2012

03:07

x64

Tsmsisrv.dll

6.2.9200.16384

109,568

26-Jul-2012

03:07

x64

Tsvipcli.dll

6.2.9200.20793

47,104

09-Aug-2013

08:01

x64

Tsvipool.dll

6.2.9200.16384

30,720

26-Jul-2012

03:07

x64

Tsvipsrv.dll

6.2.9200.20793

164,352

09-Aug-2013

08:01

x64

Tsmsiprxy.dll

6.2.9200.16384

10,240

26-Jul-2012

02:27

x86

Tsmsisrv.dll

6.2.9200.16384

92,672

25-Jul-2012

23:58

x86

Tsvipcli.dll

6.2.9200.20793

38,912

09-Aug-2013

01:45

x86

Tsvipool.dll

6.2.9200.16384

27,136

25-Jul-2012

23:34

x86

Tsvipsrv.dll

6.2.9200.20793

131,584

09-Aug-2013

01:44

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

See the terminology Microsoft uses to describe software updates.

Additional files for all supported x64-based versions of Windows Server 2012

File name

Amd64_982551a8f0a6485915f00896d33e0a56_31bf3856ad364e35_6.2.9200.20793_none_12ad54aeef7ab615.manifest

File version

Not Applicable

File size

1,094

Date (UTC)

09-Aug-2013

Time (UTC)

16:34

Platform

Not Applicable

File name

Amd64_microsoft-windows-t..-tsappsrv-component_31bf3856ad364e35_6.2.9200.20793_none_c81bea1c956a5676.manifest

File version

Not Applicable

File size

18,156

Date (UTC)

09-Aug-2013

Time (UTC)

16:34

Platform

Not Applicable

File name

Package_1_for_kb2864237~31bf3856ad364e35~amd64~~6.2.1.0.mum

File version

Not Applicable

File size

2,096

Date (UTC)

09-Aug-2013

Time (UTC)

16:34

Platform

Not Applicable

File name

Package_for_kb2864237_rtm~31bf3856ad364e35~amd64~~6.2.1.0.mum

File version

Not Applicable

File size

1,466

Date (UTC)

09-Aug-2013

Time (UTC)

16:34

Platform

Not Applicable

File name

X86_microsoft-windows-t..-tsappsrv-component_31bf3856ad364e35_6.2.9200.20793_none_6bfd4e98dd0ce540.manifest

File version

Not Applicable

File size

18,152

Date (UTC)

09-Aug-2013

Time (UTC)

16:34

Platform

Not Applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.