Applies ToWindows Server 2012 Datacenter Windows Server 2012 Datacenter Windows Server 2012 Essentials Windows Server 2012 Foundation Windows Server 2012 Foundation Windows Server 2012 Standard Windows Server 2012 Standard Windows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Datacenter Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition

Symptoms

When you create a snapshot for a large volume on a Windows Server 2012-based or Windows Server 2008 R2 Service Pack 1 (SP1)-based computer, snapshot creation takes a long time to finish. Additionally, some I/O failures occur during snapshot creation.For example, when you create a snapshot for a volume that is larger than 50 terabytes (TB), it takes a long time to complete the snapshot creation. Additionally, you experience mouse or keyboard input problems and network connection loss during the snapshot creation.Note If this issue occurs on a Windows Server 2012-based failover cluster, cluster heartbeat failure occurs. Therefore, the cluster disk resource goes offline, and then the snapshot creation fails.

Cause

This issue occurs because the Volsnap.sys driver spends too much time marking available space on the volume when holding a spinlock.

Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012 or Windows Server 2008 R2 SP1.For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 1.18xxx

    Windows Server 2008 R2

    SP1

    GDR

    6.1.760 1.22xxx

    Windows Server 2008 R2

    SP1

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.1.7601.18226

296,384

31-Jul-2013

02:35

x64

Volsnap.sys

6.1.7601.22407

296,896

31-Jul-2013

02:33

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.1.7601.18226

679,360

31-Jul-2013

01:43

IA-64

Volsnap.sys

6.1.7601.22407

681,408

31-Jul-2013

01:37

IA-64

Windows Server 2012 file information notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.16 xxx

    Windows Server 2012

    RTM

    GDR

    6.2.920 0.20 xxx

    Windows Server 2012

    RTM

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.2.9200.16678

328,024

31-Jul-2013

03:11

x64

Volsnap.sys

6.2.9200.20786

332,120

31-Jul-2013

16:29

x64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File property

Value

File name

Amd64_volume.inf_31bf3856ad364e35_6.1.7601.18226_none_73d3d11e12baf5d9.manifest

File version

Not applicable

File size

2,087

Date (UTC)

31-Jul-2013

Time (UTC)

02:54

Platform

Not applicable

File name

Amd64_volume.inf_31bf3856ad364e35_6.1.7601.22407_none_74740ff12bc7743f.manifest

File version

Not applicable

File size

2,087

Date (UTC)

31-Jul-2013

Time (UTC)

02:55

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File property

Value

File name

Ia64_volume.inf_31bf3856ad364e35_6.1.7601.18226_none_17b6d9905a5b8d9f.manifest

File version

Not applicable

File size

2,085

Date (UTC)

31-Jul-2013

Time (UTC)

02:17

Platform

Not applicable

File name

Ia64_volume.inf_31bf3856ad364e35_6.1.7601.22407_none_1857186373680c05.manifest

File version

Not applicable

File size

2,085

Date (UTC)

31-Jul-2013

Time (UTC)

02:13

Platform

Not applicable

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012

File property

Value

File name

Amd64_volume.inf_31bf3856ad364e35_6.2.9200.16678_none_6e8f35ab85cd71a4.manifest

File version

Not applicable

File size

2,104

Date (UTC)

31-Jul-2013

Time (UTC)

03:15

Platform

Not applicable

File name

Amd64_volume.inf_31bf3856ad364e35_6.2.9200.20786_none_6f0c01f69ef4fab1.manifest

File version

Not applicable

File size

2,104

Date (UTC)

31-Jul-2013

Time (UTC)

19:46

Platform

Not applicable

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