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Symptoms

Consider the following scenario:

  • You have an environment that is running a cross-site database availability group (DAG) in Microsoft Exchange Server 2010.

  • One or more members in the DAG are offline.

  • You use Microsoft Outlook in online mode to try to sort email folders by columns.

In this scenario, Outlook freezes. Additionally, an event that resembles the following is logged on the Client Access server:

Date&Time, /o=ORG/ou=SITE /cn=RECIPIENTS/cn=USERNAME,,OUTLOOK.EXE,Outlook Version, Classic,,, ncacn_ip_tcp,,,1118 (rop::1118),00:00:05.0294985,,"RopHandler: GetCollapseState: [StoragePermanentException] Cannot get collapse state. -> [MapiExceptionCallFailed] MapiExceptionCallFailed: Unable to get collapse state on table. (hr=0x80004005, ec=1118)
Note By default, the event is located in the following path:

C:\Program Files\Microsoft\Exchange Server\V14\logging\RPC Client Access

Cause

This issue occurs because there is a 5 second time-out when the Client Access server tries to contact the Active Manager on the offline server in the DAG. This causes the RPC response to the Outlook client to be delayed.

Resolution

To resolve this issue, install the following update rollup:

2891587 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 3

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

If a server is offline for a long time, you should mark the server as blocked for activation by running the following command:

Set-MailboxServer <server> -DatabaseCopyAutoActivationPolicy Blocked

For more information about the Set-MailboxServer cmdlet, go to the following Microsoft website:

General information about the Set-MailboxServer cmdletFor more information about DAGs, go to the following Microsoft website:

General information about DAGsFor more information about the Active Manager, go to the following Microsoft website:

General information about the Active Manager

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