Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Assume that you have an environment that contains users' roaming profile location (server-based profiles). The server-based profiles are accessed from Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1 through a domain-based Distributed File System (DFS) share. It takes longer than expected to load or unload the profiles. Additionally, you may notice the following behavior:

  1. When you view the network traces of the slow transactions, you notice that the DFS API request NetrDfsGetInfo or dfs_GetInfo is taking some time.

    Note The combined load of all domain controllers in a big domain against the Primary Domain Controller (PDC) might become so big that the connection to the PDC fails and that the DFS API does not respond with a valid path. When this happens, the roaming profile cannot be loaded after the delay. Please review the "More Information" section in this article.

  2. When you view the processing of the request at the DFS server, which is usually the local domain controller (local DC), you see that it has communication with the PDC. There are two basic scenarios where a delay happens:

    1. When the DFS volume has many links and the PDC is attached over a low wide area network (WAN) link, it can take a long time to retrieve the data that the local DC requests by using the LDAP protocol.

    2. When the local DC cannot reach the PDC, it spends significant time retrying a connection with it.

Cause

To learn about the real location of a path within a DFS volume, the Profile Service contacts the DFS service via a NetDfsGetInfo call. This issue occurs because the domain controller makes sure that the NetDfsGetInfo call has the most current information on the DFS volume and queries the PDC for it. The NetDfsGetInfo call does not have prerequisites but is considered a management API.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes Important Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 1.22xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Profprov.dll

6.1.7601.22575

28,672

18-Jan-2014

02:15

x86

Profsvc.dll

6.1.7601.22575

176,128

18-Jan-2014

02:15

x86

Profsvc.ptxml

Not applicable

648

13-Jul-2009

20:36

Not applicable

Userprofilewmiprovider.mof

Not applicable

10,708

13-Jul-2009

20:36

Not applicable

For all supported x64-based versions of Windows Server 2008 R2 and of Windows 7

File name

File version

File size

Date

Time

Platform

Profprov.dll

6.1.7601.22575

33,792

18-Jan-2014

02:31

x64

Profsvc.dll

6.1.7601.22575

225,280

18-Jan-2014

02:31

x64

Profsvc.ptxml

Not applicable

648

13-Jul-2009

20:29

Not applicable

Userprofilewmiprovider.mof

Not applicable

10,708

13-Jul-2009

20:29

Not applicable

For all supported IA64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Profprov.dll

6.1.7601.22575

79,360

18-Jan-2014

01:46

IA-64

Profsvc.dll

6.1.7601.22575

480,256

18-Jan-2014

01:46

IA-64

Profsvc.ptxml

Not applicable

648

13-Jul-2009

20:29

Not applicable

Userprofilewmiprovider.mof

Not applicable

10,708

13-Jul-2009

20:29

Not applicable


Workaround

To work around this issue, you can disable the RootScalability mode. The DFS server will then always use the PDC to sync, and it will use incremental synchronization to the PDC, which is typically much faster. To do this, you can run the following command:

dfsutil /root:\\domain\dfsroot /RootScalability /Disable 

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

305027 Summary of "piling on" scenarios in Active Directory domains

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

With this hotfix installed, the profile service does not rely on NetDfs API any longer that would require the DFS service to contact the PDC. It uses a different method that builds on the DFS Get Referral SMB command. For more information, go to the following Microsoft TechNet website:

How DFS WorksIf you are affected by this combination of profile service and DFS service behavior, we recommend you install this update on all computers that users who have roaming profiles are logging on. This typically applies to all workstations and remote desktop servers. The problem that the user profile links are missing after the update is already addressed with an update for DFS service. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2916267 The DFS Namespace reparse point for folder targets are missing in Windows Server 2008 R2 Note This update does not resolve the performance problem behind the PDC dependency.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows 7 and Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File property

Value

File name

X86_afc8699f5006980a57aacc3521222ebe_31bf3856ad364e35_6.1.7601.22575_none_e64c4fdcd3bf808b.manifest

File version

Not applicable

File size

695

Date (UTC)

20-Jan-2014

Time (UTC)

06:11

Platform

Not applicable

File name

X86_microsoft-windows-profsvc_31bf3856ad364e35_6.1.7601.22575_none_fe026637aa3ca1f5.manifest

File version

Not applicable

File size

39,077

Date (UTC)

18-Jan-2014

Time (UTC)

02:45

Platform

Not applicable

Additional files for all supported x64-based versions of Windows Server 2008 R2 and of Windows 7

File property

Value

File name

Amd64_66489d4fe9670666d143b8c381c922ac_31bf3856ad364e35_6.1.7601.22575_none_cdb15666a2f747ac.manifest

File version

Not applicable

File size

699

Date (UTC)

20-Jan-2014

Time (UTC)

06:11

Platform

Not applicable

File name

Amd64_microsoft-windows-profsvc_31bf3856ad364e35_6.1.7601.22575_none_5a2101bb629a132b.manifest

File version

Not applicable

File size

39,081

Date (UTC)

18-Jan-2014

Time (UTC)

03:20

Platform

Not applicable

Additional files for all supported IA64-based versions of Windows Server 2008 R2

File property

Value

File name

Ia64_1f36871a84302ba3e292250f3ffa8a4a_31bf3856ad364e35_6.1.7601.22575_none_9a7a55d91ad6bdbe.manifest

File version

Not applicable

File size

697

Date (UTC)

20-Jan-2014

Time (UTC)

06:11

Platform

Not applicable

File name

Ia64_microsoft-windows-profsvc_31bf3856ad364e35_6.1.7601.22575_none_fe040a2daa3aaaf1.manifest

File version

Not applicable

File size

39,079

Date (UTC)

18-Jan-2014

Time (UTC)

02:40

Platform

Not applicable


Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×