Applies ToWindows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Standard Windows Server 2008 R2 Foundation Windows Server 2008 R2 for Itanium-Based Systems Windows 7 Service Pack 1 Windows 7 Ultimate Windows 7 Enterprise Windows 7 Professional Windows 7 Home Premium Windows 7 Home Basic Windows 7 Starter

This article describes an issue that occurs when Windows 7 Service Pack 1 (SP1)-based or Windows Server 2008 R2 SP1-based VMware virtual machines are shutting down or restarting. A hotfix is available to resolve this issue. The hotfix has a prerequisite.

Symptoms

This issue occurs on VMware vSphere 5.0-based virtual machines that is running on an AMD processor-based computer.

Cause

A deadlock occurs when virtual machines are shutting down or restarting.

Resolution

To resolve this issue, we have released a hotfix for Windows 7 or Windows Server 2008 R2.

Get the hotfix for Windows 7 or Windows Server 2008 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update, you must have Service Pack 1 installed in Windows 7 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

More Information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information and notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 1.22xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Hal.dll

6.1.7601.22846

194,488

18-Oct-2014

01:36

x86

Halacpi.dll

6.1.7601.22846

137,152

18-Oct-2014

01:36

x86

Halmacpi.dll

6.1.7601.22846

194,488

18-Oct-2014

01:36

x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Hal.dll

6.1.7601.22846

263,096

18-Oct-2014

02:07

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Hal.dll

6.1.7601.22846

494,520

18-Oct-2014

01:12

IA-64

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File property

Value

File name

X86_52bdfaca1d887c9e46d97e49b6172e28_31bf3856ad364e35_6.1.7601.22846_none_4e6cd89e3e8ec112.manifest

File version

Not applicable

File size

691

Date (UTC)

18-Oct-2014

Time (UTC)

05:54

Platform

Not applicable

File name

X86_microsoft-windows-hal_31bf3856ad364e35_6.1.7601.22846_none_ad9b772ed1208a9a.manifest

File version

Not applicable

File size

9,274

Date (UTC)

18-Oct-2014

Time (UTC)

02:23

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File property

Value

File name

Amd64_f223669402fe118e7b20392bf9d5801e_31bf3856ad364e35_6.1.7601.22846_none_d07ab653fb92c03d.manifest

File version

Not applicable

File size

695

Date (UTC)

18-Oct-2014

Time (UTC)

05:54

Platform

Not applicable

File name

Amd64_microsoft-windows-hal_31bf3856ad364e35_6.1.7601.22846_none_09ba12b2897dfbd0.manifest

File version

Not applicable

File size

7,549

Date (UTC)

18-Oct-2014

Time (UTC)

02:24

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File property

Value

File name

Ia64_84b7010c08031878e0deec8752857f22_31bf3856ad364e35_6.1.7601.22846_none_74f0e551b76acbe2.manifest

File version

Not applicable

File size

693

Date (UTC)

18-Oct-2014

Time (UTC)

05:54

Platform

Not applicable

File name

Ia64_microsoft-windows-hal_31bf3856ad364e35_6.1.7601.22846_none_ad9d1b24d11e9396.manifest

File version

Not applicable

File size

9,299

Date (UTC)

18-Oct-2014

Time (UTC)

01:52

Platform

Not applicable

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

See the terminology that Microsoft uses to describe software updates.

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