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Symptoms

In an Exchange Server 2013 environment, multiple services may log event ID 4999 for a System.FormatException error that resembles the following in the Application event log:

Log Name: Application
Source: MSExchange Common
Event ID: 4999
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Description:
Watson report about to be sent for process id: 21820, with parameters: E12, c-RTL-AMD64, 15.00.1210.003, w3wp#MSExchangeServicesAppPool, M.E.Data.Directory, M.E.D.D.ADDataSession.ReadRangedAttribute, System.FormatException, 1e84, 15.00.1210.002.
ErrorReportingEnabled: False


Log Name: Application
Source: MSExchange Common
Event ID: 4999
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Description:
Watson report about to be sent for process id: 9764, with parameters: E12IIS, c-RTL-AMD64, .RpcClientAccess.Ser15.00.1210.003, M.Evice, M.E.Data.Directory, M.E.D.D.ADDataSession.ReadRangedAttribute, System.FormatException, 5e34, 15.00.1210.002.
ErrorReportingEnabled: False


Note These messages may be logged several times a minute while the issue is occurring.

Cause

This issue may occur when user accounts do not have the showInAddressBook attribute set. By default, all user accounts will be assigned to the following address books.

  • All mailboxes

  • All recipients

  • All users

  • Default global address list

  • Mailboxes

Cumulative update information

For Exchange Server 2013

To resolve this issue, install Cumulative Update 15 for Exchange Server 2013 or a later cumulative update for Exchange Server 2013.

Workaround

To work around this issue, update the accounts to populate the showInAddressbook attribute with the correct value.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology that Microsoft uses to describe software updates.

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