Applies ToWindows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate Windows Vista Ultimate Windows Vista Enterprise Windows Vista Business Windows Vista Home Premium Windows Vista Home Basic Windows Vista Ultimate 64-bit Edition Windows Vista Enterprise 64-bit Edition Windows Vista Business 64-bit Edition Windows Vista Home Premium 64-bit Edition Windows Vista Home Basic 64-bit Edition Windows Vista Starter

Symptoms

After you wake a Windows Vista-based computer or a Windows 7-based computer from sleep or from hibernation, you experience the following symptoms:

  • The network icon in the notification area at the far right of the taskbar is not updated to show the connectivity status of the computer.

  • The network icon in the notification area at the far right of the taskbar may show a red "X" mark instead of showing the correct connectivity status of the computer.

  • If you connect a network cable to the computer or if you connect to a wireless network, the network icon in the notification area incorrectly shows the connectivity status as disconnected.

  • If you move the pointer over the network icon in the notification area, the Currently connected to ScreenTip does not appear as expected.

  • If you click the network icon in the notification area, the Currently connected to ScreenTip does not appear as expected.Note In this case, the expected ScreenTip should contain a Connect to a network link and a Network and Sharing Center link.

  • The speaker icon in the notification area at the far right of the taskbar may show a red "X" mark instead of showing the correct speaker status.

You experience these symptoms even though you can successfully connect both to wired networks and to wireless networks and the speakers are functioning correctly.

Cause

This issue occurs if the computer enters sleep or hibernation before it finishes notifying the part of the system that controls the network-icon functionality.

Workaround

To work around this issue, use one of the following procedures:

  • Restart the computer.

  • Use the Network and Sharing Center to view the connectivity status of the computer. To open the Network and Sharing Center, click Start Start button , type Network and Sharing Center in the Start Search box, and then click Network and Sharing Center in the Programs list.

  • End the Explorer.exe process, and then restart this process. To do this, follow these steps:

    1. Open Task Manager. To do this, press CTRL+SHIFT+ESC.

    2. Click the Processes tab.

    3. In the list of processes, click explorer.exe, and then click End Process.

    4. When you are prompted to confirm that you want to continue, click End process.

    5. On the File menu, click New Task (Run...).

    6. In the Create New Task dialog box, type %systemroot%\explorer.exe in the Open box, and then click OK.

More Information

This issue occurs very rarely. For more information about the sleep state and about the hibernation state in Windows Vista, see the "Turn off a computer: frequently asked questions" topic in Windows Help and Support. To view this information online, visit the following Microsoft Web site:

http://windowshelp.microsoft.com/Windows/en-US/Help/335c6a5d-0304-4af1-b135-6bf6c124dc111033.mspx

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