Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.
Symptoms
You have some corrupted .wav files in a folder on a computer that is running Windows 7 or Windows Server 2008 R2. When you open the folder, you encounter the following problems:
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The computer responds slowly.
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You cannot perform any other operations.
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You experience high CPU usage in the Explorer.exe process.
Note To temporarily resolve these problems, restart the Explorer.exe process. For more information about how to restart the Explorer.exe process, see the"More Information" section. You may also encounter problems when you use other applications or operations to open the corrupted .wav files. For example, if you try to use Windows Media Player to open the corrupted .wav files, Windows Media Player stops responding. Additionally, the Wmplayer.exe process generates high CPU usage.
Cause
When a folder that contains corrupted .wav files is opened, Windows Explorer calls the Media Foundation (Mf.dll) function to extract metadata from the .wav files. However, the Mf.dll function enters an infinite loop when extracting the metadata.
Resolution
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must be running windows 7 or Windows Server 2008 R2.
Restart requirement
You must restart the computer after you apply this hotfix.
Registry information
To use one of the hotfixes in this package, you do not have to make any changes to the registry.
File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). The dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time (DST) bias. Additionally, the dates and times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes that are listed on the Hotfix Request page may apply to only one of these operating systems. To request the hotfix package that applies to both Windows 7 and to Windows Server 2008 R2, select the appropriate product that is listed on the page.
For all supported x86-based versions of Windows 7
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Mf.dll |
12.0.7600.20554 |
3,177,984 |
21-Oct-2009 |
06:05 |
x86 |
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Mf.dll |
12.0.7600.20554 |
4,062,208 |
21-Oct-2009 |
06:37 |
x64 |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
How to restart the Explorer.exe process
To restart the Explorer.exe process, follow these steps:
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Press CTRL+ALT+DEL.
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Click Start Task Manager.
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On the Processes tab in Windows Task Manager, click the Explorer.exeprocess, and then click the End Process button two times.
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On the File menu, click New Tasks (Run), type explorer, and then click OK.
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Exit Windows Task Manager.