Excel에서 쿼리 만들기, 로드 또는 편집(파워 쿼리)

적용 대상
Microsoft 365용 Excel Excel 2024 Excel 2021 Excel 2019 Excel 2016

파워 쿼리는 파워 쿼리를 만들고 통합 문서에 로드하는 여러 가지 방법을 제공합니다. 쿼리 옵션 창에서 기본 쿼리 로드 설정을 설정할 수도 있습니다.

워크시트의 데이터가 파워 쿼리에 의해 셰이프되었는지 확인하려면 데이터 셀을 선택하고 쿼리 컨텍스트 리본 탭이 나타나면 데이터가 파워 쿼리에서 로드된 것입니다. 

쿼리에서 셀을 선택하여 쿼리 탭 표시

Excel에 파워 쿼리 통합 정보

현재 어떤 환경에 있는지 알 수 있습니다. 파워 쿼리는 특히 데이터를 가져오고, 연결 작업을 하고, 피벗 테이블, Excel 표 및 명명된 범위를 편집할 때 Excel 사용자 인터페이스에 잘 통합되어 있습니다. 혼동을 피하려면 언제든지 현재 Excel 또는 파워 쿼리 중 어떤 환경에 있는지 아는 것이 중요합니다.

친숙한 Excel 워크시트, 리본 메뉴 및 눈금 Power Query 편집기 리본 및 데이터 미리 보기
일반적인 Excel 워크시트 일반적인 Power Query 편집기 보기

예를 들어 Excel 워크시트에서 데이터를 조작하는 것은 파워 쿼리과 근본적으로 다릅니다. 또한 Excel 워크시트에 표시되는 연결된 데이터에는 데이터를 구성하기 위해 뒤에서 작동하는 파워 쿼리가 있을 수도 있고 없을 수도 있습니다. 이는 파워 쿼리에서 워크시트 또는 데이터 모델로 데이터를 로드할 때만 발생합니다.

워크시트 탭 이름 바꾸기 특히 워크시트 탭이 많은 경우 의미 있는 방식으로 워크시트 탭의 이름을 바꾸는 것이 좋습니다. 데이터 워크시트와 Power Query 편집기에서 로드된 워크시트 간의 차이점을 명확히 하는 것은 특히 중요합니다. 두 개의 워크시트(하나는 Sheet1이라는 Excel 표가 있는 워크시트와 Table1이라는 Excel 표를 가져와서 만든 쿼리)의 워크시트만 있는 경우에도 쉽게 혼동될 수 있습니다. 워크시트 탭의 기본 이름을 사용자에게 더 적합한 이름으로 변경하는 것이 좋습니다. 예를 들어 Sheet1 의 이름을 DataTable 로, Table1 의 이름을 QueryTable로 바꿉니다. 이제 어느 탭에 데이터가 있고 어떤 탭에 쿼리가 있는지 명확합니다.

쿼리 만들기

가져온 데이터에서 쿼리를 만들거나 빈 쿼리를 만들 수 있습니다.

가져온 데이터에서 쿼리 만들기

쿼리를 만드는 가장 일반적인 방법입니다.

  1. 일부 데이터를 가져옵니다. 자세한 내용은 외부 데이터 원본에서 데이터 가져오기를 참조하세요.
  2. 데이터에서 셀을 선택한 다음 쿼리>편집을 선택합니다.

빈 쿼리 만들기

처음부터 다시 시작할 수도 있습니다. 이 작업은 다음 두 가지 방법으로 수행할 수 있습니다.

  • 데이터> 선택다른 원본>에서데이터> 가져오기빈 쿼리.
  • 데이터>선택 데이터> 가져오기Power Query 편집기를 시작합니다.

이 시점에서 파워 쿼리 M 수식 언어를 잘 알고 있다면 단계와 수식을 수동으로 추가할 수 있습니다.

또는 을 선택한 다음 새 쿼리 그룹에서 명령을 선택할 수 있습니다. 다음 중 하나를 실행합니다.

  • 새 원본을 선택하여 데이터 원본을 추가합니다. 이 명령은 Excel 리본의 데이터>가져오기 명령과 같습니다.
  • 최근 원본을 선택하여 작업 중인 데이터 원본에서 선택합니다. 이 명령은 Excel 리본의 데이터>최근 원본 명령과 같습니다.
  • 데이터 입력을 선택하여 데이터를 수동으로 입력합니다. 이 명령을 선택하여 외부 데이터 원본과 독립적으로 Power Query 편집기 사용해 볼 수 있습니다.

쿼리 로드

쿼리가 유효하고 오류가 없다고 가정하면 워크시트나 데이터 모델로 다시 로드할 수 있습니다.

Power Query 편집기에서 쿼리 로드

Power Query 편집기에서 다음 중 하나를 수행합니다.

  • 워크시트에 로드하려면 >닫기 & 로드> 닫기 & 로드를 선택합니다.

  • 데이터 모델에 로드하려면 >닫기 & 로드>닫기 & 로드 대상을 선택합니다.

    데이터 가져오기 대화 상자에서 데이터 모델에 이 데이터 추가를 선택합니다.

때때로 Load To 명령이 흐리게 표시되거나 비활성화됩니다. 이 문제는 통합 문서에서 처음으로 쿼리를 만들 때 발생할 수 있습니다. 이 경우 로드 &닫기를 선택하고 새 워크시트에서 데이터>쿼리 & 연결>쿼리 탭을 선택하고 쿼리를 마우스 오른쪽 단추로 클릭한 다음 로드 대상을 선택합니다. 또는 Power Query 편집기 리본에서 쿼리>로드를 선택합니다.

쿼리 및 연결 창에서 쿼리 로드

Excel에서 쿼리를 다른 워크시트나 데이터 모델로 로드할 수 있습니다.

  1. Excel에서 데이터>쿼리 & 연결을 선택한 다음 쿼리 탭을 선택합니다.
  2. 쿼리 목록에서 쿼리를 찾고 쿼리를 마우스 오른쪽 단추로 클릭한 다음 로드를 선택합니다. 데이터 가져오기대화 상자가 나타납니다.
  3. 데이터를 가져올 방법을 결정한 후 확인을 선택합니다. 이 대화 상자 사용에 대한 자세한 내용을 보려면 물음표(?)를 선택하세요.

워크시트에서 쿼리 편집

워크시트에 로드된 쿼리를 편집하는 방법에는 여러 가지가 있습니다.

Excel 워크시트의 데이터에서 쿼리 편집

  • 쿼리를 편집하려면 Power Query 편집기에서 이전에 로드한 쿼리를 찾아 데이터에서 셀을 선택한 다음 쿼리>편집을 선택합니다.

쿼리 & 연결 창에서 쿼리 편집

하나의 통합 문서에 많은 쿼리가 있고 빠르게 찾으려는 경우 연결 & 쿼리 창을 사용하는 것이 더 편리할 수 있습니다.

  1. Excel에서 데이터>쿼리 & 연결을 선택한 다음 쿼리 탭을 선택합니다.
  2. 쿼리 목록에서 쿼리를 찾고 쿼리를 마우스 오른쪽 단추로 클릭한 다음 편집을 선택합니다.

쿼리 속성 대화 상자에서 쿼리 편집

  • Excel에서 데이터>데이터 & 연결>쿼리 탭을 선택하고, 쿼리를 마우스 오른쪽 단추로 클릭한 후 속성을 선택한 다음, 속성 대화 상자에서 정의 탭을 선택한 다음, 쿼리 편집을 선택합니다.

쿼리가 있는 워크시트에 있는 경우 데이터>속성을 선택하고 속성 대화 상자에서 정의 탭을 선택한 다음 쿼리 편집을 선택합니다.

데이터 모델에서 테이블의 쿼리 편집

데이터 모델에는 일반적으로 관계로 정렬된 여러 테이블이 포함됩니다. 데이터 모델 쿼리를 로드하려면 로드 명령을 사용하여 데이터 가져오기 대화 상자를 표시한 다음 데이터 모드에 이 데이터 추가l 검사란을 선택합니다. 데이터 모델에 대한 자세한 내용은 통합 문서 데이터 모델에 사용되는 데이터 원본 확인, Excel에서 데이터 모델 만들기여러 표를 사용하여 피벗 테이블 만들기를 참조하세요.

  1. 데이터 모델을 열려면 파워 피벗>관리를 선택합니다.

  2. Power Pivot 창의 아래쪽에서 원하는 테이블의 워크시트 탭을 선택합니다.

    올바른 테이블이 표시되는지 확인합니다. 데이터 모델에는 여러 테이블이 있을 수 있습니다.

  3. 테이블의 이름을 적어 둡니다.

  4. PowerPivot 창을 닫으려면 파일>닫기를 선택합니다. 메모리를 회수하는 데 몇 초 정도 걸릴 수 있습니다.

  5. 속성>쿼리 탭& 데이터> 연결을 선택하고 쿼리를 마우스 오른쪽 단추로 클릭한 다음 편집을 선택합니다.

  6. Power Query 편집기에서 변경을 마쳤으면 파일>닫기 & 로드를 선택합니다.

결과

워크시트의 쿼리와 데이터 모델의 테이블이 업데이트됩니다.

데이터 모델에 쿼리를 로드하는 데 시간이 비정상적으로 오래 걸림

데이터 모델에 쿼리를 로드하는 것이 워크시트에 로드하는 것보다 훨씬 오래 걸리는 경우 파워 쿼리 단계를 검사하여 Contains 연산자를 사용하여 텍스트 열 또는 구조화된 목록을 필터링하는지 확인합니다. 이 작업을 수행하면 Excel에서 각 행에 대한 전체 데이터 집합을 다시 열거합니다. 또한 Excel은 다중 스레드 실행을 효과적으로 사용할 수 없습니다. 이 문제를 해결하려면 같음이나 시작값과 같은 다른 연산자를 사용해 보세요.

Microsoft는 이 문제를 인지하고 있으며 조사 중입니다.

쿼리 로드 옵션 설정

다음과 같이 파워 쿼리를 로드할 수 있습니다.

  • 워크시트로 이동합니다. Power Query 편집기에서 >닫기 & 로드>& 로드 닫기를 선택합니다.

  • 데이터 모델로 가져옵니다. Power Query 편집기에서 >닫기 & 로드> 닫기 & 로드를 선택합니다.

    기본적으로 파워 쿼리는 단일 쿼리를 로드할 때 새 워크시트에 쿼리를 로드하고 여러 쿼리를 데이터 모델에 동시에 로드합니다. 모든 통합 문서 또는 현재 통합 문서의 기본 동작만 변경할 수 있습니다. 이러한 옵션을 설정할 때 파워 쿼리는 워크시트 또는 데이터 모델 데이터 및 주석의 쿼리 결과를 변경하지 않습니다.

    닫기 & 로드를 선택한 후 표시되는 가져오기 대화 상자를 사용하여 쿼리의 기본 설정을 동적으로 재정의할 수도 있습니다.

모든 통합 문서에 적용되는 전역 설정

  1. Power Query 편집기에서 파일>옵션 및 설정>쿼리 옵션을 선택합니다.

  2. 쿼리 옵션 대화 상자의 왼쪽에 있는 전역 섹션에서 데이터 로드를 선택합니다.

  3. 기본 쿼리 로드 설정 섹션에서 다음을 수행합니다.

    • 표준 하중 설정 사용을 선택합니다.
    • 사용자 지정 기본 로드 설정 지정을 선택한 다음 워크시트에 로드 또는 데이터 모델에 로드를 선택하거나 선택 취소합니다.

대화 상자 하단에서 기본값 복원 을 선택하여 편리하게 기본 설정으로 돌아갈 수 있습니다.

현재 통합 문서에만 적용되는 통합 문서 설정

  1. 쿼리 옵션 대화 상자의 왼쪽에 있는 현재 통합 문서 섹션에서 데이터 로드를 선택합니다.

  2. 다음 중 하나 이상을 실행합니다.

    • 형식 검색에서 구조화되지 않은 원본에 대한 열 형식 및 머리글 검색을 선택하거나 선택 취소합니다.

      기본 동작은 이를 감지하는 것입니다. 데이터를 직접 셰이프하려면 이 옵션을 선택 취소합니다.

    • 데이터모델에 처음 추가할 때 테이블 간의 관계 만들기를 관계에서 선택하거나 선택 취소합니다.
      데이터 모델에 로드하기 전에 기본 동작은 관계형 데이터베이스의 외래 키와 같은 테이블 간의 기존 관계를 찾고 데이터와 함께 가져오는 것입니다. 직접 하려면 이 옵션을 선택 취소합니다.

    • 관계에서데이터 모델에 로드된 쿼리를 새로 고칠 때 관계 업데이트를 선택하거나 선택 취소합니다.

      기본 동작은 관계를 업데이트하지 않는 것입니다. 데이터 모델에 이미 로드된 쿼리를 새로 고칠 때 파워 쿼리는 관계형 데이터베이스의 외래 키와 같은 테이블 간의 기존 관계를 찾아 업데이트합니다. 그러면 데이터를 가져온 후 수동으로 만든 관계가 제거되거나 새 관계가 발생할 수 있습니다. 그러나 이 작업을 수행하려면 옵션을 선택합니다.

    • 백그라운드 데이터에서 데이터 미리 보기가 백그라운드에서 다운로드할 수 있도록 허용을 선택하거나 선택 취소합니다.

      기본 동작은 백그라운드에서 데이터 미리 보기를 다운로드하는 것입니다. 모든 데이터를 바로 보려면 이 옵션을 선택 취소합니다.

참고 항목

Excel용 파워 쿼리 도움말

Excel에서 쿼리 관리