데이터 옵션 대화 상자에서 피벗 테이블 기본값, 데이터 모델 동작, 추가 기능, 성능 설정, 레거시 가져오기 마법사 액세스와 같은 Excel의 데이터 가져오기 및 분석 옵션을 수정합니다.
Excel에서 데이터 요구 사항에 더 잘 맞도록 가져오기 및 분석 중에 들어오는 데이터(예: 숫자, 날짜 및 형식)를 자동으로 변환하는 방법을 제어할 수도 있습니다.
파일>옵션>데이터를 선택하여 이러한 옵션을 찾습니다.
데이터 옵션
-
피벗 테이블의 기본 레이아웃 변경
새 피벗 테이블의 여러 기본 레이아웃 옵션 중에서 선택합니다. 예를 들어 항상 압축 대신 테이블 형식에서 새 피벗 테이블을 만들도록 하거나 업데이트 시 열 너비 자동 맞춤을 끄도록 선택할 수 있습니다. -
큰 피벗 테이블 새로 고침 작업에 대한 실행 취소를 사용하지 않도록 설정하여 새로 고침 시간 단축
실행 취소를 사용하지 않도록 선택하는 경우 행 수를 실행 취소할 시기에 대한 임계값으로 선택합니다. 기본값은 300,000행입니다. -
피벗 테이블, 쿼리 테이블, 데이터 연결을 만들 때 Excel 데이터 모델 선호
데이터 모델은 여러 테이블의 데이터를 통합하여 Excel 통합 문서 내에 관계형 데이터 원본을 효과적으로 빌드합니다. -
대규모 데이터 모델 작업에 대한 실행 취소를 사용하지 않도록 설정합니다.
실행 취소를 사용하지 않도록 선택하는 경우 파일 크기의 메가바이트 수를 사용하지 않도록 설정할 임계값으로 선택합니다. 기본값은 8MB입니다. -
데이터 분석 추가 기능 사용: 파워 피벗, 파워 뷰 및 3D 맵.
추가 기능 탭 대신 여기에서 데이터 분석 추가 기능을 사용하도록 설정합니다. -
피벗 테이블에서 날짜/시간 열의 자동 그룹화를 사용하지 않도록 설정합니다.
기본적으로 날짜 및 시간 열은 옆에 + 기호가 붙어 그룹화됩니다. 이 설정은 해당 기본값을 사용하지 않도록 설정합니다.
레거시 데이터 가져오기 마법사 표시
리본의 데이터 탭을 통해 사용할 수 있는 파워 쿼리은 레거시 데이터 가져오기 마법사에 비해 보다 현대적인 데이터 커넥터 및 변환 기능을 제공합니다. 그러나 이러한 마법사 중 하나를 사용하여 데이터를 가져오려는 경우도 있을 수 있습니다. 예를 들어 데이터 원본 인증 자격 증명을 통합 문서의 일부로 저장하려는 경우입니다.
보안 자격 증명을 저장하는 경우 보안 및 개인 정보 문제 또는 손상된 데이터가 발생할 수 있으므로 이를 권장하지 않습니다.
참고
웹(레거시) 데이터 가져오기 마법사는 더 이상 사용되지 않습니다. 새 웹 쿼리에 파워 쿼리 웹 커넥터를 사용합니다. 이전 웹 쿼리를 파워 쿼리로 이동하려면 이전 웹 쿼리를 파워 쿼리로 이동을 참조하세요.
레거시 데이터 가져오기 마법사 사용
파일> 선택옵션>데이터.
마법사를 하나 이상 선택하여 Excel 리본에서 액세스할 수 있도록 설정합니다.
- Access(레거시)
- 웹(레거시)(사용되지 않음)
- 텍스트(레거시)
- SQL Server(레거시)
- OData 데이터 피드(레거시)
- XML 데이터 가져오기(레거시)
- 데이터 연결 마법사(레거시)
- Microsoft Query(레거시)
통합 문서를 닫았다가 다시 열어 활성화된 마법사를 확인합니다.
데이터>데이터 가져오기>레거시 마법사를 선택한 다음 원하는 마법사를 선택합니다.
1-3단계를 반복하고 2단계에서 설명한 검사란을 선택 취소하면 마법사를 사용하지 않도록 설정할 수 있습니다.
자동 데이터 변환
Excel에 텍스트를 입력, 붙여넣기 또는 로드할 때 모든 기본 데이터 변환을 사용하도록 설정합니다. 이 상자의 선택을 취소하고 다음 옵션 중 하나 이상을 선택합니다.
- 앞에 오는 0을 제거하고 숫자로 변환 숫자 데이터를 숫자로 변환하여 선행 0을 잃는 대신 선행 0을 텍스트로 저장하고 선행 0을 유지하려면 이 옵션을 사용하지 않도록 설정합니다. 예를 들어 00123 은 텍스트에서 00123 으로 유지되고 숫자 123으로 변환되지 않습니다.
- 긴 숫자의 처음 15자리를 유지하고 과학적 표기법으로 표시 처음 15자리만 유지하고 과학적 표기법으로 표시할 수 있는 숫자로 변환하는 대신 16자리 이상의 숫자 데이터를 텍스트로 저장하고 모든 숫자를 유지하려면 이 옵션을 사용하지 않도록 설정합니다. 예를 들어 12345678901234567890 는 텍스트에서 12345678901234567890 상태로 유지되며 숫자 12345678901234500000 로 변환되거나 과학적 표기법으로 1.23457E+19로 표시되지 않습니다.
- 문자 "E"를 묶은 숫자를 과학적 표기법으로 변환 문자 "E"를 둘러싼 숫자 데이터를 과학적 표기법으로 숫자로 변환하는 대신 텍스트로 저장하려면 이 옵션을 사용하지 않도록 설정합니다. 예를 들어 123E5 는 텍스트에서 123E5 로 유지되며, 과학적 표기법에서는 숫자 1.23E+07 로 변환되지 않습니다.
- 연속된 문자와 숫자를 날짜로 변환 날짜로 변환하는 대신 연속된 문자와 숫자가 있는 "날짜와 유사한" 값을 텍스트로 저장하려면 이 옵션을 사용하지 않도록 설정합니다. 예를 들어 JAN1은 텍스트에서 JAN1로 유지되며 1월 1일로 변환되지 않습니다. JAN 1 또는 JAN-1과 같이 공백이나 기타 문자가 포함된 데이터도 여전히 날짜로 처리될 수 있습니다.
추가 옵션
.csv 파일 또는 유사한 파일을 로드할 때 자동 데이터 변환에 대해 알림 어떤 데이터 변환이 발생할지 나타내는 대화 상자의 표시를 중지하려면 이 옵션을 사용하지 않도록 설정합니다. 기본적으로 대화 상자가 표시됩니다. 그러나 이전 옵션을 모두 사용하지 않도록 설정하면 대화 상자도 표시되지 않습니다.