Windows Server 2008 Hyper-v VMMS 인증서가 만료 된 경우 가상 컴퓨터에 연결할 수 없음

적용 대상: Windows Server 2008 StandardWindows Server 2008 EnterpriseWindows Server 2008 Datacenter

증상


Hyper-v 역할이 설치 된 Windows Server 2008 기반 컴퓨터 또는 Microsoft Hyper-v Server 2008 기반 컴퓨터에서 다음 문제 중 하나가 발생할 수 있습니다.
  • 가상 컴퓨터에 연결 하려고 하면 다음 오류 메시지가 나타납니다.
    인증 인증서가 만료 되었거나 잘못 되어 가상 컴퓨터에 연결할 수 없습니다. 연결을 다시 시도 하 시겠습니까?
  • 가상 컴퓨터를 시작 하면 다음 오류 메시지가 나타납니다.
    ' VMName '을 (를) 초기화 하지 못했습니다. Machine remoting system을 초기화할 수 없습니다. 오류: ' 알 수 없는 오류 ' (0x80004005). 사용 가능한 인증서를 찾을 수 없습니다. 오류: ' 알 수 없는 오류 ' (0x80004005).

원인


이 문제는 Hyper-v 가상 컴퓨터 관리 서비스 (VMMS) 인증서가 만료 되었기 때문에 발생 합니다.

해결 방법


서비스 팩 정보

이 문제를 해결 하려면 Windows Server 2008의 최신 서비스 팩을 구하십시오. 자세한 내용은 다음 문서 번호를 클릭 하 여 Microsoft 기술 자료 문서를 참조 하세요.
968849 Windows Server 2008용 최신 서비스 팩을 구하는 방법  

업데이트 정보

Microsoft 다운로드 센터에서 다음 파일을 다운로드할 수 있습니다. Windows Server 2008 x64 Edition (KB967902) Download 업데이트 지금 967902 패키지를 다운로드 합니다. Microsoft 지원 파일을 다운로드 하는 방법에 대 한 자세한 내용은 다음 문서 번호를 클릭 하 여 Microsoft 기술 자료 문서를 참조 하세요.
119591 온라인 서비스로부터 Microsoft 지원 파일을 구하는 방법
Microsoft에서이 파일을 바이러스에 검사 했습니다. Microsoft는 파일이 게시 된 날짜에 사용할 수 있는 최신 바이러스 검색 소프트웨어를 사용 했습니다. 이 파일은 해당 파일을 무단으로 변경할 수 없는 보안이 향상된 서버에 보관됩니다.

전제 조건

이 업데이트를 적용 하기 전에 Hyper-v의 릴리스 버전을 설치 해야 합니다. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
950050 Windows Server 2008의 Hyper-v 기술 릴리스 버전 업데이트에 대 한 설명

다시 시작 요구 사항

이 업데이트를 적용 한 후에는 컴퓨터를 다시 시작 해야 합니다.

업데이트 대체 정보

이 업데이트는 다른 업데이트를 대체 하지 않습니다.

파일 정보

이 업데이트의 영어 버전은 다음 표에 나열 된 파일 특성 (또는 최신 파일 특성)을 갖습니다. 해당 파일의 날짜와 시간은 UTC(협정 세계시)로 표시됩니다. 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 현지 시간의 차이를 알려면 제어판의 날짜 및 시간 항목에서 표준 시간대 탭을 사용하십시오.

Windows Server 2008 참고

각 환경에 설치 된 .manifest 파일과 엄마 파일은 "Windows Server 2008에 대 한 추가 파일 정보" 섹션에 별도로 나열 됩니다. 이러한 파일 및 관련 .cat (보안 카탈로그) 파일은 업데이트 된 구성 요소의 상태를 유지 관리 하는 데 중요 합니다. .Cat 파일은 Microsoft 디지털 서명으로 서명 됩니다. 이러한 보안 파일의 특성은 나열 되지 않습니다.지원 되는 모든 x64 기반 버전의 Windows Server 2008
파일 이름파일 버전파일 크기날짜시간플랫폼
Vmms.exe6.0.6001.22383387840021-Feb-200906:17x64
Vmwp.exe6.0.6001.22383352614421-Feb-200906:17x64
또한이 핫픽스에는 지원 되는 모든 x64 기반 버전의 Windows Server 2008에 대 한 GDR 버전이 포함 되어 있습니다.
파일 이름파일 버전파일 크기날짜시간플랫폼
Vmms.exe6.0.6001.18221387881621-Feb-200905:06x64
Vmwp.exe6.0.6001.18221352612021-Feb-200905:06x64
이 업데이트를 설치한 후 Hyper-v VMMS 인증서가 만료 되 면 자동으로 갱신할 수 있습니다.

해결 방법


이 문제를 해결 하려면 새 인증서를 생성 하면 됩니다. 이렇게 하려면 다음 단계를 수행하세요.
  1. 모든 가상 컴퓨터를 종료 하거나 저장 합니다.
  2. Hyper-v VMMS를 다시 시작 합니다.
  3. 가상 컴퓨터를 시작 합니다.
참고 Hyper-v VMMS 인증서가 1 년 동안 유효 하기 때문에이 문제가 향후에 발생 하는 것을 방지 하기 위해 업데이트를 적용 해야 합니다.

상태


Microsoft는 "적용 대상" 절에 나열한 제품에서 이 문제를 확인했습니다.

추가 정보


Hyper-v VMM 서비스 자체 서명 된 인증서의 만료 날짜를 확인 하려면 다음 단계를 따릅니다.
  1. 시작 , 실행 을 차례로 클릭 하 고 Mmc 를 입력 한 다음 확인을 클릭 합니다.
  2. 파일 메뉴에서 스냅인 추가/제거를 클릭 합니다.
  3. 인증서 를 클릭 한 다음 추가를 클릭 합니다.
  4. 서비스 계정을 클릭 하 고 다음을 클릭 합니다.
  5. 로컬 컴퓨터 를 클릭 하 고 다음을 클릭 합니다.
  6. Hyper-v 가상 컴퓨터 관리 를 클릭 한 다음 마침을클릭 합니다.
  7. 확인 을 클릭 하 여 스냅인 추가/제거 창을 닫습니다.
  8. 인증서-서비스, Vmms\Personal를 차례로 확장 한 다음 인증서를 클릭 합니다.
  9. VMM 서비스 인증서를 두 번 클릭 하 고 VMM 서비스 인증서 창에서 만료 날짜를 확인 합니다.
소프트웨어 업데이트 용어에 대 한 자세한 내용은 다음 문서 번호를 클릭 하 여 Microsoft 기술 자료 문서를 참조 하세요.
824684 Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명

Windows Server 2008에 대 한 추가 파일 정보

지원 되는 모든 x64 기반 버전의 Windows Server 2008에 대 한 추가 파일
파일 이름파일 버전파일 크기날짜시간플랫폼
Amd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.0.6001.22383_none_92eac53930a5ec97.manifestNot Applicable24972321-Feb-200906:38Not Applicable
Amd64_microsoft-hyper-v-vstack-vmwp_31bf3856ad364e35_6.0.6001.22383_none_91954bdf3181df4c.manifestNot Applicable19258721-Feb-200906:37Not Applicable
Package_for_kb967902_sc_0_bf~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,50521-Feb-200914:39Not Applicable
Package_for_kb967902_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable152921-Feb-200914:38Not Applicable
Package_for_kb967902_sc_bf~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable141121-Feb-200914:39Not Applicable
Package_for_kb967902_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43121-Feb-200914:38Not Applicable
Package_for_kb967902_server_0_bf~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable150921-Feb-200914:39Not Applicable
Package_for_kb967902_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,53221-Feb-200914:38Not Applicable
Package_for_kb967902_server_bf~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable141921-Feb-200914:39Not Applicable
Package_for_kb967902_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43921-Feb-200914:38Not Applicable
Update-bf.mumNot Applicable177121-Feb-200914:39Not Applicable